Update to 0.40.91 snapshot, by Greg Troxel via pkgsrc-wip.
NEWS since guile-gtk-1.2-0.31 * Guile-gtk-1.2 is now part of the GNU Project. * Drag'n'Drop support - see examples/test-dnd.scm * GdkPixbuf bindings. Formerly these bindings were part of guile-gnome, unfortunately they were far from compelete, moreover they were not working at all. Now there are full GdkPixbuf bindings in the (gtk-1.2 gdk-pixbuf) module. * LibGlade bindings (formerly part of gnome-guile). Imported from gnome-guile, completed and improved. Now it is possible to autoconnect scheme functions and build a guile-gtk (glade) application in three commands - see examples/test-glade.scm and the little bit longer examples/run-glade.scm. You can find libGlade bindings in the (gtk-1.2 glade) module. * GtkGLArea bindings (formerly part of guileGL). Imported from guileGL, completed and improved. (gtk-1.2 gdk-gl) module provides bindings for Gdk part of GtkGLArea library (GdkGLContext, GdkGLPixmap etc), (gtk-1.2 gtk-gl-area) has bindings for GtkGLArea functions. * configure script has options --with-gdk-pixbuf, --with-glade and --with-gtkgl. Just in case you would like to turn off these new nifty features. * build-guile-gtk-1.2 supports functions with arbitrary number of required arguments. * GtkPixmap bindings closely reflects C API, helper function gtk-pixmap-new-from-file implements old behaviour. GtkPixmap bindings are complete. * Lots of additional bindings, especially for Gdk. NEWS in guile-gtk-1.2-0.31 * Bug fixes. NEWS in guile-gtk-1.2-0.30 * Support for Gnome and Gtk+-2.0 has been removed. The modules have been renamed from (gtk ...) to (gtk-1.2 ...). They are still available under their old names, but the new ones are preferred. Likewise, build-guile-gtk has been renamed to build-guile-gtk-1.2, with the old name still available but deprecated. Building new programs with "build-guile-gtk main" is no longer supported; only shared libraries are. Consequently, the guile-gtk program is no longer provided. NEWS in 0.20 * New `cname' option for field specifiers. You can now specify what name to use on the C side for field accessors. For example, to access the allocation.x subfield of a GtkWidget structure, you can use (fields (int allocation-x (cname allocation.x))) The value of the option can be either a symbol or a string. * New cstring type added to deal with const char *str declarations. * Guile-gtk will now start the usual `top-repl' of Guile. The processing of Gtk events will happen in a separate handler thread. When your Guile doesn't support threading, you get the old event driven repl. * `gdk-event-button-state' and `gdk-event-key-state' have been replaced by `gdk-event-state'. The new function will return a GtkModifierType which is a list of symbol such as (shift-mask control-mask) * Automatic *.h->*defs translator * Threads support * Experimental GTK+ 2.0 support * RPM spec file corrected * Lots of additions and corrections to the *.defs files * Various bug fixes
This commit is contained in:
parent
ac4a3e9bc4
commit
be9ba77985
6 changed files with 51 additions and 52 deletions
|
@ -1,7 +1,7 @@
|
|||
Guile-gtk is a library written to make GTK accessible from guile.
|
||||
It provides a convenient interface for Scheme programmers to develop
|
||||
visual applications. It can also integrate with GNOME via the
|
||||
Gnome-guile module.
|
||||
Guile-gtk is a library written to make GTK 1.2 accessible from
|
||||
guile. It provides a convenient interface for Scheme programmers to
|
||||
develop visual applications. It can also integrate with GNOME via the
|
||||
Gnome-guile module. (For glib2, see guile-gobject instead.)
|
||||
|
||||
Guile-gtk was started by Marius Vollmer <mvo@zagadka.ping.de> and
|
||||
is currently maintained by Ariel Rios <jarios@usa.net> and other
|
||||
|
|
|
@ -1,27 +1,29 @@
|
|||
# $NetBSD: Makefile,v 1.20 2004/11/13 21:28:28 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.21 2004/12/03 15:28:33 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= guile-gtk-0.19
|
||||
PKGREVISION= 6
|
||||
DISTNAME= guile-gtk-0.40.91
|
||||
CATEGORIES= devel x11
|
||||
MASTER_SITES= http://www.ping.de/sites/zagadka/guile-gtk/download/ \
|
||||
http://erin.netpedia.net/download/ \
|
||||
http://erin.linuxbox.com/guile-gtk/download/ \
|
||||
http://linux.cem.itesm.mx/~jarios/guile-gtk/download/
|
||||
MASTER_SITES= http://www.ir.bbn.com/~gdt/pkgsrc-wip/
|
||||
|
||||
MAINTAINER= rh@NetBSD.org
|
||||
HOMEPAGE= http://www.ping.de/sites/zagadka/guile-gtk/
|
||||
COMMENT= Library to make GTK accessible from guile
|
||||
MAINTAINER= gdt@ir.bbn.com
|
||||
HOMEPAGE= http://www.gnu.org/software/guile-gtk/
|
||||
COMMENT= Library to make GTK 1.2 accessible from guile
|
||||
|
||||
USE_BUILDLINK3= yes
|
||||
USE_BUILDLINK3= # defined
|
||||
USE_X11= # defined
|
||||
USE_LIBTOOL= # defined
|
||||
|
||||
GNU_CONFIGURE= # defined
|
||||
CONFIGURE_ARGS+= --datadir=${PREFIX}/${GUILE14_SUBDIR}/share
|
||||
PLIST_SUBST+= GUILE14_SUBDIR=${GUILE14_SUBDIR:Q}
|
||||
MAKE_ENV+= MACHINE_ARCH=${MACHINE_ARCH}
|
||||
|
||||
.include "../../lang/guile14/buildlink3.mk"
|
||||
# Skip glade, because it pulls in gnome-libs.
|
||||
# Later, make a new package for just the glade parts,
|
||||
# or a BUILD_DEF.
|
||||
# glade-config may be in ${LOCALBASE}/bin, so force not using it.
|
||||
CONFIGURE_ARGS+= --without-glade
|
||||
|
||||
# .include "../../devel/libglade/buildlink3.mk"
|
||||
.include "../../lang/guile/buildlink3.mk"
|
||||
.include "../../x11/gtk/buildlink3.mk"
|
||||
.include "../../graphics/gdk-pixbuf/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,19 +1,26 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2004/09/22 08:09:26 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2004/12/03 15:28:33 wiz Exp $
|
||||
bin/build-guile-gtk
|
||||
bin/guile-gtk
|
||||
bin/guile-gtk-1.2
|
||||
bin/build-guile-gtk-1.2
|
||||
include/guile-gtk.h
|
||||
info/guile-gtk.info
|
||||
lib/libguilegdkpixbuf-1.2.la
|
||||
lib/libguilegtk-1.2.la
|
||||
${GUILE14_SUBDIR}/share/guile-gtk/gdk-1.2.defs
|
||||
${GUILE14_SUBDIR}/share/guile-gtk/gtk-1.2.defs
|
||||
${GUILE14_SUBDIR}/share/guile/gtk-1.2/gdk.scm
|
||||
${GUILE14_SUBDIR}/share/guile/gtk-1.2/gtk.scm
|
||||
${GUILE14_SUBDIR}/share/guile/gtk/config.scm
|
||||
${GUILE14_SUBDIR}/share/guile/gtk/dynlink-old.scm
|
||||
${GUILE14_SUBDIR}/share/guile/gtk/dynlink.scm
|
||||
${GUILE14_SUBDIR}/share/guile/gtk/event-repl.scm
|
||||
${GUILE14_SUBDIR}/share/guile/gtk/gdk.scm
|
||||
${GUILE14_SUBDIR}/share/guile/gtk/gtk.scm
|
||||
@dirrm ${GUILE14_SUBDIR}/share/guile/gtk
|
||||
@dirrm ${GUILE14_SUBDIR}/share/guile/gtk-1.2
|
||||
@dirrm ${GUILE14_SUBDIR}/share/guile-gtk
|
||||
share/guile-gtk/gdk-1.2.defs
|
||||
share/guile-gtk/gdk-pixbuf.defs
|
||||
share/guile-gtk/gtk-1.2.defs
|
||||
share/guile/gtk-1.2/config.scm
|
||||
share/guile/gtk-1.2/dynlink.scm
|
||||
share/guile/gtk-1.2/gdk-pixbuf.scm
|
||||
share/guile/gtk-1.2/gdk.scm
|
||||
share/guile/gtk-1.2/gtk.scm
|
||||
share/guile/gtk-1.2/repl.scm
|
||||
share/guile/gtk-1.2/threads.scm
|
||||
share/guile/gtk/config.scm
|
||||
share/guile/gtk/dynlink.scm
|
||||
share/guile/gtk/gdk.scm
|
||||
share/guile/gtk/gtk.scm
|
||||
share/guile/gtk/repl.scm
|
||||
share/guile/gtk/threads.scm
|
||||
@dirrm share/guile/gtk-1.2
|
||||
@dirrm share/guile/gtk
|
||||
@dirrm share/guile-gtk
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.2 2004/10/03 00:13:28 tv Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.3 2004/12/03 15:28:33 wiz Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
GUILE_GTK_BUILDLINK3_MK:= ${GUILE_GTK_BUILDLINK3_MK}+
|
||||
|
@ -11,12 +11,11 @@ BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nguile-gtk}
|
|||
BUILDLINK_PACKAGES+= guile-gtk
|
||||
|
||||
.if !empty(GUILE_GTK_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_DEPENDS.guile-gtk+= guile-gtk>=0.19nb4
|
||||
BUILDLINK_RECOMMENDED.guile-gtk+= guile-gtk>=0.19nb5
|
||||
BUILDLINK_DEPENDS.guile-gtk+= guile-gtk>=0.40
|
||||
BUILDLINK_PKGSRCDIR.guile-gtk?= ../../devel/guile-gtk
|
||||
.endif # GUILE_GTK_BUILDLINK3_MK
|
||||
|
||||
.include "../../lang/guile14/buildlink3.mk"
|
||||
.include "../../lang/guile/buildlink3.mk"
|
||||
.include "../../x11/gtk/buildlink3.mk"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.4 2003/02/05 21:35:06 dmcmahill Exp $
|
||||
$NetBSD: distinfo,v 1.5 2004/12/03 15:28:33 wiz Exp $
|
||||
|
||||
SHA1 (guile-gtk-0.19.tar.gz) = 22e445fb0574cee76c0d18dbdc28090b63b88302
|
||||
Size (guile-gtk-0.19.tar.gz) = 278896 bytes
|
||||
SHA1 (patch-aa) = 54753539855280704593b9ee7da330ec6934bfdf
|
||||
SHA1 (guile-gtk-0.40.91.tar.gz) = 9044067d0ff4e745167c38325cd41dbc47e9c483
|
||||
Size (guile-gtk-0.40.91.tar.gz) = 708183 bytes
|
||||
SHA1 (patch-aa) = f3f6e47727ea7429c671fe02d2a93e8e962e920b
|
||||
|
|
|
@ -1,16 +1,7 @@
|
|||
$NetBSD: patch-aa,v 1.6 2003/02/05 21:35:07 dmcmahill Exp $
|
||||
$NetBSD: patch-aa,v 1.7 2004/12/03 15:28:33 wiz Exp $
|
||||
|
||||
--- Makefile.in.orig Wed Jul 26 19:24:58 2000
|
||||
+++ Makefile.in
|
||||
@@ -617,7 +617,7 @@ install-data-local:
|
||||
$(INSTALL_DATA) ./gtk/config.scm $(gtkmoduledir)/config.scm
|
||||
$(INSTALL_DATA) $(srcdir)/gtk/event-repl.scm $(gtkmoduledir)/event-repl.scm
|
||||
.c.x:
|
||||
- guile-snarf $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< >$<.tmp && mv $<.tmp $@
|
||||
+ guile-snarf $< $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) >$<.tmp && mv $<.tmp $@
|
||||
|
||||
gtk-glue.c: $(gtkdefs) $(gdkdefs) build-guile-gtk
|
||||
$(BUILD) -I $(srcdir) glue $(gtkdefs) >tmpt && mv tmpt $@
|
||||
@@ -641,3 +641,20 @@ dist-hook:
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
|
|
Loading…
Reference in a new issue