Avoid the need for -lcompat; should fix Solaris build. PKGREVISION -> 3.
This commit is contained in:
parent
c2cc11912c
commit
bebb8ce5ca
3 changed files with 43 additions and 12 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.15 2010/02/04 01:48:01 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2012/06/23 21:45:24 dholland Exp $
|
||||
|
||||
DISTNAME= coolmail-1.3
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= mail x11
|
||||
MASTER_SITES= ${MASTER_SITE_SUNSITE:=system/mail/biffs/}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -12,13 +12,10 @@ COMMENT= Xbiff replacement with 3D animation and sound
|
|||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
OPSYSVARS+= EXTRA_LIBS
|
||||
EXTRA_LIBS.*= -lcompat
|
||||
EXTRA_LIBS.Interix= -lSM
|
||||
EXTRA_LIBS.IRIX= # empty
|
||||
MAKE_ENV+= EXTRA_LIBS=${EXTRA_LIBS:Q}
|
||||
MAKE_ENV+= X11BASE=${PREFIX:Q}
|
||||
USE_X11BASE= yes
|
||||
|
||||
MAKE_ENV+= X11BASE=${PREFIX:Q}
|
||||
INSTALLATION_DIRS= bin lib/X11/app-defaults ${PKGMANDIR}/man1
|
||||
|
||||
post-install:
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.7 2010/02/04 01:48:01 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.8 2012/06/23 21:45:24 dholland Exp $
|
||||
|
||||
SHA1 (coolmail-1.3.tgz) = 7b8dccf16f575827a595f1025294dfc66f00a6dc
|
||||
RMD160 (coolmail-1.3.tgz) = e23a8e8a465d700163393e70ebed60870ddcbc95
|
||||
Size (coolmail-1.3.tgz) = 26809 bytes
|
||||
SHA1 (patch-aa) = dd16e3150674a92f4ad43270d523bbc1f5b5eb16
|
||||
SHA1 (patch-ab) = 35879a8f39e83e47b1598b761adcfa412d6b3104
|
||||
SHA1 (patch-ab) = 5734f1f7e57f59db437996c192b98c24b4356009
|
||||
SHA1 (patch-ac) = 1054bda16101047024e2f6811034cfdc4d340a66
|
||||
|
|
|
@ -1,9 +1,43 @@
|
|||
$NetBSD: patch-ab,v 1.2 1998/08/07 11:09:29 agc Exp $
|
||||
$NetBSD: patch-ab,v 1.3 2012/06/23 21:45:24 dholland Exp $
|
||||
|
||||
--- coolmail.c.orig Thu Jul 16 05:09:10 1998
|
||||
+++ coolmail.c Thu Jul 16 05:11:28 1998
|
||||
@@ -36,3 +36,3 @@
|
||||
- use standard headers
|
||||
- use /var/mail as the default mail dir (XXX: shouldn't this be fed in
|
||||
from pkgsrc somewhere?)
|
||||
- use getlogin(), not cuserid().
|
||||
|
||||
--- coolmail.c.orig 1996-01-11 17:57:24.000000000 +0000
|
||||
+++ coolmail.c
|
||||
@@ -18,6 +18,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
#include <math.h>
|
||||
#include <assert.h>
|
||||
#include <signal.h>
|
||||
@@ -34,7 +35,7 @@
|
||||
#include "render1.h"
|
||||
#include "mailbox.h"
|
||||
|
||||
-#define DEFAULT_MAIL_DIR "/var/spool/mail/"
|
||||
+#define DEFAULT_MAIL_DIR "/var/mail/"
|
||||
#define DEFAULT_COMMAND "xterm -n Elm -e mail\0"
|
||||
#define DEFAULT_INTERVAL 30
|
||||
#define DEFAULT_FRAMES 15
|
||||
@@ -96,7 +97,6 @@ void cool_usage(void);
|
||||
int main(int argc, char *argv[])
|
||||
{
|
||||
int reason;
|
||||
- char username[L_cuserid];
|
||||
|
||||
/* Quickly scan for the -h option -- if it is present don't do anything
|
||||
* but print out some help and exit. */
|
||||
@@ -104,7 +104,7 @@ int main(int argc, char *argv[])
|
||||
return(0);
|
||||
|
||||
/* Get the username and use it to create a default mailfile name */
|
||||
- strcat(mailfile_str, cuserid(username));
|
||||
+ strcat(mailfile_str, getlogin());
|
||||
|
||||
/* Initialize the renderer */
|
||||
rend_init(&argc, argv, (float)150.0);
|
||||
|
|
Loading…
Reference in a new issue