ladspa: Split out compilation targets to hopefully fix bulk builds.

This commit is contained in:
nia 2019-07-20 19:45:57 +00:00
parent 6b288a30e3
commit bed3ef5cd2
2 changed files with 23 additions and 13 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.14 2019/07/15 22:58:50 nia Exp $
$NetBSD: distinfo,v 1.15 2019/07/20 19:45:57 nia Exp $
SHA1 (ladspa_sdk_1.13.tgz) = 2b69e28afb62c0d97943124f48ed82de796f83ed
RMD160 (ladspa_sdk_1.13.tgz) = e9eeae8edd24a6890fac3e34c4b55f844f44f8a0
SHA512 (ladspa_sdk_1.13.tgz) = a1dab807fda58e08869d3f519be5fa91c394690eb13006fbe7f20b332548e4676b32b01273f5695bf36c8da72190c07618662a76d50f991b3f05068ac2b346ef
Size (ladspa_sdk_1.13.tgz) = 70540 bytes
SHA1 (patch-aa) = 32adf919fe4194e5cc747a27f12047d6b8c66d00
SHA1 (patch-aa) = c233427fd90b701841f113bd980e7538cb4b2b62
SHA1 (patch-ab) = 1357f25ef53c24c737a4888ba7d01fb724a3f315
SHA1 (patch-ac) = 40108e5e4fdba9b2be322d0de532a97322d22325
SHA1 (patch-plugins_amp.c) = e0336ff7fe078aa6b4e6b3d25b21b70ac6dc127d

View file

@ -1,4 +1,4 @@
$NetBSD: patch-aa,v 1.8 2019/07/15 22:58:50 nia Exp $
$NetBSD: patch-aa,v 1.9 2019/07/20 19:45:57 nia Exp $
* Fix the destination directories
* Use cc(1) to link the plug-ins
@ -63,7 +63,7 @@ $NetBSD: patch-aa,v 1.8 2019/07/15 22:58:50 nia Exp $
###############################################################################
#
@@ -50,39 +51,39 @@ test: /tmp/test.wav ../snd/noise.wav alw
@@ -50,59 +51,71 @@ test: /tmp/test.wav ../snd/noise.wav alw
@echo ---------------------------------------------
@echo First listen to the white noise input signal:
@echo ---------------------------------------------
@ -129,33 +129,43 @@ $NetBSD: patch-aa,v 1.8 2019/07/15 22:58:50 nia Exp $
###############################################################################
#
@@ -90,19 +91,21 @@ targets: $(PLUGINS) $(PROGRAMS)
# PROGRAMS
#
+default.o:
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c default.c
+
+load.o:
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c load.c
+
+applyplugin.o:
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c applyplugin.c
+
+analyseplugin.o:
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c analyseplugin.c
+
+listplugins.o:
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c listplugins.c
+
+search.o:
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c search.c
+
../bin/applyplugin: applyplugin.o load.o default.o
- $(CC) $(CFLAGS) $(LIBRARIES) \
- -o ../bin/applyplugin \
- applyplugin.o load.o default.o
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c applyplugin.c
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c load.c
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c default.c
+ ${LIBTOOL} --tag=CC --mode=link $(CC) $(LOCAL_LDFLAGS) -o $@ $(^:.o=.lo) $(LIBRARIES) \
../bin/analyseplugin: analyseplugin.o load.o default.o
- $(CC) $(CFLAGS) $(LIBRARIES) \
- -o ../bin/analyseplugin \
- analyseplugin.o load.o default.o
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c analyseplugin.c
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c load.c
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c default.c
+ ${LIBTOOL} --tag=CC --mode=link $(CC) $(LOCAL_LDFLAGS) -o $@ $(^:.o=.lo) $(LIBRARIES)
../bin/listplugins: listplugins.o search.o
- $(CC) $(CFLAGS) $(LIBRARIES) \
- -o ../bin/listplugins \
- listplugins.o search.o
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c listplugins.c
+ ${LIBTOOL} --tag=CC --mode=compile $(CC) -c search.c
+ ${LIBTOOL} --tag=CC --mode=link $(CC) $(LOCAL_LDFLAGS) -o $@ $(^:.o=.lo) $(LIBRARIES)
###############################################################################