* Strongly buildinkify.
* Manage all of the icon directories for all of the KDE2 packages in the PLIST. * Workaround a NetBSD/alpha egcs optimization bug. * Allow artsdsp pre-loadable module to be built. * Fix pkg/14430 by Mark Davies <mark@mcs.vuw.ac.nz> where mounting devices from KDE2 when /sbin isn't in your path doesn't work because mount/umount can't be found. We append /sbin:/usr/sbin to the path before calling mount/umount. * Properly recognize that NetBSD's OSS implementation doesn't include the Linux MIDI interface. * Fix and sort PLIST.
This commit is contained in:
parent
5e85458d08
commit
befb2d2650
8 changed files with 241 additions and 84 deletions
|
@ -1,55 +1,93 @@
|
|||
# $NetBSD: Makefile,v 1.18 2001/10/26 13:57:59 skrll Exp $
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.19 2001/11/13 21:09:07 jlam Exp $
|
||||
|
||||
DISTNAME= kdelibs-2.2.1
|
||||
CATEGORIES= x11 kde
|
||||
.include "../../x11/kde2/Makefile.part1"
|
||||
CATEGORIES= x11
|
||||
COMMENT= Support libraries for the KDE integrated X11 desktop
|
||||
|
||||
#DEPENDS+= jade>=1.2.1:../../textproc/jade
|
||||
USE_BUILDLINK_ONLY= yes
|
||||
USE_PERL= yes
|
||||
.include "../../x11/kde2/Makefile.kde2"
|
||||
|
||||
.include "../../x11/kde2/Makefile.part2"
|
||||
|
||||
LTCONFIG_OVERRIDE+= ${WRKSRC}/ksgmltools/ltconfig
|
||||
#DEPENDS+= jade>=1.2.1:../../textproc/jade
|
||||
BUILDLINK_DEPENDS.audiofile= libaudiofile>=0.1.9
|
||||
|
||||
USE_BUILDLINK_ONLY= YES
|
||||
USE_PERL5= YES
|
||||
USE_OPENSSL_VERSION= ${OPENSSL_VERSION_096}
|
||||
|
||||
CONFIGURE_ARGS+= --with-ssl-dir="${BUILDLINK_DIR}"
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
CONFIGURE_ARGS+= --with-ssl-dir="${BUILDLINK_DIR}"
|
||||
CONFIGURE_ENV+= USER_LDFLAGS="${USER_LDFLAGS}"
|
||||
.if ${OPSYS} == "NetBSD"
|
||||
LIBS+= -Wl,--export-dynamic
|
||||
USER_LDFLAGS= -L${BUILDLINK_DIR}/lib
|
||||
USER_LDFLAGS+= -Wl,-R${LOCALBASE}/lib
|
||||
USER_LDFLAGS+= -Wl,-R${X11BASE}/lib
|
||||
.endif
|
||||
|
||||
MKDIRS= \
|
||||
share/kde/icons/hicolor/22x22/mimetypes \
|
||||
share/kde/icons/hicolor/22x22/filesystems
|
||||
# share/kde/icons/locolor/32x32/actions/kde \
|
||||
# share/kde/icons/locolor/22x22/mimetypes \
|
||||
# share/kde/icons/locolor/22x22/filesystems \
|
||||
# share/kde/icons/locolor/22x22/actions/kde \
|
||||
# Override KDE_INCLUDES and QT_INCLUDES at build-time since their values
|
||||
# are used by reference within the kdelibs2 Makefiles
|
||||
#
|
||||
MAKE_FLAGS+= KDE_INCLUDES="-I${BUILDLINK_DIR}/include"
|
||||
MAKE_FLAGS+= QT_INCLUDES="-I${BUILDLINK_QTDIR}/include"
|
||||
|
||||
# The configure script looks for xml2-config in the environment as
|
||||
# ${XML_CONFIG}, not as ${XML2_CONFIG} like it's supposed to.
|
||||
#
|
||||
CONFIGURE_ENV+= XML_CONFIG="${XML2_CONFIG}"
|
||||
|
||||
REPLACE_PERL= \
|
||||
${WRKSRC}/kio/proxytype.pl \
|
||||
${WRKSRC}/kio/useragent.pl
|
||||
|
||||
post-install:
|
||||
for d in ${MKDIRS}; do \
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/$$d; \
|
||||
done
|
||||
PLIST_SRC= ${WRKDIR}/PLIST
|
||||
|
||||
BUILDLINK_DEPENDS.audiofile= libaudiofile>=0.1.9
|
||||
# We will create the complete icon directory tree for use by other KDE2
|
||||
# packages at post-install time.
|
||||
#
|
||||
ICONCOLORS= hicolor locolor
|
||||
ICONSIZES= 16x16 22x22 32x32 48x48 64x64
|
||||
ICONDIRS= actions/kde actions apps devices filesystems mimetypes
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/kde/locale
|
||||
@( ${CAT} ${PKGDIR}/PLIST; \
|
||||
for color in ${ICONCOLORS}; do \
|
||||
colordir=share/kde/icons/$${color}; \
|
||||
for size in ${ICONSIZES}; do \
|
||||
sizedir=$${colordir}/$${size}; \
|
||||
for dir in ${ICONDIRS}; do \
|
||||
icondir=$${sizedir}/$${dir}; \
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/$${icondir}; \
|
||||
${ECHO} "@exec ${MKDIR} %D/$${icondir}"; \
|
||||
${ECHO} "@dirrm $${icondir}"; \
|
||||
done; \
|
||||
${ECHO} "@dirrm $${sizedir}"; \
|
||||
done; \
|
||||
${ECHO} "@dirrm $${colordir}"; \
|
||||
done; \
|
||||
${ECHO} "@dirrm share/kde/icons"; \
|
||||
${ECHO} "@dirrm share/kde"; \
|
||||
) > ${PLIST_SRC}
|
||||
|
||||
.include "../../archivers/bzip2/buildlink.mk"
|
||||
.include "../../print/cups/buildlink.mk"
|
||||
.include "../../audio/libaudiofile/buildlink.mk"
|
||||
.include "../../devel/pcre/buildlink.mk"
|
||||
.include "../../graphics/tiff/buildlink.mk"
|
||||
.include "../../print/cups/buildlink.mk"
|
||||
.include "../../security/openssl/buildlink.mk"
|
||||
.include "../../textproc/libxml2/buildlink.mk"
|
||||
.include "../../devel/pcre/buildlink.mk"
|
||||
|
||||
.include "../../x11/kde2/buildlink.mk"
|
||||
.include "../../x11/qt2-libs/buildlink.mk"
|
||||
.include "../../mk/ossaudio.buildlink.mk"
|
||||
.include "../../mk/x11.buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
||||
# XXX On NetBSD, the egcs for:
|
||||
# XXX
|
||||
# XXX alpha
|
||||
# XXX
|
||||
# XXX has an optimization bug when compiling with -O2 that is tickled by
|
||||
# XXX ${WRKSRC}/kdeprint/management/kmiconview.cpp.
|
||||
#
|
||||
.if ${OPSYS} == "NetBSD"
|
||||
. if (${MACHINE_ARCH} == "alpha")
|
||||
CFLAGS+= -O
|
||||
. endif
|
||||
.endif
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2001/10/31 22:11:08 zuntum Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2001/11/13 21:09:07 jlam Exp $
|
||||
bin/artsc-config
|
||||
bin/artscat
|
||||
bin/artsd
|
||||
|
@ -2766,35 +2766,8 @@ share/kde/servicetypes/kurifilterplugin.desktop
|
|||
@dirrm share/kde/mimelnk/application
|
||||
@dirrm share/kde/mimelnk/all
|
||||
@dirrm share/kde/mimelnk
|
||||
@dirrm share/kde/icons/hicolor/64x64/mimetypes
|
||||
@dirrm share/kde/icons/hicolor/64x64/filesystems
|
||||
@dirrm share/kde/icons/hicolor/64x64
|
||||
@dirrm share/kde/icons/hicolor/48x48/mimetypes
|
||||
@dirrm share/kde/icons/hicolor/48x48/filesystems
|
||||
@dirrm share/kde/icons/hicolor/48x48/devices
|
||||
@dirrm share/kde/icons/hicolor/48x48/actions
|
||||
@dirrm share/kde/icons/hicolor/48x48
|
||||
@dirrm share/kde/icons/hicolor/32x32/mimetypes
|
||||
@dirrm share/kde/icons/hicolor/32x32/filesystems
|
||||
@dirrm share/kde/icons/hicolor/32x32/devices
|
||||
@dirrm share/kde/icons/hicolor/32x32/actions/kde
|
||||
@dirrm share/kde/icons/hicolor/32x32/actions
|
||||
@dirrm share/kde/icons/hicolor/32x32
|
||||
@exec /bin/mkdir -p %D/share/kde/icons/hicolor/22x22/mimetypes
|
||||
@dirrm share/kde/icons/hicolor/22x22/mimetypes
|
||||
@exec /bin/mkdir -p %D/share/kde/icons/hicolor/22x22/filesystems
|
||||
@dirrm share/kde/icons/hicolor/22x22/filesystems
|
||||
@dirrm share/kde/icons/hicolor/22x22/actions/kde
|
||||
@dirrm share/kde/icons/hicolor/22x22/actions
|
||||
@dirrm share/kde/icons/hicolor/22x22
|
||||
@dirrm share/kde/icons/hicolor/16x16/mimetypes
|
||||
@dirrm share/kde/icons/hicolor/16x16/filesystems
|
||||
@dirrm share/kde/icons/hicolor/16x16/devices
|
||||
@dirrm share/kde/icons/hicolor/16x16/apps
|
||||
@dirrm share/kde/icons/hicolor/16x16/actions
|
||||
@dirrm share/kde/icons/hicolor/16x16
|
||||
@dirrm share/kde/icons/hicolor
|
||||
@dirrm share/kde/icons
|
||||
@exec ${MKDIR} %D/share/kde/locale
|
||||
@dirrm share/kde/locale
|
||||
@dirrm share/kde/config/ui
|
||||
@dirrm share/kde/config/colors
|
||||
@dirrm share/kde/config
|
||||
|
@ -2909,12 +2882,11 @@ share/kde/servicetypes/kurifilterplugin.desktop
|
|||
@dirrm share/kde/apps/kdeprint/filters
|
||||
@dirrm share/kde/apps/kdeprint
|
||||
@dirrm share/kde/apps/kconf_update
|
||||
@exec /bin/mkdir -p %D/share/kde/apps/kab/pics
|
||||
@exec ${MKDIR} %D/share/kde/apps/kab/pics
|
||||
@dirrm share/kde/apps/kab/pics
|
||||
@dirrm share/kde/apps/kab
|
||||
@dirrm share/kde/apps/LICENSES
|
||||
@dirrm share/kde/apps
|
||||
@dirrm share/kde
|
||||
@dirrm share/doc/kde/HTML/en/common
|
||||
@dirrm share/doc/kde/HTML/en
|
||||
@dirrm share/doc/kde/HTML
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink.mk,v 1.12 2001/11/01 18:32:03 tron Exp $
|
||||
# $NetBSD: buildlink.mk,v 1.13 2001/11/13 21:09:07 jlam Exp $
|
||||
#
|
||||
# This Makefile fragment is included by packages that use kdelibs2.
|
||||
#
|
||||
|
@ -17,7 +17,7 @@ KDELIBS2_BUILDLINK_MK= # defined
|
|||
|
||||
.include "../../mk/bsd.buildlink.mk"
|
||||
|
||||
BUILDLINK_DEPENDS.kdelibs2?= kdelibs>=2.2.1
|
||||
BUILDLINK_DEPENDS.kdelibs2?= kdelibs-2.[1-9]*
|
||||
DEPENDS+= ${BUILDLINK_DEPENDS.kdelibs2}:../../x11/kdelibs2
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
@ -27,16 +27,21 @@ BUILDLINK_PREFIX.kdelibs2_DEFAULT= ${X11PREFIX}
|
|||
BUILDLINK_FILES.kdelibs2!= ${GREP} "^\(include\|lib\)" ${.CURDIR}/../../x11/kdelibs2/PLIST
|
||||
BUILDLINK_FILES.kdelibs2+= bin/dcopserver
|
||||
|
||||
BUILDLINK_KDEDIR= ${BUILDLINK_DIR}
|
||||
KDEDIR= ${BUILDLINK_PREFIX.kdelibs2}
|
||||
|
||||
BUILDLINK_DEPENDS.audiofile= libaudiofile>=0.1.9
|
||||
USE_OPENSSL_VERSION= ${OPENSSL_VERSION_096}
|
||||
|
||||
.include "../../archivers/bzip2/buildlink.mk"
|
||||
.include "../../print/cups/buildlink.mk"
|
||||
.include "../../audio/libaudiofile/buildlink.mk"
|
||||
.include "../../graphics/tiff/buildlink.mk"
|
||||
.include "../../security/openssl/buildlink.mk"
|
||||
.include "../../devel/pcre/buildlink.mk"
|
||||
.include "../../graphics/tiff/buildlink.mk"
|
||||
.include "../../print/cups/buildlink.mk"
|
||||
.include "../../security/openssl/buildlink.mk"
|
||||
.include "../../textproc/libxml2/buildlink.mk"
|
||||
.include "../../x11/qt2-libs/buildlink.mk"
|
||||
.include "../../mk/ossaudio.buildlink.mk"
|
||||
|
||||
BUILDLINK_TARGETS.kdelibs2= kdelibs2-buildlink
|
||||
BUILDLINK_TARGETS.kdelibs2+= kdelibs2-buildlink-config-wrapper
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.7 2001/10/15 22:46:21 skrll Exp $
|
||||
$NetBSD: distinfo,v 1.8 2001/11/13 21:09:07 jlam Exp $
|
||||
|
||||
SHA1 (kdelibs-2.2.1.tar.bz2) = 6f5359905ba1f6c0785972da92c0113485ddee62
|
||||
Size (kdelibs-2.2.1.tar.bz2) = 5999418 bytes
|
||||
|
@ -7,7 +7,7 @@ SHA1 (patch-ab) = 4fcb10ca2605b9641ad317cea37d504f1644e150
|
|||
SHA1 (patch-ac) = 442c255b1361cbc77ac2b1c738c224467b9a35c5
|
||||
SHA1 (patch-ad) = 52fe9cdc53496ecbde42ff4a6c46a5bb104738a0
|
||||
SHA1 (patch-ae) = 55feaee4a2c1bcedbd135d8f4ed49a9fdc487247
|
||||
SHA1 (patch-af) = 3772906fb5d4986a9a8a79b0ebc1ac1b11ee5fc0
|
||||
SHA1 (patch-af) = a0a9c54c82cb039313d680d5379f80d8399de3cb
|
||||
SHA1 (patch-ag) = 14d75d761888ff56058f305853cf29244d9a3878
|
||||
SHA1 (patch-ah) = b31b2e72f70bd3cfd9b005cf7796c8cbef395b49
|
||||
SHA1 (patch-ai) = 02a985d9032412fc98f6497ea81d524a063e3115
|
||||
|
@ -43,3 +43,6 @@ SHA1 (patch-bl) = e97414ba9c0407d73ef1b9d44f023a49444539ea
|
|||
SHA1 (patch-bm) = 5f4609c677c8a55c4269567be1f1ab4ac2eb8249
|
||||
SHA1 (patch-bn) = db1962a1424601820b628a82d7e286f4c54f7594
|
||||
SHA1 (patch-bo) = 50c88a7ca572409a7f91df075155a1705a7ebca2
|
||||
SHA1 (patch-bp) = 84fe12d8317bbc9eb0ea2f2d320d3fb9fb138faf
|
||||
SHA1 (patch-bq) = 37b760bcd4067d3adac6260377f16fcb6ffae909
|
||||
SHA1 (patch-br) = e4098450a416d419a8ac947ad7a2244298c2c011
|
||||
|
|
|
@ -1,20 +1,8 @@
|
|||
$NetBSD: patch-af,v 1.2 2001/10/15 22:46:22 skrll Exp $
|
||||
$NetBSD: patch-af,v 1.3 2001/11/13 21:09:07 jlam Exp $
|
||||
|
||||
--- configure.orig Wed Sep 12 06:10:21 2001
|
||||
--- configure.orig Wed Sep 12 01:10:21 2001
|
||||
+++ configure
|
||||
@@ -6211,9 +6211,10 @@
|
||||
x_libraries="/usr/lib"; else
|
||||
x_libraries=$kde_x_libraries
|
||||
X_LDFLAGS="-L$x_libraries"
|
||||
+ X_WLRFLAGS="-Wl,-R$x_libraries"
|
||||
fi
|
||||
all_includes="$X_INCLUDES"
|
||||
-all_libraries="$X_LDFLAGS"
|
||||
+all_libraries="$X_LDFLAGS $X_WLRFLAGS"
|
||||
|
||||
|
||||
|
||||
@@ -6889,7 +6890,7 @@
|
||||
@@ -6889,7 +6889,7 @@
|
||||
ac_link='${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
|
||||
cross_compiling=$ac_cv_prog_cxx_cross
|
||||
|
||||
|
|
68
x11/kdelibs2/patches/patch-bp
Normal file
68
x11/kdelibs2/patches/patch-bp
Normal file
|
@ -0,0 +1,68 @@
|
|||
$NetBSD: patch-bp,v 1.1 2001/11/13 21:09:07 jlam Exp $
|
||||
|
||||
--- arts/artsc/artsdsp.c.orig Sun Jul 29 00:54:48 2001
|
||||
+++ arts/artsc/artsdsp.c
|
||||
@@ -127,6 +127,9 @@
|
||||
|
||||
static void artsdsp_doinit()
|
||||
{
|
||||
+#if defined(__NetBSD__)
|
||||
+ void *handle;
|
||||
+#endif
|
||||
const char *env;
|
||||
artsdsp_init = 1;
|
||||
|
||||
@@ -139,6 +142,18 @@
|
||||
mmapemu = env && !strcmp(env,"1");
|
||||
|
||||
/* resolve original symbols */
|
||||
+#if defined(__NetBSD__)
|
||||
+ handle = dlopen(NULL, DL_LAZY);
|
||||
+ orig_open = (orig_open_ptr)dlsym(handle,"open");
|
||||
+ orig_close = (orig_close_ptr)dlsym(handle,"close");
|
||||
+ orig_write = (orig_write_ptr)dlsym(handle,"write");
|
||||
+ orig_ioctl = (orig_ioctl_ptr)dlsym(handle,"_oss_ioctl");
|
||||
+ orig_mmap = (orig_mmap_ptr)dlsym(handle,"mmap");
|
||||
+ orig_munmap = (orig_munmap_ptr)dlsym(handle,"munmap");
|
||||
+ orig_fopen = (orig_fopen_ptr)dlsym(handle,"fopen");
|
||||
+ orig_access = (orig_access_ptr)dlsym(handle,"access");
|
||||
+ (void) dlclose(handle);
|
||||
+#else
|
||||
orig_open = (orig_open_ptr)dlsym(RTLD_NEXT,"open");
|
||||
orig_close = (orig_close_ptr)dlsym(RTLD_NEXT,"close");
|
||||
orig_write = (orig_write_ptr)dlsym(RTLD_NEXT,"write");
|
||||
@@ -147,6 +162,7 @@
|
||||
orig_munmap = (orig_munmap_ptr)dlsym(RTLD_NEXT,"munmap");
|
||||
orig_fopen = (orig_fopen_ptr)dlsym(RTLD_NEXT,"fopen");
|
||||
orig_access = (orig_access_ptr)dlsym(RTLD_NEXT,"access");
|
||||
+#endif
|
||||
}
|
||||
|
||||
static void artsdspdebug(const char *fmt,...)
|
||||
@@ -230,13 +246,18 @@
|
||||
return sndfd;
|
||||
}
|
||||
|
||||
+#if defined(__NetBSD__)
|
||||
+int _oss_ioctl (int fd, unsigned long request, void *argp)
|
||||
+#else
|
||||
int ioctl (int fd, ioctl_request_t request, ...)
|
||||
+#endif
|
||||
{
|
||||
static int channels;
|
||||
static int bits;
|
||||
static int speed;
|
||||
int space, size, latency, odelay;
|
||||
|
||||
+#if !defined(__NetBSD__)
|
||||
/*
|
||||
* FreeBSD needs ioctl with varargs. However I have no idea how to "forward"
|
||||
* the variable args ioctl to the orig_ioctl routine. So I expect the ioctl
|
||||
@@ -248,6 +269,7 @@
|
||||
va_start(args,request);
|
||||
argp = va_arg(args, void *);
|
||||
va_end(args);
|
||||
+#endif
|
||||
|
||||
CHECK_INIT();
|
||||
|
65
x11/kdelibs2/patches/patch-bq
Normal file
65
x11/kdelibs2/patches/patch-bq
Normal file
|
@ -0,0 +1,65 @@
|
|||
$NetBSD: patch-bq,v 1.1 2001/11/13 21:09:07 jlam Exp $
|
||||
|
||||
--- kio/file/file.cc.orig Tue Sep 4 19:08:16 2001
|
||||
+++ kio/file/file.cc
|
||||
@@ -42,6 +42,8 @@
|
||||
#ifdef HAVE_VOLMGT
|
||||
#include <volmgt.h>
|
||||
#include <sys/mnttab.h>
|
||||
+#else
|
||||
+#include <kstddirs.h>
|
||||
#endif
|
||||
|
||||
#include <kio/ioslave_defaults.h>
|
||||
@@ -1071,24 +1073,31 @@
|
||||
QCString point = QFile::encodeName( shellQuote(_point) );
|
||||
QCString fstype = _fstype;
|
||||
QCString readonly = _ro ? "-r" : "";
|
||||
+ QString path = getenv("PATH");
|
||||
+ path.append(":/usr/sbin:/sbin");
|
||||
+ QString mountProg = KGlobal::dirs()->findExe("mount", path);
|
||||
+
|
||||
+ if (mountProg.isEmpty()) {
|
||||
+ mountProg = "mount";
|
||||
+ }
|
||||
|
||||
// Two steps, in case mount doesn't like it when we pass all options
|
||||
for ( int step = 0 ; step <= 1 ; step++ )
|
||||
{
|
||||
// Mount using device only if no fstype nor mountpoint (KDE-1.x like)
|
||||
if ( !_dev.isEmpty() && _point.isEmpty() && fstype.isEmpty() )
|
||||
- buffer.sprintf( "mount %s 2>%s", dev.data(), tmp );
|
||||
+ buffer.sprintf( "%s %s 2>%s", mountProg.latin1(), dev.data(), tmp );
|
||||
else
|
||||
// Mount using the mountpoint, if no fstype nor device (impossible in first step)
|
||||
if ( !_point.isEmpty() && _dev.isEmpty() && fstype.isEmpty() )
|
||||
- buffer.sprintf( "mount %s 2>%s", point.data(), tmp );
|
||||
+ buffer.sprintf( "%s %s 2>%s", mountProg.latin1(), point.data(), tmp );
|
||||
else
|
||||
// mount giving device + mountpoint but no fstype
|
||||
if ( !_point.isEmpty() && !_dev.isEmpty() && fstype.isEmpty() )
|
||||
- buffer.sprintf( "mount %s %s %s 2>%s", readonly.data(), dev.data(), point.data(), tmp );
|
||||
+ buffer.sprintf( "%s %s %s %s 2>%s", mountProg.latin1(), readonly.data(), dev.data(), point.data(), tmp );
|
||||
else
|
||||
// mount giving device + mountpoint + fstype
|
||||
- buffer.sprintf( "mount %s -t %s %s %s 2>%s", readonly.data(),
|
||||
+ buffer.sprintf( "%s %s -t %s %s %s 2>%s", mountProg.latin1(), readonly.data(),
|
||||
fstype.data(), dev.data(), point.data(), tmp );
|
||||
|
||||
kdDebug(7101) << buffer << endl;
|
||||
@@ -1232,7 +1241,14 @@
|
||||
return;
|
||||
}
|
||||
#else
|
||||
- buffer.sprintf( "umount %s 2>%s", QFile::encodeName(_point).data(), tmp );
|
||||
+ QString path = getenv("PATH");
|
||||
+ path.append(":/usr/sbin:/sbin");
|
||||
+ QString umountProg = KGlobal::dirs()->findExe("umount", path);
|
||||
+
|
||||
+ if (umountProg.isEmpty()) {
|
||||
+ umountProg = "umount";
|
||||
+ }
|
||||
+ buffer.sprintf( "%s %s 2>%s", umountProg.latin1(), QFile::encodeName(_point).data(), tmp );
|
||||
system( buffer.ascii() );
|
||||
#endif /* HAVE_VOLMGT */
|
||||
|
18
x11/kdelibs2/patches/patch-br
Normal file
18
x11/kdelibs2/patches/patch-br
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-br,v 1.1 2001/11/13 21:09:07 jlam Exp $
|
||||
|
||||
--- libkmid/sndcard.h.orig Sat Jun 24 09:35:18 2000
|
||||
+++ libkmid/sndcard.h
|
||||
@@ -31,9 +31,12 @@
|
||||
|
||||
#ifdef HAVE_SYS_SOUNDCARD_H
|
||||
#include <sys/soundcard.h>
|
||||
- #define HAVE_OSS_SUPPORT
|
||||
#elif defined(HAVE_MACHINE_SOUNDCARD_H)
|
||||
#include <machine/soundcard.h>
|
||||
+#endif
|
||||
+
|
||||
+/* Check for OSS MIDI API */
|
||||
+#if defined(SNDCTL_SEQ_NRSYNTHS) && defined(CTL_MAIN_VOLUME)
|
||||
#define HAVE_OSS_SUPPORT
|
||||
#else
|
||||
#undef HAVE_OSS_SUPPORT
|
Loading…
Reference in a new issue