Changes 2.11:

We have improved the trust-region update rule in the primal-based Newton method. It's significantly faster (e.g., twice faster or more) on some problems (see the technical report).
We now support scipy objects in the Python interface
This commit is contained in:
adam 2017-05-21 10:40:28 +00:00
parent 10177e50b4
commit bf12b23211
4 changed files with 19 additions and 25 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.3 2016/01/28 11:34:48 jperkin Exp $
# $NetBSD: Makefile,v 1.4 2017/05/21 10:40:28 adam Exp $
DISTNAME= liblinear-2.1
PKGREVISION= 1
DISTNAME= liblinear-2.11
CATEGORIES= math
MASTER_SITES= http://www.csie.ntu.edu.tw/~cjlin/liblinear/

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.1 2015/11/20 14:47:20 adam Exp $
# $NetBSD: buildlink3.mk,v 1.2 2017/05/21 10:40:28 adam Exp $
BUILDLINK_TREE+= liblinear
@ -6,7 +6,7 @@ BUILDLINK_TREE+= liblinear
LIBLINEAR_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.liblinear+= liblinear>=2.1
BUILDLINK_PKGSRCDIR.liblinear?= ../../math/liblinear
BUILDLINK_PKGSRCDIR.liblinear?= ../../math/liblinear
.endif # LIBLINEAR_BUILDLINK3_MK
BUILDLINK_TREE+= -liblinear

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.4 2016/01/28 11:34:48 jperkin Exp $
$NetBSD: distinfo,v 1.5 2017/05/21 10:40:28 adam Exp $
SHA1 (liblinear-2.1.tar.gz) = 071e1c86c400bfa3605b1a5e45dace250c6a4574
RMD160 (liblinear-2.1.tar.gz) = bb325a017a0044039c3ad2a058d56af7dc063ade
SHA512 (liblinear-2.1.tar.gz) = e70d96c8119682258066433e0e79bcc55e20a8f6cb229da555b225a4677e19b17961b32e3502d8f85e5638dff56314aa83e0fdcda059df6d0cb056bb2a2b0495
Size (liblinear-2.1.tar.gz) = 382326 bytes
SHA1 (liblinear-2.11.tar.gz) = 6c306d0d0b7ea5281ee2b587adc89745ee0d74fa
RMD160 (liblinear-2.11.tar.gz) = c80d051e8b354de03da3e41bd1bea096ef4076f3
SHA512 (liblinear-2.11.tar.gz) = c5a33e98ae3c792173d38060b6002cf63af4571b42cdf313f6e5fd8ee5ac7b86caa99d123a028a6ecb3843aac0f839c9ff655f5fb28cfdf26ca7a6cb5f3f359d
Size (liblinear-2.11.tar.gz) = 506509 bytes
SHA1 (patch-Makefile) = 88e7188f9e5a8bb5da90a1cac23a5de98dbe5817
SHA1 (patch-blas_Makefile) = 48a27b5b7bc285ebb65d87cab027b9f7ed5e2183
SHA1 (patch-blas_Makefile) = b52b5e18a47c075241adbfcdcf8f70e6fe849711

View file

@ -1,23 +1,18 @@
$NetBSD: patch-blas_Makefile,v 1.1 2016/01/28 11:34:48 jperkin Exp $
$NetBSD: patch-blas_Makefile,v 1.2 2017/05/21 10:40:28 adam Exp $
Use libtool.
Use LIBTOOL.
--- blas/Makefile.orig 2015-09-26 22:03:28.000000000 +0000
--- blas/Makefile.orig 2017-03-28 22:22:33.000000000 +0000
+++ blas/Makefile
@@ -2,21 +2,21 @@ AR = ar rcv
RANLIB = ranlib
HEADERS = blas.h blasp.h
-FILES = dnrm2.o daxpy.o ddot.o dscal.o
+FILES = dnrm2.lo daxpy.lo ddot.lo dscal.lo
CFLAGS = $(OPTFLAGS)
@@ -7,16 +7,16 @@ FILES = dnrm2.o daxpy.o ddot.o dscal.o
CFLAGS = $(OPTFLAGS)
FFLAGS = $(OPTFLAGS)
blas: $(FILES) $(HEADERS)
- $(AR) blas.a $(FILES)
-blas: $(FILES) $(HEADERS)
- $(AR) blas.a $(FILES)
- $(RANLIB) blas.a
+ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -o libblas.la $(FILES)
+blas: $(FILES:.o=.lo) $(HEADERS)
+ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -o libblas.la $(FILES:.o=.lo)
clean:
- rm -f *.o