audio: Remove gnome-speech
Obsolete GNOME 2 component, no longer part of GNOME
This commit is contained in:
parent
a136b36344
commit
bf25c7a8d5
38 changed files with 1 additions and 579 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.598 2020/05/09 09:55:31 nia Exp $
|
||||
# $NetBSD: Makefile,v 1.599 2020/05/15 12:07:50 nia Exp $
|
||||
#
|
||||
|
||||
COMMENT= Audio tools
|
||||
|
@ -139,8 +139,6 @@ SUBDIR+= gmpc-lyricwiki
|
|||
SUBDIR+= gmpc-magnatune
|
||||
SUBDIR+= gmpc-tagedit
|
||||
SUBDIR+= gnome-audio
|
||||
SUBDIR+= gnome-speech
|
||||
SUBDIR+= gnome-speech-espeak
|
||||
SUBDIR+= gnome-vfs-cdda
|
||||
SUBDIR+= goom
|
||||
SUBDIR+= gqmpeg-devel
|
||||
|
|
|
@ -1 +0,0 @@
|
|||
GNOME 2 Speech is a simple general API for producing text-to-speech output.
|
|
@ -1,17 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.17 2020/03/08 16:48:40 wiz Exp $
|
||||
#
|
||||
|
||||
.include "../../audio/gnome-speech/Makefile.common"
|
||||
|
||||
PKGNAME= ${DISTNAME:S/speech/speech-espeak/}
|
||||
PKGREVISION= 7
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
COMMENT= GNOME 2 text-to-speech API
|
||||
|
||||
BUILD_DIRS= drivers/espeak
|
||||
INSTALL_DIRS= drivers/espeak
|
||||
CONFIGURE_ARGS+= --with-espeak-dir=${LOCALBASE}
|
||||
|
||||
.include "../../audio/espeak/buildlink3.mk"
|
||||
.include "../../audio/gnome-speech/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,3 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2009/06/14 17:32:09 joerg Exp $
|
||||
bin/espeak-synthesis-driver
|
||||
lib/bonobo/servers/GNOME_Speech_SynthesisDriver_Espeak.server
|
|
@ -1 +0,0 @@
|
|||
GNOME 2 Speech is a simple general API for producing text-to-speech output.
|
|
@ -1,10 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.50 2020/03/08 16:47:25 wiz Exp $
|
||||
#
|
||||
|
||||
.include "Makefile.common"
|
||||
|
||||
PKGREVISION= 7
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
COMMENT= GNOME 2 text-to-speech API
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,33 +0,0 @@
|
|||
# $NetBSD: Makefile.common,v 1.6 2020/03/19 14:37:10 prlw1 Exp $
|
||||
#
|
||||
# used by audio/gnome-speech/Makefile
|
||||
# used by audio/gnome-speech-espeak/Makefile
|
||||
|
||||
DISTNAME= gnome-speech-0.4.25
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gnome-speech/0.4/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
HOMEPAGE= https://www.gnome.org/
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PATCHDIR= ${.CURDIR}/../gnome-speech/patches
|
||||
DISTINFO_FILE= ${.CURDIR}/../gnome-speech/distinfo
|
||||
|
||||
USE_TOOLS+= gmake msgfmt pkg-config
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
# Disable Java support.
|
||||
CONFIGURE_ARGS+= JAVAC=no JAVA=no IDLJ=no JAB=no
|
||||
|
||||
PKGCONFIG_OVERRIDE+= gnome-speech-1.0.pc.in
|
||||
|
||||
# We patch configure
|
||||
CHECK_PORTABILITY_SKIP+= configure.in
|
||||
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../devel/libbonobo/buildlink3.mk"
|
||||
.include "../../net/ORBit2/buildlink3.mk"
|
|
@ -1,14 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2009/06/14 17:32:09 joerg Exp $
|
||||
bin/festival-synthesis-driver
|
||||
bin/test-speech
|
||||
include/gnome-speech-1.0/gnome-speech/GNOME_Speech.h
|
||||
include/gnome-speech-1.0/gnome-speech/gnome-speech.h
|
||||
include/gnome-speech-1.0/gnome-speech/speaker.h
|
||||
lib/bonobo/servers/GNOME_Speech_SynthesisDriver_Festival.server
|
||||
lib/libgnomespeech.la
|
||||
lib/orbit-2.0/GNOME_Speech_module.la
|
||||
lib/pkgconfig/gnome-speech-1.0.pc
|
||||
share/idl/gnome-speech-1.0/GNOME_Speech.idl
|
||||
share/idl/gnome-speech-1.0/GNOME_Speech_Speaker.idl
|
||||
share/idl/gnome-speech-1.0/GNOME_Speech_SpeechCallback.idl
|
||||
share/idl/gnome-speech-1.0/GNOME_Speech_SynthesisDriver.idl
|
|
@ -1,17 +0,0 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.20 2020/03/08 16:47:25 wiz Exp $
|
||||
|
||||
BUILDLINK_TREE+= gnome-speech
|
||||
|
||||
.if !defined(GNOME_SPEECH_BUILDLINK3_MK)
|
||||
GNOME_SPEECH_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.gnome-speech+= gnome-speech>=0.3.2
|
||||
BUILDLINK_ABI_DEPENDS.gnome-speech+= gnome-speech>=0.4.25nb7
|
||||
BUILDLINK_PKGSRCDIR.gnome-speech?= ../../audio/gnome-speech
|
||||
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../devel/libbonobo/buildlink3.mk"
|
||||
.include "../../net/ORBit2/buildlink3.mk"
|
||||
.endif # GNOME_SPEECH_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -gnome-speech
|
|
@ -1,34 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.31 2015/11/03 01:12:33 agc Exp $
|
||||
|
||||
SHA1 (gnome-speech-0.4.25.tar.bz2) = c229af1583c522212e067990eafaf6a58df42966
|
||||
RMD160 (gnome-speech-0.4.25.tar.bz2) = 305f0e820ce77039776a1c3d3fa259d4f628b88e
|
||||
SHA512 (gnome-speech-0.4.25.tar.bz2) = 46b135aaa4beba7786d90087533ae13828f81c9ed5eeada834820b98a8b3e00e50f653f7e10dcd869be36ecba600f9b20d6846771f3ed9eea950dfea4c27d376
|
||||
Size (gnome-speech-0.4.25.tar.bz2) = 336706 bytes
|
||||
SHA1 (patch-aa) = d858b42547ff02b1ee47bfaee83ffc5230d4df31
|
||||
SHA1 (patch-ab) = 2a0212e0dab613371db44c278f96d88acd1f5b1c
|
||||
SHA1 (patch-ac) = 44c38746c51fc6dbf3e086532ed05f1b0c0c158c
|
||||
SHA1 (patch-drivers_dectalk_dectalkspeaker_c) = 82c3af75f2f8bd59a0118c4bc695d4cebbda5172
|
||||
SHA1 (patch-drivers_dectalk_dectalkspeaker_h) = 626662c439caf1d531138515c8af272a5472b1af
|
||||
SHA1 (patch-drivers_dectalk_dectalksynthesisdriver_c) = 638b94061077bc6b57b95c2d218a2f6463ee4e88
|
||||
SHA1 (patch-drivers_dectalk_dectalksynthesisdriver_h) = 671bc87a7145e78445d7e2fa9ff8ac1bc6b034ae
|
||||
SHA1 (patch-drivers_eloquence_eloquencespeaker_c) = 30437763bace4be2be5820a62067995e124b9a5d
|
||||
SHA1 (patch-drivers_eloquence_eloquencespeaker_h) = 6ec99b265ae453a3892db1b80570efb22a9617ad
|
||||
SHA1 (patch-drivers_eloquence_eloquencesynthesisdriver_c) = 3d8e6724a3d6d12a9438afa2ad703bb850ae7b8c
|
||||
SHA1 (patch-drivers_espeak_espeakspeaker_c) = cbb558528f2c17379480ad87464f995264bf8bce
|
||||
SHA1 (patch-drivers_espeak_espeakspeaker_h) = 5f2607762f4033677b95be3a28ee971de23e4e0c
|
||||
SHA1 (patch-drivers_espeak_espeaksynthesisdriver_c) = 9ec8b44e20c7255d4dd6fc7a9ebd724abdde1cdc
|
||||
SHA1 (patch-drivers_espeak_espeaksynthesisdriver_h) = f83955a1f5bd90e31340076858695309734daeb1
|
||||
SHA1 (patch-drivers_loquendo_loquendospeaker_c) = d0667787b00f8d1c23031de3ef4ec0bda4a893cb
|
||||
SHA1 (patch-drivers_loquendo_loquendospeaker_h) = ed42be11f999117c42c3fe60ad6f35230b77bdb5
|
||||
SHA1 (patch-drivers_loquendo_loquendosynthesisdriver_c) = 58465a7d4be2faf4d663802996324b69c2448dda
|
||||
SHA1 (patch-drivers_loquendo_loquendosynthesisdriver_h) = 31cf625fb1e3e4cfba1eb8130abbc6645ff29232
|
||||
SHA1 (patch-drivers_swift_swiftspeaker_c) = 2b35afdb12362a6377bbb017de3fb143959f70eb
|
||||
SHA1 (patch-drivers_swift_swiftspeaker_h) = e8dafc3b34a156ec2b4aadffb5fd39a49d87c45c
|
||||
SHA1 (patch-drivers_swift_swiftsynthesisdriver_c) = 78287b3adac07f80ac2118257c05dfb732f1c7db
|
||||
SHA1 (patch-drivers_theta_thetaspeaker_c) = 9d7876afec5b6c0e6950914b26c1a865fd617191
|
||||
SHA1 (patch-drivers_theta_thetaspeaker_h) = a240f76d9e69809df0103a8aed50deab38f085b5
|
||||
SHA1 (patch-drivers_theta_thetasynthesisdriver_c) = 77f2a9710aa501b999de101430797d90972432fc
|
||||
SHA1 (patch-drivers_viavoice_viavoicespeaker_c) = fc1183dd7b3e6b44fcb8d7cf1eb070391811456a
|
||||
SHA1 (patch-drivers_viavoice_viavoicespeaker_h) = aef307b3e2a95b00e15c17278136622f5ea5c528
|
||||
SHA1 (patch-drivers_viavoice_viavoicesynthesisdriver_c) = b8b87e6ac964b43887dfab579d43c773700a585e
|
||||
SHA1 (patch-drivers_viavoice_viavoicesynthesisdriver_h) = a836015f8b3f7df41e2b76f7aa3b99f54f8996d4
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.5 2008/11/16 17:24:40 wiz Exp $
|
||||
|
||||
Added some necessary header files.
|
||||
|
||||
--- drivers/festival/festivalsynthesisdriver.c.orig Tue Mar 8 14:10:23 2005
|
||||
+++ drivers/festival/festivalsynthesisdriver.c
|
||||
@@ -25,8 +25,10 @@
|
||||
*
|
||||
*/
|
||||
|
||||
-#include <string.h>
|
||||
#include <sys/types.h>
|
||||
+#include <sys/socket.h>
|
||||
+#include <netinet/in.h>
|
||||
+#include <string.h>
|
||||
#include <sys/wait.h>
|
||||
#include <signal.h>
|
||||
#include <unistd.h>
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2009/01/18 11:28:56 wiz Exp $
|
||||
|
||||
--- configure.orig 2008-11-16 17:25:05.000000000 +0100
|
||||
+++ configure
|
||||
@@ -12133,7 +12133,7 @@ fi
|
||||
|
||||
|
||||
if test x$build_swift != xno ; then
|
||||
- if test x$with_swift_dir == x ; then
|
||||
+ if test x$with_swift_dir = x ; then
|
||||
# Check default location /opt/swift
|
||||
with_swift_dir="/opt/swift"
|
||||
fi
|
||||
@@ -12189,7 +12189,7 @@ fi
|
||||
|
||||
|
||||
if test x$build_theta != xno ; then
|
||||
- if test x$with_theta_dir == x ; then
|
||||
+ if test x$with_theta_dir = x ; then
|
||||
# Check default location /opt/theta
|
||||
with_theta_dir="/opt/theta"
|
||||
fi
|
|
@ -1,27 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.5 2009/02/24 15:04:15 wiz Exp $
|
||||
|
||||
For separating gnome-speech-espeak into a separate package.
|
||||
|
||||
--- drivers/espeak/Makefile.in.orig 2009-02-15 17:43:44.000000000 +0000
|
||||
+++ drivers/espeak/Makefile.in
|
||||
@@ -55,7 +55,6 @@ espeak_synthesis_driver_OBJECTS = \
|
||||
espeak_synthesis_driver_LDADD = $(LDADD)
|
||||
am__DEPENDENCIES_1 =
|
||||
espeak_synthesis_driver_DEPENDENCIES = \
|
||||
- $(top_builddir)/gnome-speech/libgnomespeech.la \
|
||||
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
|
||||
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
|
||||
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
||||
@@ -250,9 +249,10 @@ INCLUDES = -I$(top_srcdir) \
|
||||
-I$(top_srcdir)/gnome-speech\
|
||||
$(gnome_speech_CFLAGS) \
|
||||
$(WARN_CFLAGS) \
|
||||
- -I$(espeak_INCLUDES)
|
||||
+ -I$(espeak_INCLUDES) \
|
||||
+ -I${LOCALBASE}/include/gnome-speech-1.0
|
||||
|
||||
-LDADD = $(top_builddir)/gnome-speech/libgnomespeech.la \
|
||||
+LDADD = -lgnomespeech \
|
||||
$(gnome_speech_LIBS) \
|
||||
$(espeak_LIBS)
|
||||
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-drivers_dectalk_dectalkspeaker_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/dectalk/dectalkspeaker.c~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/dectalk/dectalkspeaker.c
|
||||
@@ -27,8 +27,7 @@
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <dtk/ttsapi.h>
|
||||
#include "dectalkspeaker.h"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_dectalk_dectalkspeaker_h,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/dectalk/dectalkspeaker.h~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/dectalk/dectalkspeaker.h
|
||||
@@ -30,7 +30,7 @@
|
||||
#define __DECTALK_SPEAKER_H_
|
||||
|
||||
#include <bonobo/bonobo-object.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
|
||||
#define DECTALK_SPEAKER_TYPE (dectalk_speaker_get_type())
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_dectalk_dectalksynthesisdriver_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/dectalk/dectalksynthesisdriver.c~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/dectalk/dectalksynthesisdriver.c
|
||||
@@ -26,7 +26,7 @@
|
||||
|
||||
#include <string.h>
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include "dectalksynthesisdriver.h"
|
||||
#include <dtk/ttsapi.h>
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_dectalk_dectalksynthesisdriver_h,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/dectalk/dectalksynthesisdriver.h~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/dectalk/dectalksynthesisdriver.h
|
||||
@@ -28,7 +28,7 @@
|
||||
#ifndef __DECTALK_SYNTHESIS_DRIVER_H_
|
||||
#define __DECTALK_SYNTHESIS_DRIVER_H_
|
||||
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <bonobo/bonobo-object.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <dtk/ttsapi.h>
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-drivers_eloquence_eloquencespeaker_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/eloquence/eloquencespeaker.c~ 2009-02-08 16:14:55.000000000 +0000
|
||||
+++ drivers/eloquence/eloquencespeaker.c
|
||||
@@ -25,8 +25,7 @@
|
||||
|
||||
#include <unistd.h>
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include "eloquencespeaker.h"
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_eloquence_eloquencespeaker_h,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/eloquence/eloquencespeaker.h~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/eloquence/eloquencespeaker.h
|
||||
@@ -34,7 +34,7 @@ extern "C" {
|
||||
#endif /* __cplusplus */
|
||||
|
||||
#include <bonobo/bonobo-object.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <eci.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_eloquence_eloquencesynthesisdriver_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/eloquence/eloquencesynthesisdriver.c~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/eloquence/eloquencesynthesisdriver.c
|
||||
@@ -24,7 +24,7 @@
|
||||
*/
|
||||
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include "eloquencesynthesisdriver.h"
|
||||
#include "eloquencespeaker.h"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_espeak_espeakspeaker_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/espeak/espeakspeaker.c~ 2009-02-15 17:24:06.000000000 +0000
|
||||
+++ drivers/espeak/espeakspeaker.c
|
||||
@@ -26,7 +26,7 @@
|
||||
#include <unistd.h>
|
||||
#include <string.h>
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <speak_lib.h>
|
||||
#include "espeaksynthesisdriver.h"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_espeak_espeakspeaker_h,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/espeak/espeakspeaker.h~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/espeak/espeakspeaker.h
|
||||
@@ -34,7 +34,7 @@ extern "C" {
|
||||
#endif /* __cplusplus */
|
||||
|
||||
#include <bonobo/bonobo-object.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <speak_lib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-drivers_espeak_espeaksynthesisdriver_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/espeak/espeaksynthesisdriver.c~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/espeak/espeaksynthesisdriver.c
|
||||
@@ -28,7 +28,6 @@
|
||||
#include <stdlib.h>
|
||||
#include <libbonobo.h>
|
||||
#include <glib.h>
|
||||
-#include <glib/gmain.h>
|
||||
#include <speak_lib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include "espeaksynthesisdriver.h"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_espeak_espeaksynthesisdriver_h,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/espeak/espeaksynthesisdriver.h~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/espeak/espeaksynthesisdriver.h
|
||||
@@ -29,7 +29,7 @@
|
||||
#define __ESPEAK_SYNTHESIS_DRIVER_H_
|
||||
|
||||
#include <bonobo/bonobo-object.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <speak_lib.h>
|
||||
#include "espeakspeaker.h"
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-drivers_loquendo_loquendospeaker_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/loquendo/loquendospeaker.c~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/loquendo/loquendospeaker.c
|
||||
@@ -27,8 +27,7 @@
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <loqtts.h>
|
||||
#include "loquendospeaker.h"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_loquendo_loquendospeaker_h,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/loquendo/loquendospeaker.h~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/loquendo/loquendospeaker.h
|
||||
@@ -34,7 +34,7 @@ extern "C" {
|
||||
#endif /* __cplusplus */
|
||||
|
||||
#include <bonobo/bonobo-object.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <loqtts.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_loquendo_loquendosynthesisdriver_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/loquendo/loquendosynthesisdriver.c~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/loquendo/loquendosynthesisdriver.c
|
||||
@@ -23,7 +23,7 @@
|
||||
*/
|
||||
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
+#include <glib.h>
|
||||
#include <loqtts.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include "loquendosynthesisdriver.h"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_loquendo_loquendosynthesisdriver_h,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/loquendo/loquendosynthesisdriver.h~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/loquendo/loquendosynthesisdriver.h
|
||||
@@ -31,7 +31,7 @@
|
||||
|
||||
|
||||
#include <bonobo/bonobo-object.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include "loquendospeaker.h"
|
||||
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-drivers_swift_swiftspeaker_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/swift/swiftspeaker.c~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/swift/swiftspeaker.c
|
||||
@@ -28,8 +28,7 @@
|
||||
#include <math.h>
|
||||
#include <unistd.h>
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <swift.h>
|
||||
#include "swiftspeaker.h"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_swift_swiftspeaker_h,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/swift/swiftspeaker.h~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/swift/swiftspeaker.h
|
||||
@@ -28,7 +28,7 @@
|
||||
#define __SWIFT_SPEAKER_H_
|
||||
|
||||
#include <bonobo/bonobo-object.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <swift.h>
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_swift_swiftsynthesisdriver_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/swift/swiftsynthesisdriver.c~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/swift/swiftsynthesisdriver.c
|
||||
@@ -28,7 +28,7 @@
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <swift.h>
|
||||
#include "swiftsynthesisdriver.h"
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-drivers_theta_thetaspeaker_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/theta/thetaspeaker.c~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/theta/thetaspeaker.c
|
||||
@@ -28,8 +28,7 @@
|
||||
#include <math.h>
|
||||
#include <unistd.h>
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <theta.h>
|
||||
#include "thetaspeaker.h"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_theta_thetaspeaker_h,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/theta/thetaspeaker.h~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/theta/thetaspeaker.h
|
||||
@@ -30,7 +30,7 @@
|
||||
#define __THETA_SPEAKER_H_
|
||||
|
||||
#include <bonobo/bonobo-object.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <theta.h>
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_theta_thetasynthesisdriver_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/theta/thetasynthesisdriver.c~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/theta/thetasynthesisdriver.c
|
||||
@@ -28,7 +28,7 @@
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <theta.h>
|
||||
#include "thetasynthesisdriver.h"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_viavoice_viavoicespeaker_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/viavoice/viavoicespeaker.c~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/viavoice/viavoicespeaker.c
|
||||
@@ -26,7 +26,7 @@
|
||||
#include <unistd.h>
|
||||
#include <string.h>
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include "viavoicesynthesisdriver.h"
|
||||
#include "viavoicespeaker.h"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_viavoice_viavoicespeaker_h,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/viavoice/viavoicespeaker.h~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/viavoice/viavoicespeaker.h
|
||||
@@ -34,7 +34,7 @@ extern "C" {
|
||||
#endif /* __cplusplus */
|
||||
|
||||
#include <bonobo/bonobo-object.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <eci.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_viavoice_viavoicesynthesisdriver_c,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/viavoice/viavoicesynthesisdriver.c~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/viavoice/viavoicesynthesisdriver.c
|
||||
@@ -24,7 +24,7 @@
|
||||
*/
|
||||
|
||||
#include <libbonobo.h>
|
||||
-#include <glib/gmain.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <string.h>
|
||||
#include "viavoicesynthesisdriver.h"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-drivers_viavoice_viavoicesynthesisdriver_h,v 1.1 2012/05/06 19:49:37 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- drivers/viavoice/viavoicesynthesisdriver.h~ 2008-12-10 13:36:00.000000000 +0000
|
||||
+++ drivers/viavoice/viavoicesynthesisdriver.h
|
||||
@@ -30,7 +30,7 @@
|
||||
#define __VIAVOICE_SYNTHESIS_DRIVER_H_
|
||||
|
||||
#include <bonobo/bonobo-object.h>
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
#include <gnome-speech/gnome-speech.h>
|
||||
#include <eci.h>
|
||||
#include "viavoicespeaker.h"
|
Loading…
Reference in a new issue