- Updated to v1.0 (No CHANGELOG available)
- Use options.mk framework for python and rrdtool support
This commit is contained in:
parent
7ab00beee9
commit
bf43b23fd4
5 changed files with 82 additions and 28 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.5 2004/12/28 02:47:49 reed Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2005/01/14 21:44:33 adrianp Exp $
|
||||
#
|
||||
|
||||
DISTNAME= honeyd-0.8b
|
||||
PKGREVISION= 4
|
||||
DISTNAME= honeyd-1.0
|
||||
CATEGORIES= security net
|
||||
MASTER_SITES= http://niels.xtdnet.nl/honeyd/
|
||||
|
||||
|
@ -10,20 +9,23 @@ MAINTAINER= adrianp@NetBSD.org
|
|||
HOMEPAGE= http://niels.xtdnet.nl/honeyd/index.php
|
||||
COMMENT= Small daemon that creates virtual hosts on a network
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
DEPENDS+= honeyd-arpd>=0.2:../../security/honeyd-arpd
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BUILDLINK3= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_PKGINSTALL= yes
|
||||
GNU_CONFIGURE= YES
|
||||
USE_BUILDLINK3= YES
|
||||
USE_LIBTOOL= YES
|
||||
USE_PKGINSTALL= YES
|
||||
PKG_SYSCONFSUBDIR= honeyd
|
||||
RCD_SCRIPTS= honeyd
|
||||
USE_BUILTIN.libevent= NO
|
||||
|
||||
CONFIGURE_ENV+= _PATH_PYTHON=${PYTHONBIN}
|
||||
LIBS.Linux+= -lutil
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
DIST_CONF_FILES= nmap.assoc xprobe2.conf nmap.prints \
|
||||
config.ethernet pf.os
|
||||
config.ethernet pf.os config.sample
|
||||
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
|
||||
DOCDIR= ${PREFIX}/share/doc/${PKGBASE}
|
||||
|
||||
|
@ -32,15 +34,15 @@ CONF_FILES+= ${EGDIR}/${f} ${PKG_SYSCONFDIR}/${f}
|
|||
.endfor
|
||||
.undef f
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${DOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCDIR}
|
||||
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../devel/readline/buildlink3.mk"
|
||||
.include "../../devel/libevent/buildlink3.mk"
|
||||
.include "../../devel/ncurses/buildlink3.mk"
|
||||
.include "../../net/libdnet/buildlink3.mk"
|
||||
.include "../../net/libpcap/buildlink3.mk"
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${DOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCDIR}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2004/04/23 22:07:58 reed Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2005/01/14 21:44:33 adrianp Exp $
|
||||
bin/honeyd
|
||||
bin/honeydctl
|
||||
include/honeyd/debug.h
|
||||
|
@ -15,6 +15,37 @@ share/examples/honeyd/nmap.assoc
|
|||
share/examples/honeyd/nmap.prints
|
||||
share/examples/honeyd/pf.os
|
||||
share/examples/honeyd/xprobe2.conf
|
||||
share/examples/honeyd/webserver/htdocs/graphs/traffic_daily.gif
|
||||
share/examples/honeyd/webserver/htdocs/graphs/traffic_hourly.gif
|
||||
share/examples/honeyd/webserver/htdocs/images/arrow_down.gif
|
||||
share/examples/honeyd/webserver/htdocs/images/delete.gif
|
||||
share/examples/honeyd/webserver/htdocs/images/logo.gif
|
||||
share/examples/honeyd/webserver/htdocs/images/edit.gif
|
||||
share/examples/honeyd/webserver/htdocs/images/arrow_right.gif
|
||||
share/examples/honeyd/webserver/htdocs/images/add.gif
|
||||
share/examples/honeyd/webserver/htdocs/images/google_logo.gif
|
||||
share/examples/honeyd/webserver/htdocs/styles/layout.css
|
||||
share/examples/honeyd/webserver/htdocs/templates/inc/header.tmpl
|
||||
share/examples/honeyd/webserver/htdocs/templates/inc/footer.tmpl
|
||||
share/examples/honeyd/webserver/htdocs/templates/inc/main.tmpl
|
||||
share/examples/honeyd/webserver/htdocs/templates/inc/nav.tmpl
|
||||
share/examples/honeyd/webserver/htdocs/templates/status_connections.tmpl
|
||||
share/examples/honeyd/webserver/htdocs/templates/config_ip.tmpl
|
||||
share/examples/honeyd/webserver/htdocs/templates/index.tmpl
|
||||
share/examples/honeyd/webserver/htdocs/templates/status_stats.tmpl
|
||||
share/examples/honeyd/webserver/htdocs/config.py
|
||||
share/examples/honeyd/webserver/htdocs/index.py
|
||||
share/examples/honeyd/webserver/htmltmpl.py
|
||||
share/examples/honeyd/webserver/support.py
|
||||
share/examples/honeyd/webserver/server.py
|
||||
@dirrm share/examples/honeyd/webserver/htdocs/templates/inc
|
||||
@dirrm share/examples/honeyd/webserver/htdocs/templates
|
||||
@dirrm share/examples/honeyd/webserver/htdocs/styles
|
||||
@dirrm share/examples/honeyd/webserver/htdocs/images
|
||||
@dirrm share/examples/honeyd/webserver/htdocs/graphs
|
||||
@dirrm share/examples/honeyd/webserver/htdocs
|
||||
@dirrm share/examples/honeyd/webserver
|
||||
@dirrm share/examples/honeyd
|
||||
@dirrm share/doc/honeyd
|
||||
@dirrm lib/honeyd
|
||||
@dirrm include/honeyd
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/04/20 09:14:43 xtraeme Exp $
|
||||
$NetBSD: distinfo,v 1.2 2005/01/14 21:44:33 adrianp Exp $
|
||||
|
||||
SHA1 (honeyd-0.8b.tar.gz) = fe8054847b98003d52ec50a8376e51a9f76d41e5
|
||||
Size (honeyd-0.8b.tar.gz) = 523808 bytes
|
||||
SHA1 (patch-aa) = 8f6330238715a19951731372f70fefcea85e5df9
|
||||
SHA1 (honeyd-1.0.tar.gz) = abff00cf7815b6448e5432be8b4710f39bf2119f
|
||||
Size (honeyd-1.0.tar.gz) = 600339 bytes
|
||||
SHA1 (patch-aa) = 83d823e891e2837fab85a0cda5a67dded772c97d
|
||||
|
|
23
security/honeyd/options.mk
Normal file
23
security/honeyd/options.mk
Normal file
|
@ -0,0 +1,23 @@
|
|||
# $NetBSD: options.mk,v 1.1 2005/01/14 21:44:33 adrianp Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.honeyd
|
||||
PKG_SUPPORTED_OPTIONS= python rrdtool
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
###
|
||||
### Add python support
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mpython)
|
||||
. include "../../lang/python/extension.mk"
|
||||
CONFIGURE_ENV+= _PATH_PYTHON=${PYTHONBIN}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-python
|
||||
.endif
|
||||
|
||||
###
|
||||
### Add RRDTool support
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mrrdtool)
|
||||
. include "../../databases/rrdtool/buildlink3.mk"
|
||||
.endif
|
|
@ -1,8 +1,6 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/04/20 09:14:43 xtraeme Exp $
|
||||
|
||||
--- Makefile.in.orig 2004-04-20 11:00:09.000000000 +0200
|
||||
+++ Makefile.in 2004-04-20 11:01:05.000000000 +0200
|
||||
@@ -109,10 +109,10 @@
|
||||
--- Makefile.in.orig 2005-01-13 10:48:06.000000000 +0000
|
||||
+++ Makefile.in 2005-01-13 10:52:09.000000000 +0000
|
||||
@@ -112,10 +112,10 @@
|
||||
libhoneyd_DATA = libhoneyd.so
|
||||
|
||||
# Configuration files for Honeyd
|
||||
|
@ -15,12 +13,12 @@ $NetBSD: patch-aa,v 1.1.1.1 2004/04/20 09:14:43 xtraeme Exp $
|
|||
|
||||
|
||||
honeydplugins = @PLUGINS@
|
||||
@@ -146,7 +146,7 @@
|
||||
@@ -152,7 +152,7 @@
|
||||
honeydctl_INCLUDES = @EDITINC@
|
||||
honeydctl_CFLAGS = -O2 -Wall
|
||||
|
||||
-CFLAGS = -O2 -Wall -g -DPATH_HONEYDINCLUDE="\"$(honeydincludedir)\"" -DPATH_HONEYDDATA="\"$(honeyddatadir)\"" -DPATH_HONEYDLIB="\"$(honeydlibdir)\"" -DHONEYD_PLUGINS_DECLARE="$(honeydpluginsdeclare)" -DHONEYD_PLUGINS="$(honeydplugins)"
|
||||
+CFLAGS += -DPATH_HONEYDINCLUDE="\"$(honeydincludedir)\"" -DPATH_HONEYDDATA="\"$(sysconfdir)\"" -DPATH_HONEYDLIB="\"$(honeydlibdir)\"" -DHONEYD_PLUGINS_DECLARE="$(honeydpluginsdeclare)" -DHONEYD_PLUGINS="$(honeydplugins)"
|
||||
-CFLAGS = -O2 -Wall -g -DPATH_HONEYDINCLUDE="\"$(honeydincludedir)\"" -DPATH_HONEYDDATA="\"$(honeyddatadir)\"" -DPATH_HONEYDLIB="\"$(honeydlibdir)\"" -DHONEYD_PLUGINS_DECLARE="$(honeydpluginsdeclare)" -DHONEYD_PLUGINS="$(honeydplugins)" -DPATH_RRDTOOL="\"$(PATH_RRDTOOL)\""
|
||||
+CFLAGS += -DPATH_HONEYDINCLUDE="\"$(honeydincludedir)\"" -DPATH_HONEYDDATA="\"$(sysconfdir)\"" -DPATH_HONEYDLIB="\"$(honeydlibdir)\"" -DHONEYD_PLUGINS_DECLARE="$(honeydpluginsdeclare)" -DHONEYD_PLUGINS="$(honeydplugins)" -DPATH_RRDTOOL="\"$(PATH_RRDTOOL)\""
|
||||
|
||||
|
||||
INCLUDES = -I$(top_srcdir)/@DNETCOMPAT@ -I$(top_srcdir)/compat @PYTHONINC@ @EVENTINC@ @PCAPINC@ @DNETINC@
|
||||
INCLUDES = -I$(top_srcdir)/@DNETCOMPAT@ -I$(top_srcdir)/compat @PYTHONINC@ @EVENTINC@ @PCAPINC@ @DNETINC@ @ZINC@
|
||||
|
|
Loading…
Reference in a new issue