It looks like Interix wants function names to be prefixed with __ instead

of a single _.  So extend existing conditionals for Cygwin and MinGW to
also support Interix, hoping that this will fix the build problems shown
in tv@'s bulk build.
This commit is contained in:
jmmv 2005-01-18 12:06:37 +00:00
parent 7f318ec81a
commit bf7291aa38
5 changed files with 57 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.38 2005/01/12 11:20:20 jmmv Exp $
$NetBSD: distinfo,v 1.39 2005/01/18 12:06:37 jmmv Exp $
SHA1 (gtk+-2.6.1.tar.bz2) = a584abc1d43e68dc79ebfb9e5d09bd9aa1a77781
Size (gtk+-2.6.1.tar.bz2) = 11070668 bytes
@ -6,3 +6,7 @@ SHA1 (patch-aa) = ab8a71ffa3b44816bb6f53ced068f80132b67c09
SHA1 (patch-ab) = 764729f9ee7e8b66e7165c34da0863b033af9552
SHA1 (patch-ac) = 42dff743263b141029a814d7dec9fdc5637a3cff
SHA1 (patch-ad) = dad88a4ee8bdac6bd3ea32b16ce4e0a3d1b202ab
SHA1 (patch-ae) = 04dbb379cea2bc1ca2e26893abddd3679f8476b3
SHA1 (patch-af) = 0fa3e8958023d0e6bce456f89178c1cfdb551ff3
SHA1 (patch-ag) = 5bccfda9bda71aefe70993b59fa5a466349a165e
SHA1 (patch-ah) = 966f8a6cd3057c32c8fce937456b06efff9d27cd

13
x11/gtk2/patches/patch-ae Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.8 2005/01/18 12:06:37 jmmv Exp $
--- gdk-pixbuf/pixops/composite_line_22_4a4_mmx.S.orig 2004-08-11 16:23:31.000000000 +0200
+++ gdk-pixbuf/pixops/composite_line_22_4a4_mmx.S
@@ -4,7 +4,7 @@ gcc2_compiled.:
.text
.align 16
-#if !defined(__MINGW32__) && !defined(__CYGWIN__)
+#if !defined(__MINGW32__) && !defined(__CYGWIN__) && !defined(__INTERIX)
.globl _pixops_composite_line_22_4a4_mmx
.type _pixops_composite_line_22_4a4_mmx,@function

13
x11/gtk2/patches/patch-af Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.10 2005/01/18 12:06:37 jmmv Exp $
--- gdk-pixbuf/pixops/composite_line_color_22_4a4_mmx.S.orig 2004-08-11 16:23:31.000000000 +0200
+++ gdk-pixbuf/pixops/composite_line_color_22_4a4_mmx.S
@@ -4,7 +4,7 @@ gcc2_compiled.:
.text
.align 16
-#if !defined(__MINGW32__) && !defined(__CYGWIN__)
+#if !defined(__MINGW32__) && !defined(__CYGWIN__) && !defined(__INTERIX)
.globl _pixops_composite_line_color_22_4a4_mmx
.type _pixops_composite_line_color_22_4a4_mmx,@function

13
x11/gtk2/patches/patch-ag Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ag,v 1.6 2005/01/18 12:06:38 jmmv Exp $
--- gdk-pixbuf/pixops/have_mmx.S.orig 2004-08-11 16:23:31.000000000 +0200
+++ gdk-pixbuf/pixops/have_mmx.S
@@ -4,7 +4,7 @@ gcc2_compiled.:
.text
.align 16
-#if !defined(__MINGW32__) && !defined(__CYGWIN__)
+#if !defined(__MINGW32__) && !defined(__CYGWIN__) && !defined(__INTERIX)
.globl _pixops_have_mmx
.type _pixops_have_mmx,@function

13
x11/gtk2/patches/patch-ah Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ah,v 1.8 2005/01/18 12:06:38 jmmv Exp $
--- gdk-pixbuf/pixops/scale_line_22_33_mmx.S.orig 2004-08-11 16:23:31.000000000 +0200
+++ gdk-pixbuf/pixops/scale_line_22_33_mmx.S
@@ -4,7 +4,7 @@ gcc2_compiled.:
.text
.align 16
-#if !defined(__MINGW32__) && !defined(__CYGWIN__)
+#if !defined(__MINGW32__) && !defined(__CYGWIN__) && !defined(__INTERIX)
.globl _pixops_scale_line_22_33_mmx
.type _pixops_scale_line_22_33_mmx,@function