Update qdirstat to 1.5.
1.5 - (Optional) breadcrumbs navigation - (Optional) a new "details" panel for the currently selected item - (Optional) new tree columns: owner, group, permissions both in "rwxrwxrwx" and in octal format - Package manager support for the major Linux package managers (dpkg / rpm / pacman) to see what package a system file belongs to. - Quick-switchable different layouts for the main window - A new "General" page in the configuration dialog - Show in the window title if the program runs with root permissions (sudo etc.) - (Optional) show the URL in the window title - Some bug fixes 1.4 - File size statistics window with histogram - Filling the gaps in the treemap (directories with lots of small files) - Checked code with Coverity and fixed all issues it pointed out - Improved support for file and directory names with UTF-8 special characters (Qt 4 only issue) - Improved support for directories that have read, but not execute permissions 1.3 - File type statistics window - Locate files per directory by file type - Display path and size of the current item in the status line while hovering over a treemap tile - Optional alternate layout of the main window: Tree view and treemap side by side - Improved logging: More secure and rotating logs - New document: QDirStat for Headless Servers for server admins - New document: The GitHub Workflow for developers 1.2 - Btrfs improvements 1.1 - This is mostly a bug fix release with some small features thrown in.
This commit is contained in:
parent
f59d2e3947
commit
bf794d8e82
4 changed files with 9 additions and 30 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.4 2018/11/12 03:52:56 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2018/11/17 20:02:41 bsiegert Exp $
|
||||
|
||||
DISTNAME= qdirstat-1.0
|
||||
PKGREVISION= 3
|
||||
DISTNAME= qdirstat-1.5
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=shundhammer/}
|
||||
|
||||
|
@ -27,14 +26,13 @@ pre-configure:
|
|||
do-configure:
|
||||
cd ${WRKSRC} && qmake
|
||||
|
||||
INSTALLATION_DIRS= bin share/applications share/pixmaps share/doc/qdirstat
|
||||
#INSTALLATION_DIRS= bin share/applications share/pixmaps share/doc/qdirstat
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/qdirstat ${DESTDIR}${PREFIX}/bin/qdirstat
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/scripts/qdirstat-cache-writer ${DESTDIR}${PREFIX}/bin/qdirstat-cache-writer
|
||||
${INSTALL_DATA} ${WRKSRC}/src/qdirstat.desktop ${DESTDIR}${PREFIX}/share/applications/qdirstat.desktop
|
||||
${INSTALL_DATA} ${WRKSRC}/src/icons/qdirstat.png ${DESTDIR}${PREFIX}/share/pixmaps/qdirstat.png
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} Contributing.md DevHistory.md README.md TODO.md LICENSE ${DESTDIR}${PREFIX}/share/doc/qdirstat/
|
||||
|
||||
.include "../../x11/qt5-qtbase/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,10 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2018/06/14 00:24:26 markd Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2018/11/17 20:02:41 bsiegert Exp $
|
||||
bin/qdirstat
|
||||
bin/qdirstat-cache-writer
|
||||
share/applications/qdirstat.desktop
|
||||
share/doc/qdirstat/Contributing.md
|
||||
share/doc/qdirstat/DevHistory.md
|
||||
share/doc/qdirstat/LICENSE
|
||||
share/doc/qdirstat/README.md
|
||||
share/doc/qdirstat/TODO.md
|
||||
share/pixmaps/qdirstat.png
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2018/06/14 00:24:26 markd Exp $
|
||||
$NetBSD: distinfo,v 1.2 2018/11/17 20:02:41 bsiegert Exp $
|
||||
|
||||
SHA1 (qdirstat-1.0.tar.gz) = dd459a622ca014ca96b0ed853525ccb56ee15fa6
|
||||
RMD160 (qdirstat-1.0.tar.gz) = 057f20e284117cd102b3ef31eeaad3470531eda7
|
||||
SHA512 (qdirstat-1.0.tar.gz) = 9e98ea690fd84b435f1b4078c79350a7c0ee6b48560dc500fc9410633a650539c2db16f0526e181700580de0ee8b3044d1219eafc9870cd7e421511159b6d11d
|
||||
Size (qdirstat-1.0.tar.gz) = 805110 bytes
|
||||
SHA1 (patch-src_DirReadJob.cpp) = da39fbb62c5e008961097bd65fad783de109f5ab
|
||||
SHA1 (qdirstat-1.5.tar.gz) = ecae0055791038f4add1ee8b256bc27070c1dc16
|
||||
RMD160 (qdirstat-1.5.tar.gz) = 877e3320867200422dd920d09ec8a6f45a30e43b
|
||||
SHA512 (qdirstat-1.5.tar.gz) = 7cafce3a085c4a9c4dc1ce1814d8bed9e0dbb9416b03dc49681b070c15cb114dfcf269c8f293671cc29b4e54c37d22b9ebff013902b147ce45592982d3ba8cbe
|
||||
Size (qdirstat-1.5.tar.gz) = 4546980 bytes
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-src_DirReadJob.cpp,v 1.1 2018/06/14 00:24:26 markd Exp $
|
||||
|
||||
--- src/DirReadJob.cpp.orig 2016-05-16 13:49:54.000000000 +0000
|
||||
+++ src/DirReadJob.cpp
|
||||
@@ -11,7 +11,7 @@
|
||||
#include <sys/stat.h>
|
||||
#include <unistd.h>
|
||||
#include <stdio.h>
|
||||
-#include <sys/errno.h>
|
||||
+#include <errno.h>
|
||||
|
||||
#include <QMutableListIterator>
|
||||
|
Loading…
Reference in a new issue