-fix the libtoolization
-use python buildlink file -install examples into version dependant subdir to avoid conflicts
This commit is contained in:
parent
4ae2715be1
commit
bfd38e3d3d
4 changed files with 34 additions and 24 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/03/21 23:36:07 jwise Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2002/01/19 15:03:35 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ExpectPy-1.9b1
|
||||
PKGNAME= py-expect-1.9b1
|
||||
PKGNAME= ${PYPKGPREFIX}-expect-1.9b1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pub/sourceforge/expectpy/}
|
||||
|
||||
|
@ -10,7 +10,6 @@ MAINTAINER= jwise@netbsd.org
|
|||
HOMEPAGE= http://www.sourceforge.net/projects/expectpy/
|
||||
COMMENT= Expect module for Python
|
||||
|
||||
DEPENDS+= python>=2.0:../../lang/python
|
||||
DEPENDS+= tcl-expect>=5.32.1:../../lang/tcl-expect
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
|
@ -18,14 +17,19 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ARGS+= --with-python=${LOCALBASE} \
|
||||
--with-expect=${LOCALBASE} \
|
||||
--with-tcl --enable-shared
|
||||
CONFIGURE_ENV+= PYTHON=${PYTHONBIN}
|
||||
INSTALL_TARGET= installshared
|
||||
PY_PATCHPLIST= yes
|
||||
PLIST_SUBST+= PYLIB=${PYLIB} PYPKGPREFIX=${PYPKGPREFIX}
|
||||
|
||||
pre-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/python/py-expect
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/ask.py ${PREFIX}/share/examples/python/py-expect
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/glob.py ${PREFIX}/share/examples/python/py-expect
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/ping.py ${PREFIX}/share/examples/python/py-expect
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/telnet.py ${PREFIX}/share/examples/python/py-expect
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/xping.py ${PREFIX}/share/examples/python/py-expect
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples/${PYPKGPREFIX}-expect
|
||||
EXAMPLESFILES= ask.py glob.py ping.py telnet.py xping.py
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${EXAMPLESDIR}
|
||||
.for f in ${EXAMPLESFILES}
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/$f ${EXAMPLESDIR}
|
||||
.endfor
|
||||
|
||||
.include "../../lang/python/extension.buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2001/11/01 01:26:07 zuntum Exp $
|
||||
lib/python2.0/lib-dynload/ExpectPymodule.so
|
||||
share/examples/python/py-expect/ask.py
|
||||
share/examples/python/py-expect/glob.py
|
||||
share/examples/python/py-expect/ping.py
|
||||
share/examples/python/py-expect/telnet.py
|
||||
share/examples/python/py-expect/xping.py
|
||||
@dirrm share/examples/python/py-expect
|
||||
@comment $NetBSD: PLIST,v 1.2 2002/01/19 15:03:36 drochner Exp $
|
||||
${PYLIB}/lib-dynload/ExpectPymodule.so
|
||||
share/examples/${PYPKGPREFIX}-expect/ask.py
|
||||
share/examples/${PYPKGPREFIX}-expect/glob.py
|
||||
share/examples/${PYPKGPREFIX}-expect/ping.py
|
||||
share/examples/${PYPKGPREFIX}-expect/telnet.py
|
||||
share/examples/${PYPKGPREFIX}-expect/xping.py
|
||||
@dirrm share/examples/${PYPKGPREFIX}-expect
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/21 00:44:44 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2002/01/19 15:03:36 drochner Exp $
|
||||
|
||||
SHA1 (ExpectPy-1.9b1.tar.gz) = f43fcd53901f327dc8acf0650dbfe45b274a8d7d
|
||||
Size (ExpectPy-1.9b1.tar.gz) = 149580 bytes
|
||||
|
@ -6,4 +6,4 @@ SHA1 (patch-aa) = eff544e7290736bebb81b8391848369d630f7b03
|
|||
SHA1 (patch-ab) = 751f56a7a71822dbb93530dd9396bc92f9def05b
|
||||
SHA1 (patch-ac) = 0ff7162129a84fbc913a8b1240209387b922c2a8
|
||||
SHA1 (patch-ad) = 267c2e93f89f786b415c7fa2645913c40541bc38
|
||||
SHA1 (patch-ae) = 349abc99878b3df93cf122f57cc996602ac10368
|
||||
SHA1 (patch-ae) = 0f5190724d3b17e7b7f06f6408e1c9e7a3e66868
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2001/03/21 23:36:07 jwise Exp $
|
||||
--- explib/Makefile.in.orig Sat Nov 4 05:27:16 2000
|
||||
+++ explib/Makefile.in Wed Mar 21 15:01:18 2001
|
||||
@@ -13,11 +13,11 @@
|
||||
$NetBSD: patch-ae,v 1.2 2002/01/19 15:03:37 drochner Exp $
|
||||
|
||||
--- explib/Makefile.in.orig Sat Nov 4 14:27:16 2000
|
||||
+++ explib/Makefile.in Sat Jan 19 15:58:50 2002
|
||||
@@ -13,15 +13,15 @@
|
||||
OBJS = exp_clib.o $(EXPLIB_REGEXP)
|
||||
DUMMYOBJS= dummy.o
|
||||
|
||||
|
@ -15,3 +16,8 @@ $NetBSD: patch-ae,v 1.1.1.1 2001/03/21 23:36:07 jwise Exp $
|
|||
libexplib.as: $(OBJS:.o=.os)
|
||||
ar r $@ $(OBJS:.o=.os)
|
||||
libdummy.a: $(DUMMYOBJS)
|
||||
- ar r $@ $(DUMMYOBJS)
|
||||
+ ${LD} -o libdummy.la $(DUMMYOBJS:.o=.lo)
|
||||
libdummy.as: $(DUMMYOBJS:.o=.os)
|
||||
ar r $@ $(DUMMYOBJS:.o=.os)
|
||||
|
||||
|
|
Loading…
Reference in a new issue