Update gauche to 0.8.6. Patch provided by Kenji Hisazumi.

From this release we don't use external Boehm GC library because
gauche needs GC to be built with special compilation options.

New features in 0.8.6:

    * New modules:

	+ dbi: Database independent access layer, providing unified
	  access to various relational databases. You need separate
	  "driver" packages to access the actual RDBMS. There are a
	  few driver packages available at
	  http://www.kahua.org/cgi-bin/kahua.fcgi/kahua-web/show/dev/DBI/.
	    Note: If you have been using the separate dbi module, make
	    sure you remove it before using the new dbi and dbd
	    modules. You can find the old dbi.scm under somewhere like
	    /usr/local/share/gauche/site/lib (the actualy directory
	    depends on the configuration when you've installed the dbi
	    module).
	+ util.relation: A framework to work with relations (as defined
	  by Codd). The result of database access via dbi is represened as
	  a relation.
	+ text.sql: SQL parser/constructor. Full features are not
	  implemented yet, but used in dbi module for prepared queries.

    * New SRFIs:

	+ SRFI-40 (Library of streams) as util.stream.
	+ SRFI-43 (vector library) as srfi-43.
	+ SRFI-45 (Primitives for Expressing Iterative Lazy
	    Algorithms) : built-in.

    * New built-in proceduers global-variable-bound? and
      glboal-variable-ref. The former supersedes symbol-bound? (
      symbol-bound? is now deprecated and will go away in the future
      releases. Code that uses symbol-bound? should change it to
      global-variable-bound?. ). The latter removes some need of using
      eval just to peek the value of the global variable.

    * New regexp procedures: regexp-replace*, regexp-replace-all*,
      regexp-case-fold?.

    * Stack overflow handling is largely improved. You can see better
      performance if your script frequently oveflows the stack.

0.8.5 was a maintainance release.

0.8.4:

Gauche 0.8.4:

The compiler and VM have been rewritten. Now Gauche runs faster with
less memory (as fast as 1.9x, or cosumes 0.7x memory, in best cases of
our tests. But your mileage may vary.) The compiler now does simple
closure optimization, so the typical loop-by-local-closure style code
will get the advantage. On the other hand, you won't see much gain in
OO-heavy or library-heavy programs.

Other changes:

    * New features:

	  + srfi-42 (Eager comprehension) is supported.
	  + srfi-55 (require-extension) is supported.
	  + A simple sampling profiler is implemented to help tuning
	    programs. Check out "Profiling and tuning" section of the
	    reference manual. The profiler may not be available on all
	    platforms.
	  + We provide an experimenal Windows/MinGW binary package for
	    the convenience. See download page.
This commit is contained in:
uebayasi 2005-12-09 15:38:54 +00:00
parent dec9de3db0
commit bfdc779de0
9 changed files with 46 additions and 174 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: CHANGES,v 1.12146 2005/12/09 13:50:55 tron Exp $
$NetBSD: CHANGES,v 1.12147 2005/12/09 15:39:59 uebayasi Exp $
Changes to the packages collection and infrastructure in 2005:
@ -5538,3 +5538,4 @@ Changes to the packages collection and infrastructure in 2005:
Updated net/nmapfe to 0.9.5nb22 [salo 2005-12-08]
Updated chat/silc-server to 1.0.1 [salo 2005-12-09]
Updated databases/phpmyadmin to 2.7.0pl1 [tron 2005-12-09]
Updated lang/gauche to 0.8.6 [uebayasi 2005-12-09]

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.31 2005/12/05 23:55:09 rillig Exp $
# $NetBSD: Makefile,v 1.32 2005/12/09 15:38:54 uebayasi Exp $
#
DISTNAME= Gauche-0.8.3
PKGREVISION= 1
DISTNAME= Gauche-0.8.6
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gauche/}
EXTRACT_SUFX= .tgz
@ -34,7 +33,6 @@ LDFLAGS+= ${BUILDLINK_LIBICONV_LDADD}
USE_MAKEINFO= YES
INFO_FILES= gauche-refe.info gauche-refj.info
.include "../../devel/boehm-gc/buildlink3.mk"
.include "../../converters/libiconv/buildlink3.mk"
.include "../../mk/dlopen.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.11 2005/03/07 03:16:46 uebayasi Exp $
@comment $NetBSD: PLIST,v 1.12 2005/12/09 15:38:54 uebayasi Exp $
bin/gauche-cesconv
bin/gauche-config
bin/gauche-install
@ -7,6 +7,7 @@ bin/gosh
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/auxsys.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/binary.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/fcntl.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/file-util-lib.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/gauche-cesconv
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/gauche-config
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/gauche-install
@ -21,9 +22,17 @@ lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/md5.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/mt-random.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/ndbm.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/sha1.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/srfi-1-lib.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/srfi-13-lib.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/srfi-19-lib.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/srfi-43-lib.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/sxml-ssax.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/sxml-sxpath.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/sxml-tools.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/syslog.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/termios.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/threads.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/util-match-lib.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/vport.so
lib/gauche/${PKGVERSION}/include/gauche.h
lib/gauche/${PKGVERSION}/include/gauche/arch.h
@ -34,9 +43,11 @@ lib/gauche/${PKGVERSION}/include/gauche/char_sjis.h
lib/gauche/${PKGVERSION}/include/gauche/char_utf_8.h
lib/gauche/${PKGVERSION}/include/gauche/class.h
lib/gauche/${PKGVERSION}/include/gauche/config.h
lib/gauche/${PKGVERSION}/include/gauche/code.h
lib/gauche/${PKGVERSION}/include/gauche/exception.h
lib/gauche/${PKGVERSION}/include/gauche/extend.h
lib/gauche/${PKGVERSION}/include/gauche/int64.h
lib/gauche/${PKGVERSION}/include/gauche/mingw-compat.h
lib/gauche/${PKGVERSION}/include/gauche/net.h
lib/gauche/${PKGVERSION}/include/gauche/pthread.h
lib/gauche/${PKGVERSION}/include/gauche/scmconst.h
@ -44,9 +55,12 @@ lib/gauche/${PKGVERSION}/include/gauche/uthread.h
lib/gauche/${PKGVERSION}/include/gauche/uvector.h
lib/gauche/${PKGVERSION}/include/gauche/vm.h
lib/gauche/${PKGVERSION}/include/gauche/vminsn.h
lib/gauche/${PKGVERSION}/include/gc.h
lib/gauche/${PKGVERSION}/include/gc_config_macros.h
lib/gauche/${PKGVERSION}/include/gc_pthread_redirects.h
lib/libgauche.so
lib/libgauche.so.${PKGVERSION}
lib/libgauche.so.0
lib/libgauche.so
man/man1/gauche-config.1
man/man1/gosh.1
share/aclocal/gauche.m4
@ -56,6 +70,8 @@ share/gauche/${PKGVERSION}/lib/binary/pack.scm
share/gauche/${PKGVERSION}/lib/cesconv
share/gauche/${PKGVERSION}/lib/compat/jfilter.scm
share/gauche/${PKGVERSION}/lib/compat/stk.scm
share/gauche/${PKGVERSION}/lib/dbd/null.scm
share/gauche/${PKGVERSION}/lib/dbi.scm
share/gauche/${PKGVERSION}/lib/dbm.scm
share/gauche/${PKGVERSION}/lib/dbm/fsdbm.scm
${USE_GDBM}share/gauche/${PKGVERSION}/lib/dbm/gdbm.scm
@ -82,7 +98,6 @@ share/gauche/${PKGVERSION}/lib/gauche/interpolate.scm
share/gauche/${PKGVERSION}/lib/gauche/let-opt.scm
share/gauche/${PKGVERSION}/lib/gauche/libutil.scm
share/gauche/${PKGVERSION}/lib/gauche/listener.scm
share/gauche/${PKGVERSION}/lib/gauche/listutil.scm
share/gauche/${PKGVERSION}/lib/gauche/logger.scm
share/gauche/${PKGVERSION}/lib/gauche/logical.scm
share/gauche/${PKGVERSION}/lib/gauche/macroutil.scm
@ -94,9 +109,9 @@ share/gauche/${PKGVERSION}/lib/gauche/mop/singleton.scm
share/gauche/${PKGVERSION}/lib/gauche/mop/validator.scm
share/gauche/${PKGVERSION}/lib/gauche/net.scm
share/gauche/${PKGVERSION}/lib/gauche/numerical.scm
share/gauche/${PKGVERSION}/lib/gauche/object.scm
share/gauche/${PKGVERSION}/lib/gauche/package.scm
share/gauche/${PKGVERSION}/lib/gauche/package/build.scm
share/gauche/${PKGVERSION}/lib/gauche/package/compile.scm
share/gauche/${PKGVERSION}/lib/gauche/package/fetch.scm
share/gauche/${PKGVERSION}/lib/gauche/package/util.scm
share/gauche/${PKGVERSION}/lib/gauche/parameter.scm
@ -123,10 +138,10 @@ share/gauche/${PKGVERSION}/lib/gauche/time.scm
share/gauche/${PKGVERSION}/lib/gauche/uvector.scm
share/gauche/${PKGVERSION}/lib/gauche/validator.scm
share/gauche/${PKGVERSION}/lib/gauche/version.scm
share/gauche/${PKGVERSION}/lib/gauche/vport.scm
share/gauche/${PKGVERSION}/lib/gauche/vm/debugger.scm
share/gauche/${PKGVERSION}/lib/gauche/vm/disasm.scm
share/gauche/${PKGVERSION}/lib/gauche/with.scm
share/gauche/${PKGVERSION}/lib/gauche/vm/insn.scm
share/gauche/${PKGVERSION}/lib/gauche/vm/profiler.scm
share/gauche/${PKGVERSION}/lib/gauche/vport.scm
share/gauche/${PKGVERSION}/lib/genstub
share/gauche/${PKGVERSION}/lib/math/const.scm
share/gauche/${PKGVERSION}/lib/math/mt-random.scm
@ -144,42 +159,12 @@ share/gauche/${PKGVERSION}/lib/slib.scm
share/gauche/${PKGVERSION}/lib/slibcat
share/gauche/${PKGVERSION}/lib/srfi-0.scm
share/gauche/${PKGVERSION}/lib/srfi-1.scm
share/gauche/${PKGVERSION}/lib/srfi-1/cat.scm
share/gauche/${PKGVERSION}/lib/srfi-1/filter.scm
share/gauche/${PKGVERSION}/lib/srfi-1/finder.scm
share/gauche/${PKGVERSION}/lib/srfi-1/folder.scm
share/gauche/${PKGVERSION}/lib/srfi-1/generator.scm
share/gauche/${PKGVERSION}/lib/srfi-1/mapper.scm
share/gauche/${PKGVERSION}/lib/srfi-1/nary.scm
share/gauche/${PKGVERSION}/lib/srfi-1/nth.scm
share/gauche/${PKGVERSION}/lib/srfi-1/pred.scm
share/gauche/${PKGVERSION}/lib/srfi-1/selector.scm
share/gauche/${PKGVERSION}/lib/srfi-1/set.scm
share/gauche/${PKGVERSION}/lib/srfi-1/zipper.scm
share/gauche/${PKGVERSION}/lib/srfi-11.scm
share/gauche/${PKGVERSION}/lib/srfi-13.scm
share/gauche/${PKGVERSION}/lib/srfi-13/casemap.scm
share/gauche/${PKGVERSION}/lib/srfi-13/comparer.scm
share/gauche/${PKGVERSION}/lib/srfi-13/filter.scm
share/gauche/${PKGVERSION}/lib/srfi-13/folder.scm
share/gauche/${PKGVERSION}/lib/srfi-13/generator.scm
share/gauche/${PKGVERSION}/lib/srfi-13/hash.scm
share/gauche/${PKGVERSION}/lib/srfi-13/internal.scm
share/gauche/${PKGVERSION}/lib/srfi-13/kmp.scm
share/gauche/${PKGVERSION}/lib/srfi-13/misc.scm
share/gauche/${PKGVERSION}/lib/srfi-13/pred.scm
share/gauche/${PKGVERSION}/lib/srfi-13/prefix.scm
share/gauche/${PKGVERSION}/lib/srfi-13/revapp.scm
share/gauche/${PKGVERSION}/lib/srfi-13/rotator.scm
share/gauche/${PKGVERSION}/lib/srfi-13/searcher.scm
share/gauche/${PKGVERSION}/lib/srfi-13/selector.scm
share/gauche/${PKGVERSION}/lib/srfi-14.scm
share/gauche/${PKGVERSION}/lib/srfi-14/query.scm
share/gauche/${PKGVERSION}/lib/srfi-14/set.scm
share/gauche/${PKGVERSION}/lib/srfi-19.scm
share/gauche/${PKGVERSION}/lib/srfi-19/format.scm
share/gauche/${PKGVERSION}/lib/srfi-19/read-tai.scm
share/gauche/${PKGVERSION}/lib/srfi-2.scm
share/gauche/${PKGVERSION}/lib/srfi-26.scm
share/gauche/${PKGVERSION}/lib/srfi-27.scm
share/gauche/${PKGVERSION}/lib/srfi-29.scm
@ -188,7 +173,10 @@ share/gauche/${PKGVERSION}/lib/srfi-29/format.scm
share/gauche/${PKGVERSION}/lib/srfi-31.scm
share/gauche/${PKGVERSION}/lib/srfi-37.scm
share/gauche/${PKGVERSION}/lib/srfi-4.scm
share/gauche/${PKGVERSION}/lib/srfi-42.scm
share/gauche/${PKGVERSION}/lib/srfi-43.scm
share/gauche/${PKGVERSION}/lib/srfi-5.scm
share/gauche/${PKGVERSION}/lib/srfi-55.scm
share/gauche/${PKGVERSION}/lib/srfi-7.scm
share/gauche/${PKGVERSION}/lib/srfi-9.scm
share/gauche/${PKGVERSION}/lib/sxml/adaptor.scm
@ -203,6 +191,7 @@ share/gauche/${PKGVERSION}/lib/text/gettext.scm
share/gauche/${PKGVERSION}/lib/text/html-lite.scm
share/gauche/${PKGVERSION}/lib/text/info.scm
share/gauche/${PKGVERSION}/lib/text/parse.scm
share/gauche/${PKGVERSION}/lib/text/sql.scm
share/gauche/${PKGVERSION}/lib/text/tr.scm
share/gauche/${PKGVERSION}/lib/text/tree.scm
share/gauche/${PKGVERSION}/lib/util/combinations.scm
@ -213,10 +202,20 @@ share/gauche/${PKGVERSION}/lib/util/list.scm
share/gauche/${PKGVERSION}/lib/util/match.scm
share/gauche/${PKGVERSION}/lib/util/queue.scm
share/gauche/${PKGVERSION}/lib/util/record.scm
share/gauche/${PKGVERSION}/lib/util/relation.scm
share/gauche/${PKGVERSION}/lib/util/stream.scm
share/gauche/${PKGVERSION}/lib/util/toposort.scm
share/gauche/${PKGVERSION}/lib/util/tree.scm
share/gauche/${PKGVERSION}/lib/www/cgi-test.scm
share/gauche/${PKGVERSION}/lib/www/cgi.scm
share/gauche/${PKGVERSION}/template.DIST
share/gauche/${PKGVERSION}/template.Makefile.in
share/gauche/${PKGVERSION}/template.configure.ac
share/gauche/${PKGVERSION}/template.extension.c
share/gauche/${PKGVERSION}/template.extension.h
share/gauche/${PKGVERSION}/template.extensionlib.stub
share/gauche/${PKGVERSION}/template.module.scm
share/gauche/${PKGVERSION}/template.test.scm
@exec ${MKDIR} %D/lib/gauche/site 2>/dev/null || ${TRUE}
@exec ${MKDIR} %D/lib/gauche/site/${PKGVERSION} 2>/dev/null || ${TRUE}
@exec ${MKDIR} %D/lib/gauche/site/${PKGVERSION}/${MACHINE_GNU_PLATFORM} 2>/dev/null || ${TRUE}
@ -227,10 +226,7 @@ share/gauche/${PKGVERSION}/lib/www/cgi.scm
@dirrm share/gauche/${PKGVERSION}/lib/text
@dirrm share/gauche/${PKGVERSION}/lib/sxml
@dirrm share/gauche/${PKGVERSION}/lib/srfi-29
@dirrm share/gauche/${PKGVERSION}/lib/srfi-19
@dirrm share/gauche/${PKGVERSION}/lib/srfi-14
@dirrm share/gauche/${PKGVERSION}/lib/srfi-13
@dirrm share/gauche/${PKGVERSION}/lib/srfi-1
@dirrm share/gauche/${PKGVERSION}/lib/rfc
@dirrm share/gauche/${PKGVERSION}/lib/math
@dirrm share/gauche/${PKGVERSION}/lib/gauche/vm
@ -241,6 +237,7 @@ share/gauche/${PKGVERSION}/lib/www/cgi.scm
@dirrm share/gauche/${PKGVERSION}/lib/gauche
@dirrm share/gauche/${PKGVERSION}/lib/file
@dirrm share/gauche/${PKGVERSION}/lib/dbm
@dirrm share/gauche/${PKGVERSION}/lib/dbd
@dirrm share/gauche/${PKGVERSION}/lib/compat
@dirrm share/gauche/${PKGVERSION}/lib/binary
@dirrm share/gauche/${PKGVERSION}/lib

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.3 2004/11/26 09:39:30 jlam Exp $
# $NetBSD: buildlink3.mk,v 1.4 2005/12/09 15:38:54 uebayasi Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
GAUCHE_BUILDLINK3_MK:= ${GAUCHE_BUILDLINK3_MK}+
@ -15,7 +15,6 @@ BUILDLINK_DEPENDS.Gauche+= Gauche>=0.8.1
BUILDLINK_PKGSRCDIR.Gauche?= ../../lang/gauche
.endif # GAUCHE_BUILDLINK3_MK
.include "../../devel/boehm-gc/buildlink3.mk"
.include "../../converters/libiconv/buildlink3.mk"
.include "../../mk/dlopen.buildlink3.mk"

View file

@ -1,9 +1,5 @@
$NetBSD: distinfo,v 1.16 2005/02/24 09:03:07 agc Exp $
$NetBSD: distinfo,v 1.17 2005/12/09 15:38:54 uebayasi Exp $
SHA1 (Gauche-0.8.3.tgz) = c60282eb7cd4080dbe80d56f4327574820642526
RMD160 (Gauche-0.8.3.tgz) = fb2aff12825041c6b655f2b4b1216d150c5f76dd
Size (Gauche-0.8.3.tgz) = 2534879 bytes
SHA1 (patch-aa) = 81a351b08cbd957242f88eb43d26c65ba95fe2f2
SHA1 (patch-ab) = c08f8b9fbed9d9f41cddfddb386a756e8bd322cc
SHA1 (patch-ac) = e07cbf9604b53781952dbef297fd7360ec9bda3f
SHA1 (patch-ad) = bb1b71c43f01ba7b0be270164a53e9b16da1981b
SHA1 (Gauche-0.8.6.tgz) = 8ce200011da2eff925c8ccf65502529df379f2b8
RMD160 (Gauche-0.8.6.tgz) = e6986c2602926b6a5c16a41838212bd041a4fbae
Size (Gauche-0.8.6.tgz) = 2881800 bytes

View file

@ -1,21 +0,0 @@
$NetBSD: patch-aa,v 1.3 2004/03/29 09:34:27 kei Exp $
--- doc/gauche-ref.texi.orig 2004-02-05 06:30:07.000000000 +0900
+++ doc/gauche-ref.texi 2004-03-29 01:55:04.000000000 +0900
@@ -5,14 +5,14 @@
@settitle Gauche Reference Manual
@dircategory The Algorithmic Language Scheme
@direntry
-* Gauche Reference: (gauche-refe.info). An R5RS Scheme implementation.
+* Gauche Reference: (gauche-refe). An R5RS Scheme implementation.
@end direntry
@c JP
@setfilename gauche-refj.info
@settitle Gauche リファレンスマニュアル
@dircategory The Algorithmic Language Scheme
@direntry
-* Gauche Reference (ja): (gauche-refj.info). An R5RS Scheme implementation.
+* Gauche Reference (ja): (gauche-refj). An R5RS Scheme implementation.
@end direntry
@c COMMON
@comment %**end of header

View file

@ -1,33 +0,0 @@
$NetBSD: patch-ab,v 1.3 2004/03/29 09:34:27 kei Exp $
--- Makefile.in.orig 2004-03-29 08:52:23.000000000 +0900
+++ Makefile.in 2004-03-29 08:52:42.000000000 +0900
@@ -13,8 +13,8 @@
srcdir = @srcdir@
datadir = @datadir@
-SUBDIRS = gc src lib ext doc
-SRIDBUS = doc ext lib src gc
+SUBDIRS = src lib ext doc
+SRIDBUS = doc ext lib src
MKINSTDIR = @top_srcdir@/mkinstalldirs
INSTALL = @INSTALL@
GAUCHE_VERSION = @GAUCHE_VERSION@
@@ -22,7 +22,7 @@
DESTDIR =
CONFIG_GENERATED = Makefile config.cache config.log config.status libtool \
- configure.lineno autom4* gc/autom4*
+ configure.lineno autom4*
AUTOCONF_GENERATED = $(CONFIG_GENERATED) configure
all:
@@ -64,7 +64,7 @@
maintainer-clean: clean
for d in $(SRIDBUS); do (cd $$d; $(MAKE) maintainer-clean); done
- rm -rf $(AUTOCONF_GENERATED) VERSION INSTALL INSTALL.eucjp DIST_EXCLUDE_X gc/configure
+ rm -rf $(AUTOCONF_GENERATED) VERSION INSTALL INSTALL.eucjp DIST_EXCLUDE_X
dist:
@echo "To create a distribution tarball, use DIST script."

View file

@ -1,52 +0,0 @@
$NetBSD: patch-ac,v 1.4 2005/01/16 08:57:55 kei Exp $
--- src/Makefile.in.orig 2004-11-22 07:36:28.000000000 +0900
+++ src/Makefile.in 2005-01-16 17:42:25.000000000 +0900
@@ -46,7 +46,7 @@
# These are set by configure
DEFS = @DEFS@
OPTFLAGS = @OPTFLAGS@
-INCLUDES = -I$(srcdir) -I$(srcdir)/../gc/include @LOCAL_INC@
+INCLUDES = -I$(srcdir) -I@prefix@/include/gc @LOCAL_INC@
RANLIB = @RANLIB@
OBJEXT = @OBJEXT@
EXEEXT = @EXEEXT@
@@ -81,10 +81,7 @@
SITE_ARCH_DIR = $(GAUCHE_ARCH_DIR)/site/@GAUCHE_VERSION@/@host@
ARCH = @host@
-INSTALL_HEADERS = gauche.h \
- ../gc/include/gc.h \
- ../gc/include/gc_config_macros.h \
- ../gc/include/gc_pthread_redirects.h
+INSTALL_HEADERS = gauche.h
INSTALL_SUBHEADERS = gauche/config.h gauche/vm.h gauche/vminsn.h \
gauche/char_euc_jp.h gauche/char_utf_8.h \
gauche/char_sjis.h gauche/char_none.h \
@@ -108,7 +105,7 @@
# build -----------------------------------------------
-GCLIB = ../gc/libgc.la
+GCLIB = @prefix@/lib/libgc.la
gosh_SOURCES = main.c
gosh_OBJECTS = main.$(OBJEXT)
@@ -140,7 +137,7 @@
$(LINK) $(gosh_LDFLAGS) -o gosh$(EXEEXT) $(gosh_OBJECTS) $(gosh_LDADD) $(LIBS)
relink :
- $(RELINK) $(libgauche_LDFLAGS) libgauche.$(SOEXT) $(libgauche_OBJECTS) ../gc/*.lo $(LIBS)
+ $(RELINK) $(libgauche_LDFLAGS) libgauche.$(SOEXT) $(libgauche_OBJECTS) @prefix@/lib/libgc.$(SOEXT) $(LIBS)
$(RELINK) $(gosh_LDFLAGS) -o gosh$(EXEEXT) $(gosh_OBJECTS) $(gosh_LDADD) $(LIBS)
$(OBJECTS) : $(HEADERS)
@@ -164,7 +161,7 @@
load.$(OBJEXT) : dl_dlopen.c dl_dummy.c dl_win.c dl_darwin.c
libgauche.$(SOEXT) : $(libgauche_OBJECTS) $(GCLIB)
- $(LINK) $(libgauche_LDFLAGS) libgauche.$(SOEXT) $(libgauche_OBJECTS) ../gc/*.lo $(LIBS)
+ $(LINK) $(libgauche_LDFLAGS) libgauche.$(SOEXT) $(libgauche_OBJECTS) @prefix@/lib/libgc.$(SOEXT) $(LIBS)
$(POSTBUILD)
gauche/arch.h :

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ad,v 1.5 2005/01/27 10:15:35 minoura Exp $
--- configure.orig 2004-12-03 14:14:15.000000000 +0900
+++ configure 2005-01-27 11:38:21.000000000 +0900
@@ -8097,7 +8097,7 @@
case "$host" in
i686-*) I686OPT="-DUSE_I686_PREFETCH";;
esac
-if test $CC = "gcc"; then
+if test "$GCC" = "yes"; then
case "$target" in
*mingw*) ;;
*) GCCOPT="-fomit-frame-pointer";;