Update to 1.1.7
Changelog: Release 1.1.7 (21 Feb 2013) --------------------------- * Back out dangerous change to thread.h that was in 1.1.6, which could cause performance problems. * Compile fix for WIN32 in strutil.cpp * Compile fix for Windows XP - add implementation of InterlockedExchangeAdd64 Release 1.1.6 (11 Feb 2013) --------------------------- * Fix bug that could generate NaNs or other bad values near the poles of very blurry environment lookups specifically from OpenEXR latlong env maps. * Fix bug in oiiotool --crop where it could mis-parse the geometric parameter. * Fix bug in ImageCache::invalidate() where it did not properly delete the fingerprint of an invalidated file. * Cleanup and fixes in the oiiotool command line help messages. * New function ImageBufAlgo::paste() copies a region from one IB to another. * oiiotool --fit resizes an image to fit into a given resolution (keeping the original aspect ratio and padding with black if needed). * ImageBufAlgo::channels() and "oiiotool --ch" have been extended to allow new channels (specified to be filled with numeric constants) to also be named. * New function ImageBufAlgo::mul() and "oiiotool --cmul" let you multiply an image by a scalar constant (or per-channel constant). * Important maketx bug fix: when creating latlong environment maps as OpenEXR files, it was adding energy near the poles, making low-res MIP levels too bright near the poles. * Fix to "oiiotool --text" and "oiiotool --fill" -- both were incorrectly making the base image black rather than drawing overtop of the previous image. * Fix FreeBSD compile when not using TBB. * New oiiotool --swap exchanges the top two items on the image stack.
This commit is contained in:
parent
f3b84348cf
commit
bfdf0df5f9
3 changed files with 24 additions and 17 deletions
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.8 2013/02/16 11:19:50 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.9 2013/02/27 15:19:02 ryoon Exp $
|
||||
|
||||
DISTNAME= oiio-Release-1.1.5
|
||||
OIIOVER= 1.1.7
|
||||
DISTNAME= oiio-Release-${OIIOVER}
|
||||
PKGNAME= ${DISTNAME:S/oiio-Release/openimageio/}
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= -https://github.com/OpenImageIO/oiio/archive/Release-1.1.5.tar.gz
|
||||
MASTER_SITES= -https://github.com/OpenImageIO/oiio/archive/Release-${OIIOVER}.tar.gz
|
||||
FETCH_USING= curl
|
||||
|
||||
MAINTAINER= ryoon@NetBSD.org
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.3 2013/02/10 23:22:36 ryoon Exp $
|
||||
$NetBSD: distinfo,v 1.4 2013/02/27 15:19:02 ryoon Exp $
|
||||
|
||||
SHA1 (oiio-Release-1.1.5.tar.gz) = 6d1577ae9997a4287617c922dcba4111d13fa154
|
||||
RMD160 (oiio-Release-1.1.5.tar.gz) = 8e42a14e66c72520f376878f989d38cdf0728e8a
|
||||
Size (oiio-Release-1.1.5.tar.gz) = 8248495 bytes
|
||||
SHA1 (oiio-Release-1.1.7.tar.gz) = 435286ffad18169fd615cd33d95c2b49d3e4ec17
|
||||
RMD160 (oiio-Release-1.1.7.tar.gz) = dfe15e32ff0c821165079bf517cf11dd87146ccc
|
||||
Size (oiio-Release-1.1.7.tar.gz) = 8300700 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 2923ca84d7981aaaf6494588392444e5ee07f74a
|
||||
SHA1 (patch-cmake_modules_FindOpenJpeg.cmake) = 20d15c8ee0a25ab631ed39910b6e441d069760c5
|
||||
SHA1 (patch-cmake_oiio__macros.cmake) = 016c4792c1dc85a903477f4c72af26577e1b2bb9
|
||||
SHA1 (patch-cmake_platform.cmake) = 841295fbd0ba47dda7224e6536b0a7e6f6ea9558
|
||||
SHA1 (patch-cmake_platform.cmake) = bb3ef743bdb04a76efcabb745af62473205e01ae
|
||||
SHA1 (patch-dpx.imageio_libdpx_DPXColorConverter.cpp) = 595415e7e2897798df76474dd906e25cdf3a929e
|
||||
SHA1 (patch-include_tbb_tbb__machine.h) = 7d9a196397315e0d39dd2f16139e011ab84c5630
|
||||
SHA1 (patch-include_tbb_tbb__misc.h) = 27995a9cdb72b182e352b2a649756af2d60fec86
|
||||
|
|
|
@ -1,16 +1,23 @@
|
|||
$NetBSD: patch-cmake_platform.cmake,v 1.1 2012/12/03 12:54:14 ryoon Exp $
|
||||
$NetBSD: patch-cmake_platform.cmake,v 1.2 2013/02/27 15:19:02 ryoon Exp $
|
||||
|
||||
* Add NetBSD support
|
||||
|
||||
--- cmake/platform.cmake.orig 2012-11-16 23:02:42.000000000 +0000
|
||||
--- cmake/platform.cmake.orig 2013-02-21 17:10:46.000000000 +0000
|
||||
+++ cmake/platform.cmake
|
||||
@@ -23,6 +23,9 @@ if (UNIX)
|
||||
elseif (${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
|
||||
set (platform "FreeBSD")
|
||||
set (CXXFLAGS "${CXXFLAGS} -DFREEBSD")
|
||||
@@ -30,6 +30,16 @@ if (UNIX)
|
||||
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=i586")
|
||||
endif()
|
||||
endif()
|
||||
+ elseif (${CMAKE_SYSTEM_NAME} STREQUAL "NetBSD")
|
||||
+ set (platform "NetBSD")
|
||||
+ set (CXXFLAGS "${CXXFLAGS} -DNETBSD")
|
||||
+ set (platform "NetBSD")
|
||||
+ set (CXXFLAGS "${CXXFLAGS} -DNETBSD")
|
||||
+ if (${CMAKE_SYSTEM_PROCESSOR} STREQUAL "i386")
|
||||
+ if (NOT USE_TBB)
|
||||
+ # to use gcc atomics we need cpu instructions only available
|
||||
+ # with arch of i586 or higher
|
||||
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=i586")
|
||||
+ endif()
|
||||
+ endif()
|
||||
else ()
|
||||
string (TOLOWER ${CMAKE_SYSTEM_NAME} platform)
|
||||
endif ()
|
||||
|
|
Loading…
Reference in a new issue