Update LuaJIT2 to 2.0.5.

LuaJIT 2.0.5 -- 2017-05-01

     * Add workaround for MSVC 2015 stdio changes.
     * Limit mcode alloc probing, depending on the available pool size.
     * Fix overly restrictive range calculation in mcode allocation.
     * Fix out-of-scope goto handling in parser.
     * Remove internal __mode = "K" and replace with safe check.
     * Add "proto" field to jit.util.funcinfo().
     * Fix GC step size calculation.
     * Initialize uv->immutable for upvalues of loaded chunks.
     * Fix for cdata vs. non-cdata arithmetics/comparisons.
     * Drop leftover regs in 'for' iterator assignment, too.
     * Fix PHI remarking in SINK pass.
     * Don't try to record outermost pcall() return to lower frame.
     * Add guard for obscure aliasing between open upvalues and SSA slots.
     * Remove assumption that lj_math_random_step() doesn't clobber FPRs.
     * Fix handling of non-numeric strings in arithmetic coercions.
     * Fix recording of select(n, ...) with off-trace varargs
     * Fix install for cross-builds.
     * Don't allocate unused 2nd result register in JIT compiler backend.
     * Drop marks from replayed instructions when sinking.
     * Fix unsinking check.
     * Properly handle OOM in trace_save().
     * Limit number of arguments given to io.lines() and fp:lines().
     * Fix narrowing of TOBIT.
     * OSX: Fix build with recent XCode.
     * x86/x64: Don't spill an explicit REF_BASE in the IR.
     * x86/x64: Fix instruction length decoder.
     * x86/x64: Search for exit jumps with instruction length decoder.
     * ARM: Fix BLX encoding for Thumb interworking calls.
     * MIPS: Don't use RID_GP as a scratch register.
     * MIPS: Fix emitted code for U32 to float conversion.
     * MIPS: Backport workaround for compact unwind tables.
     * MIPS: Fix cross-endian jit.bcsave.
     * MIPS: Fix BC_ISNEXT fallback path.
     * MIPS: Fix use of ffgccheck delay slots in interpreter.
     * FFI: Fix FOLD rules for int64_t comparisons.
     * FFI: Fix SPLIT pass for CONV i64.u64.
     * FFI: Fix ipairs() recording.
     * FFI: Don't propagate qualifiers into subtypes of complex.
This commit is contained in:
alnsn 2017-05-29 21:47:31 +00:00
parent d2f954b2e0
commit bfe0ba5e3c
4 changed files with 16 additions and 41 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.9 2016/08/21 21:34:57 alnsn Exp $
# $NetBSD: Makefile,v 1.10 2017/05/29 21:47:31 alnsn Exp $
#
DISTNAME= LuaJIT-2.0.4
DISTNAME= LuaJIT-2.0.5
PKGNAME= ${DISTNAME:S/LuaJIT/LuaJIT2/}
PKGREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://luajit.org/download/

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.8 2016/04/01 13:26:03 adam Exp $
$NetBSD: distinfo,v 1.9 2017/05/29 21:47:31 alnsn Exp $
SHA1 (LuaJIT-2.0.4.tar.gz) = 6e533675180300e85d12c4bbeea2d0e41ad21172
RMD160 (LuaJIT-2.0.4.tar.gz) = ef9ec596ebf81e3871f060c40303bcd2002474c4
SHA512 (LuaJIT-2.0.4.tar.gz) = a72957bd85d8f457269e78bf08c19b28c5707df5d19920d61918f8a6913f55913ce13037fb9a6463c04cefde0c6644739f390e09d656e4bbc2c236927aa3f8f9
Size (LuaJIT-2.0.4.tar.gz) = 847615 bytes
SHA1 (patch-Makefile) = 4dc6b2fd4f155700aa92e81bf2e10ce2e7990f16
SHA1 (patch-src_Makefile) = 29426c80f12d34d69eff2dfae1da786827069163
SHA1 (LuaJIT-2.0.5.tar.gz) = 10427215da7d424fd9e48adbea087966053cdb6f
RMD160 (LuaJIT-2.0.5.tar.gz) = 5176d34fa112c4586394398c3a5c9ce1ad4d4c72
SHA512 (LuaJIT-2.0.5.tar.gz) = 2636675602b4a060b0571c05220db2061dd2f38568e35b2be346a0f5e3128d87057d11d3d0d7567d8cc4e0817b5e4cf2c52a17a48065520962b157816465a9fe
Size (LuaJIT-2.0.5.tar.gz) = 849845 bytes
SHA1 (patch-Makefile) = edea30d017c9d2938d951bfdee88020906945aee
SHA1 (patch-src_Makefile) = d7236260dc17f470d7d6e41a57a22dcd3a501c28

View file

@ -1,8 +1,8 @@
$NetBSD: patch-Makefile,v 1.5 2016/04/01 11:22:36 jperkin Exp $
$NetBSD: patch-Makefile,v 1.6 2017/05/29 21:47:31 alnsn Exp $
Fix installation.
--- Makefile.orig 2014-03-12 12:10:00.000000000 +0000
--- Makefile.orig 2017-05-01 18:11:00.000000000 +0000
+++ Makefile
@@ -24,7 +24,6 @@ ABIVER= 5.1
# Change the installation path as needed. This automatically adjusts
@ -21,23 +21,7 @@ Fix installation.
INSTALL_PKGCONFIG= $(INSTALL_LIB)/pkgconfig
INSTALL_TNAME= luajit-$(VERSION)
@@ -48,6 +47,7 @@ INSTALL_TSYMNAME= luajit
INSTALL_ANAME= libluajit-$(ABIVER).a
INSTALL_SONAME= libluajit-$(ABIVER).so.$(MAJVER).$(MINVER).$(RELVER)
INSTALL_SOSHORT= libluajit-$(ABIVER).so
+INSTALL_SOMAJOR= libluajit-$(ABIVER).so.$(MAJVER)
INSTALL_DYLIBNAME= libluajit-$(ABIVER).$(MAJVER).$(MINVER).$(RELVER).dylib
INSTALL_DYLIBSHORT1= libluajit-$(ABIVER).dylib
INSTALL_DYLIBSHORT2= libluajit-$(ABIVER).$(MAJVER).dylib
@@ -57,6 +57,7 @@ INSTALL_STATIC= $(INSTALL_LIB)/$(INSTALL
INSTALL_DYN= $(INSTALL_LIB)/$(INSTALL_SONAME)
INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
+INSTALL_MAJOR1= $(INSTALL_LIB)/$(INSTALL_SOMAJOR)
INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
INSTALL_TSYM= $(INSTALL_BIN)/$(INSTALL_TSYMNAME)
INSTALL_PC= $(INSTALL_PKGCONFIG)/$(INSTALL_PCNAME)
@@ -73,7 +74,7 @@ SYMLINK= ln -sf
@@ -74,7 +73,7 @@ SYMLINK= ln -sf
INSTALL_X= install -m 0755
INSTALL_F= install -m 0644
UNINSTALL= $(RM)
@ -46,11 +30,3 @@ Fix installation.
SED_PC= sed -e "s|^prefix=.*|prefix=$(PREFIX)|" \
-e "s|^multilib=.*|multilib=$(MULTILIB)|"
@@ -113,6 +114,7 @@ install: $(INSTALL_DEP)
cd src && test -f $(FILE_SO) && \
$(INSTALL_X) $(FILE_SO) $(INSTALL_DYN) && \
$(LDCONFIG) $(INSTALL_LIB) && \
+ $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_MAJOR1) && \
$(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT1) && \
$(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT2) || :
cd etc && $(INSTALL_F) $(FILE_MAN) $(INSTALL_MAN)

View file

@ -1,10 +1,10 @@
$NetBSD: patch-src_Makefile,v 1.1 2016/04/01 13:26:03 adam Exp $
$NetBSD: patch-src_Makefile,v 1.2 2017/05/29 21:47:31 alnsn Exp $
Fix building on OS X.
--- src/Makefile.orig 2015-05-14 18:30:00.000000000 +0000
--- src/Makefile.orig 2017-05-01 18:11:00.000000000 +0000
+++ src/Makefile
@@ -294,9 +294,6 @@ ifeq (,$(shell $(TARGET_CC) -o /dev/null
@@ -297,9 +297,6 @@ ifeq (,$(shell $(TARGET_CC) -o /dev/null
TARGET_XCFLAGS+= -fno-stack-protector
endif
ifeq (Darwin,$(TARGET_SYS))
@ -12,5 +12,5 @@ Fix building on OS X.
- export MACOSX_DEPLOYMENT_TARGET=10.4
- endif
TARGET_STRIP+= -x
TARGET_AR+= 2>/dev/null
TARGET_XSHLDFLAGS= -dynamiclib -single_module -undefined dynamic_lookup -fPIC
TARGET_DYNXLDOPTS=