Add minor typo fix in doc/example for make test to pass

This commit is contained in:
mef 2016-02-01 13:13:10 +00:00
parent faee5e6287
commit c003f46faa
2 changed files with 19 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.112 2016/01/28 11:46:02 mef Exp $
$NetBSD: distinfo,v 1.113 2016/02/01 13:13:10 mef Exp $
SHA1 (curl-7.47.0.tar.bz2) = 0f8112c50acf1c3896906643adb7f1aeb9b8b633
RMD160 (curl-7.47.0.tar.bz2) = 5f4a9f97d3788ee93025be069b5bf43e85044787
@ -6,4 +6,5 @@ SHA512 (curl-7.47.0.tar.bz2) = cd85b7c46b693e0d0f50c42030c9e63de98ac9a61183dcf89
Size (curl-7.47.0.tar.bz2) = 3498935 bytes
SHA1 (patch-aa) = 793701d5ecc3343170fb437906c9adb74763cd13
SHA1 (patch-curl-config.in) = d0cc7bb6a5bf0b9257f40dcffce7093cc0098eb7
SHA1 (patch-doc_examples_getredirect_c) = 3c8235ef938f6920008f18f4583a9d47b12cda47
SHA1 (patch-lib_hostcheck.c) = 8e772d3f91cdafae17281cc19004269ece0cf308

View file

@ -0,0 +1,17 @@
$NetBSD: patch-doc_examples_getredirect_c,v 1.1 2016/02/01 13:13:10 mef Exp $
Simple typo in examle code, but this needs make test to pass
(when PKGSRC_TEST_RUN= yes).
I've reported this to upstream.
--- docs/examples/getredirect.c~ 2016-01-15 00:37:49.000000000 +0900
+++ docs/examples/getredirect.c 2016-02-01 21:52:01.000000000 +0900
@@ -48,7 +48,7 @@ int main(void)
else {
res = curl_easy_getinfo(curl, CURLINFO_RESPONSE_CODE, &response_code);
if((res == CURLE_OK) &&
- ((code / 100) != 3)) {
+ ((response_code / 100) != 3)) {
/* a redirect implies a 3xx response code */
fprintf(stderr, "Not a redirect.\n");
}