update to 0.10.11
changes: -Synced to FFmpeg 0.6 branch -Add mappings for all new codecs -encoders: proxy downstream width/height/framerate -encoders: Fix timestamps
This commit is contained in:
parent
d6c691e491
commit
c017bcf09d
8 changed files with 7 additions and 136 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.12 2010/05/14 17:06:19 drochner Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2011/01/17 17:03:03 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gst-ffmpeg-0.10.10
|
||||
DISTNAME= gst-ffmpeg-0.10.11
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-ffmpeg/
|
||||
|
||||
|
@ -25,5 +25,5 @@ PKGSRC_MAKE_ENV+= PERL=${PERL5}
|
|||
# and there are no releases
|
||||
.include "../../multimedia/ffmpeg/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-system-ffmpeg
|
||||
.include "../../devel/liboil/buildlink3.mk"
|
||||
.include "../../devel/orc/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,11 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.6 2010/05/14 17:06:19 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.7 2011/01/17 17:03:03 drochner Exp $
|
||||
|
||||
SHA1 (gst-ffmpeg-0.10.10.tar.gz) = b35d3f7409ecf885cab6d48cd2755237e30e6d61
|
||||
RMD160 (gst-ffmpeg-0.10.10.tar.gz) = 5db5666b669005eece46597b1ddd094509799d10
|
||||
Size (gst-ffmpeg-0.10.10.tar.gz) = 4567571 bytes
|
||||
SHA1 (patch-aa) = 6c68315fdf344e56f5ad120e793b325605afb33b
|
||||
SHA1 (patch-ab) = a9bde5f8d1a49ed60f5fe7df4bb49c1891e2f198
|
||||
SHA1 (patch-ac) = 120525a289a67f0ace418618a2d4309f607cea94
|
||||
SHA1 (patch-ad) = 560b973bad1627c5e14c1c9edf0ffa359cf4e0bc
|
||||
SHA1 (patch-ae) = 231ec406d31115ad2e0a57c91811699d820571f7
|
||||
SHA1 (patch-af) = ea24b655832ce2eabbdbc2e52f468ee7e9d21e2d
|
||||
SHA1 (gst-ffmpeg-0.10.11.tar.gz) = 062c8877e421d507d08f64110644333153f3631e
|
||||
RMD160 (gst-ffmpeg-0.10.11.tar.gz) = 6327476aa9a2235adf29ad8968234fc3614ea29e
|
||||
Size (gst-ffmpeg-0.10.11.tar.gz) = 5081404 bytes
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.3 2010/05/14 17:06:19 drochner Exp $
|
||||
|
||||
--- ./gst-libs/ext/ffmpeg/Makefile.orig 2008-05-22 01:05:32.000000000 +0200
|
||||
+++ ./gst-libs/ext/ffmpeg/Makefile
|
||||
@@ -128,7 +128,7 @@ doc/%.html: doc/%.texi
|
||||
mv $(@F) $@
|
||||
|
||||
doc/%.pod: doc/%-doc.texi
|
||||
- doc/texi2pod.pl $< $@
|
||||
+ ${PERL} doc/texi2pod.pl $< $@
|
||||
|
||||
doc/%.1: doc/%.pod
|
||||
pod2man --section=1 --center=" " --release=" " $< > $@
|
|
@ -1,48 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2010/05/14 17:06:19 drochner Exp $
|
||||
|
||||
--- configure.orig 2010-03-06 13:07:09.000000000 +0000
|
||||
+++ configure
|
||||
@@ -15355,7 +15355,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
$as_echo "$flag_ok" >&6; }
|
||||
|
||||
|
||||
- if test "x$ERROR_CFLAGS" == "x"
|
||||
+ if test "x$ERROR_CFLAGS" = "x"
|
||||
then
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking to see if compiler understands -errwarn=%all" >&5
|
||||
@@ -15997,9 +15997,9 @@ $as_echo "$as_me: Using ffmpeg revision
|
||||
-I \$(top_builddir)/gst-libs/ext/ffmpeg \
|
||||
-Wno-deprecated-declarations"
|
||||
|
||||
- FFMPEG_LIBS="\$(top_builddir)/gst-libs/ext/ffmpeg/libavformat/libavformat.a \
|
||||
- \$(top_builddir)/gst-libs/ext/ffmpeg/libavcodec/libavcodec.a \
|
||||
- \$(top_builddir)/gst-libs/ext/ffmpeg/libavutil/libavutil.a"
|
||||
+ FFMPEG_LIBS="\$(top_builddir)/gst-libs/ext/ffmpeg/libavformat/libavformat.la \
|
||||
+ \$(top_builddir)/gst-libs/ext/ffmpeg/libavcodec/libavcodec.la \
|
||||
+ \$(top_builddir)/gst-libs/ext/ffmpeg/libavutil/libavutil.la"
|
||||
POSTPROC_CFLAGS="-I \$(top_srcdir)/gst-libs/ext/ffmpeg/libpostproc \
|
||||
-I \$(top_srcdir)/gst-libs/ext/ffmpeg/libavutil \
|
||||
-I \$(top_srcdir)/gst-libs/ext/ffmpeg/libavcodec \
|
||||
@@ -16007,8 +16007,8 @@ $as_echo "$as_me: Using ffmpeg revision
|
||||
-I \$(top_builddir)/gst-libs/ext/ffmpeg \
|
||||
-Wno-deprecated-declarations"
|
||||
|
||||
- POSTPROC_LIBS="\$(top_builddir)/gst-libs/ext/ffmpeg/libpostproc/libpostproc.a \
|
||||
- \$(top_builddir)/gst-libs/ext/ffmpeg/libavutil/libavutil.a"
|
||||
+ POSTPROC_LIBS="\$(top_builddir)/gst-libs/ext/ffmpeg/libpostproc/libpostproc.la \
|
||||
+ \$(top_builddir)/gst-libs/ext/ffmpeg/libavutil/libavutil.la"
|
||||
|
||||
SWSCALE_CFLAGS="-I \$(top_srcdir)/gst-libs/ext/ffmpeg/libswscale \
|
||||
-I \$(top_srcdir)/gst-libs/ext/ffmpeg/libavutil \
|
||||
@@ -16016,8 +16016,8 @@ $as_echo "$as_me: Using ffmpeg revision
|
||||
-I \$(top_builddir)/gst-libs/ext/ffmpeg \
|
||||
-Wno-deprecated-declarations"
|
||||
|
||||
- SWSCALE_LIBS="\$(top_builddir)/gst-libs/ext/ffmpeg/libswscale/libswscale.a \
|
||||
- \$(top_builddir)/gst-libs/ext/ffmpeg/libavutil/libavutil.a"
|
||||
+ SWSCALE_LIBS="\$(top_builddir)/gst-libs/ext/ffmpeg/libswscale/libswscale.la \
|
||||
+ \$(top_builddir)/gst-libs/ext/ffmpeg/libavutil/libavutil.la"
|
||||
|
||||
FFMPEG_SUBDIRS=gst-libs
|
||||
$as_echo "#define HAVE_AVI_H 1" >>confdefs.h
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.2 2010/05/14 17:06:19 drochner Exp $
|
||||
|
||||
--- gst-libs/ext/ffmpeg/configure.orig 2010-03-06 13:11:26.000000000 +0000
|
||||
+++ gst-libs/ext/ffmpeg/configure
|
||||
@@ -2123,6 +2123,7 @@ case $target_os in
|
||||
nm_opts='-P -g'
|
||||
;;
|
||||
netbsd)
|
||||
+ disable need_memalign
|
||||
oss_indev_extralibs="-lossaudio"
|
||||
oss_outdev_extralibs="-lossaudio"
|
||||
;;
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2010/05/14 17:06:19 drochner Exp $
|
||||
|
||||
--- gst-libs/ext/ffmpeg/common.mak.orig 2010-05-05 18:42:19.000000000 +0000
|
||||
+++ gst-libs/ext/ffmpeg/common.mak
|
||||
@@ -22,9 +22,9 @@ ALLFFLIBS = avcodec avdevice avfilter av
|
||||
CPPFLAGS := -DHAVE_AV_CONFIG_H -I$(BUILD_ROOT_REL) -I$(SRC_PATH) $(CPPFLAGS)
|
||||
CFLAGS += $(ECFLAGS)
|
||||
|
||||
-%.o: %.c
|
||||
+%.lo: %.c
|
||||
$(CCDEP)
|
||||
- $(CC) $(CPPFLAGS) $(CFLAGS) $(CC_DEPFLAGS) -c $(CC_O) $<
|
||||
+ ${LIBTOOL} --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS) $(CC_DEPFLAGS) -c $(CC_O) $<
|
||||
|
||||
%.o: %.S
|
||||
$(ASDEP)
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.1 2010/05/14 17:06:19 drochner Exp $
|
||||
|
||||
--- gst-libs/ext/ffmpeg/subdir.mak.orig 2010-05-05 18:45:14.000000000 +0000
|
||||
+++ gst-libs/ext/ffmpeg/subdir.mak
|
||||
@@ -51,9 +51,9 @@ install-libs: install-lib$(NAME)-shared
|
||||
$(SUBDIR)$(SLIBNAME): $(SUBDIR)$(SLIBNAME_WITH_MAJOR)
|
||||
cd ./$(SUBDIR) && $(LN_S) $(SLIBNAME_WITH_MAJOR) $(SLIBNAME)
|
||||
|
||||
-$(SUBDIR)$(SLIBNAME_WITH_MAJOR): $(OBJS) $(SUBDIR)lib$(NAME).ver
|
||||
+$(SUBDIR)$(SLIBNAME_WITH_MAJOR): $(OBJS:.o=.lo) $(SUBDIR)lib$(NAME).ver
|
||||
$(SLIB_CREATE_DEF_CMD)
|
||||
- $(LD) $(SHFLAGS) $(FFLDFLAGS) -o $$@ $$(filter %.o,$$^) $(FFEXTRALIBS) $(EXTRAOBJS)
|
||||
+ ${LIBTOOL} --mode=link $(LD) $(SHFLAGS) $(FFLDFLAGS) -o $$@ $$(filter %.lo,$$^) $(FFEXTRALIBS) $(EXTRAOBJS)
|
||||
$(SLIB_EXTRA_CMD)
|
||||
|
||||
ifdef SUBDIR
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.1 2010/05/14 17:06:19 drochner Exp $
|
||||
|
||||
--- ext/ffmpeg/gstffmpegcodecmap.c.orig 2010-05-05 19:30:18.000000000 +0000
|
||||
+++ ext/ffmpeg/gstffmpegcodecmap.c
|
||||
@@ -644,11 +644,13 @@ gst_ffmpeg_codecid_to_caps (enum CodecID
|
||||
caps = gst_ff_aud_caps_new (context, codec_id, "audio/x-true-hd", NULL);
|
||||
break;
|
||||
|
||||
+#if 0
|
||||
case CODEC_ID_ATRAC1:
|
||||
caps =
|
||||
gst_ff_aud_caps_new (context, codec_id, "audio/x-vnd.sony.atrac3",
|
||||
NULL);
|
||||
break;
|
||||
+#endif
|
||||
|
||||
case CODEC_ID_ATRAC3:
|
||||
caps =
|
Loading…
Reference in a new issue