Fix buildling with Clang
This commit is contained in:
parent
79f16565ee
commit
c01bda295d
5 changed files with 22 additions and 25 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.34 2011/04/22 13:42:48 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.35 2011/05/05 08:55:23 adam Exp $
|
||||
|
||||
DISTNAME= gnupg-2.0.17
|
||||
PKGNAME= ${DISTNAME:S/gnupg/gnupg2/}
|
||||
|
@ -25,7 +25,11 @@ CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
|
|||
CONFIGURE_ARGS+= --with-static-rnd=auto
|
||||
CONFIGURE_ARGS+= --without-included-gettext
|
||||
CONFIGURE_ARGS+= --with-pinentry-pgm=${BUILDLINK_PREFIX.pinentry}/bin/pinentry
|
||||
#CONFIGURE_ARGS+= --enable-maintainer-mode
|
||||
|
||||
# Sometimes wrong include file gets detected, e.g. for Clang
|
||||
.if exists(/usr/include/stdint.h)
|
||||
CONFIGURE_ENV+= gl_cv_absolute_stdint_h=/usr/include/stdint.h
|
||||
.endif
|
||||
|
||||
TEST_TARGET= check
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST.gpgsm,v 1.11 2011/01/20 08:54:56 adam Exp $
|
||||
@comment $NetBSD: PLIST.gpgsm,v 1.12 2011/05/05 08:55:23 adam Exp $
|
||||
bin/gpg-connect-agent
|
||||
bin/gpg2
|
||||
bin/gpgconf
|
||||
|
@ -13,11 +13,11 @@ bin/watchgnupg
|
|||
info/gnupg.info
|
||||
info/gnupg.info-1
|
||||
libexec/gnupg-pcsc-wrapper
|
||||
libexec/gpg-check-pattern
|
||||
libexec/gpg2keys_curl
|
||||
libexec/gpg2keys_finger
|
||||
libexec/gpg2keys_hkp
|
||||
libexec/gpg2keys_ldap
|
||||
libexec/gpg-check-pattern
|
||||
man/man1/gpg-agent.1
|
||||
man/man1/gpg-connect-agent.1
|
||||
man/man1/gpg-preset-passphrase.1
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.21 2011/01/20 08:54:56 adam Exp $
|
||||
$NetBSD: distinfo,v 1.22 2011/05/05 08:55:23 adam Exp $
|
||||
|
||||
SHA1 (gnupg-2.0.17.tar.bz2) = 41ef5460417ca0a1131fc730849fe3afd49ad2de
|
||||
RMD160 (gnupg-2.0.17.tar.bz2) = f919947a1896ac20c455534d91a3e2d3e5b60c1f
|
||||
|
@ -6,6 +6,5 @@ Size (gnupg-2.0.17.tar.bz2) = 3997356 bytes
|
|||
SHA1 (patch-ah) = 0c9e061611ebfe22441a161aca016436a70ccc60
|
||||
SHA1 (patch-ai) = 4445d30150518f71f996e3b368a81523daded2e2
|
||||
SHA1 (patch-aj) = bfd21504e0d55f99df543912b1cdf2c573de2f98
|
||||
SHA1 (patch-ak) = 2eeb4e8a51ae569867730fa8f0bafd27c56a6f16
|
||||
SHA1 (patch-al) = ef7c698ed102c4e27bbf707ae5d1fce4c2b5d8d4
|
||||
SHA1 (patch-ao) = a4040ac226d93d7bbf406ef2233f096dd8100ba2
|
||||
SHA1 (patch-ao) = 2f91b33271d5e79d48b392cc58978da08ee46e8a
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ak,v 1.3 2011/01/20 08:54:56 adam Exp $
|
||||
|
||||
gpg-zip script will not be installed, so man page also should not be installed.
|
||||
If will introduce conflict with security/gnupg.
|
||||
|
||||
--- doc/Makefile.am.orig 2009-12-16 18:23:55.000000000 +0000
|
||||
+++ doc/Makefile.am
|
||||
@@ -65,7 +65,7 @@ myman_sources = gnupg7.texi gpg.texi gpg
|
||||
myman_pages = gpg2.1 gpgsm.1 gpg-agent.1 scdaemon.1 gpgv2.1 \
|
||||
watchgnupg.1 gpgconf.1 addgnupghome.8 gpg-preset-passphrase.1 \
|
||||
gpg-connect-agent.1 gpgparsemail.1 symcryptrun.1 \
|
||||
- gpgsm-gencert.sh.1 applygnupgdefaults.8 gpg-zip.1
|
||||
+ gpgsm-gencert.sh.1 applygnupgdefaults.8
|
||||
|
||||
man_MANS = $(myman_pages)
|
||||
noinst_MANS = gnupg.7
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: patch-ao,v 1.2 2011/01/20 08:54:56 adam Exp $
|
||||
$NetBSD: patch-ao,v 1.3 2011/05/05 08:55:23 adam Exp $
|
||||
|
||||
from patch-ak
|
||||
gpg-zip script will not be installed, so man page also should not be installed.
|
||||
If will introduce conflict with security/gnupg.
|
||||
|
||||
--- doc/Makefile.in.orig 2010-07-19 07:05:40.000000000 +0000
|
||||
+++ doc/Makefile.in
|
||||
|
@ -13,3 +14,12 @@ from patch-ak
|
|||
|
||||
man_MANS = $(myman_pages)
|
||||
noinst_MANS = gnupg.7
|
||||
@@ -905,7 +905,7 @@ uninstall-man: uninstall-man1 uninstall-
|
||||
|
||||
|
||||
yat2m: yat2m.c
|
||||
- $(CC_FOR_BUILD) -o $@ $(srcdir)/yat2m.c
|
||||
+ $(CC_FOR_BUILD) $(CPPFLAGS) -o $@ $(srcdir)/yat2m.c
|
||||
|
||||
.fig.png:
|
||||
fig2dev -L png `test -f '$<' || echo '$(srcdir)/'`$< $@
|
||||
|
|
Loading…
Reference in a new issue