Update clutter to 1.2.14.
Clutter 1.2.14 (24/09/2010) =============================================================================== * List of changes since Clutter 1.2.12 > Backport GLES detection logic, and remove an unwanted GL dependency when building EGLX backends against Mesa. > Fix build on Quartz. > Plug leaks in CoglProgram and CoglShader. > Fixes for CoglShader usage on GLES2. > Backport a fix in the request mode of ClutterBoxLayout. > Documentation fixes. Many thanks to: Neil Roberts Alexandros Frantzis Nate Stedman
This commit is contained in:
parent
e38d8e7a33
commit
c02cd5effb
4 changed files with 6 additions and 45 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.18 2010/09/14 11:00:51 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.19 2010/10/16 14:05:17 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= clutter-1.2.12
|
||||
PKGREVISION= 1
|
||||
DISTNAME= clutter-1.2.14
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://source.clutter-project.org/sources/clutter/1.2/
|
||||
# ${MASTER_SITE_GNOME:=sources/clutter/1.2/}
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.12 2010/08/01 09:04:33 obache Exp $
|
||||
$NetBSD: distinfo,v 1.13 2010/10/16 14:05:17 obache Exp $
|
||||
|
||||
SHA1 (clutter-1.2.12.tar.gz) = b4ee053f61306526ef13e4b15ad2a63fc3e9f70f
|
||||
RMD160 (clutter-1.2.12.tar.gz) = 6f590f9c20dd030820aa6bbb88fba7cb93b6140d
|
||||
Size (clutter-1.2.12.tar.gz) = 3200650 bytes
|
||||
SHA1 (patch-ab) = 9f76fc4f1357081cd4a30485663bb440d3376095
|
||||
SHA1 (patch-ac) = 02d9c33b7d3cd7f08e342fb8796d95d471f1bb67
|
||||
SHA1 (clutter-1.2.14.tar.gz) = 2fcc0a053424a33f98cbab51477cec2518c4bba6
|
||||
RMD160 (clutter-1.2.14.tar.gz) = 9f54c29e17b5595b964f3345729d001189df40f1
|
||||
Size (clutter-1.2.14.tar.gz) = 3201417 bytes
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.2 2010/07/16 14:56:11 obache Exp $
|
||||
|
||||
Fixes build with !Linux.
|
||||
http://git.clutter-project.org/clutter/commit/?h=clutter-1.2&id=4600615be61a1d73abfd4d521308e9512a01f475
|
||||
|
||||
--- clutter/glx/clutter-stage-glx.c.orig 2010-07-14 10:32:57.000000000 +0000
|
||||
+++ clutter/glx/clutter-stage-glx.c
|
||||
@@ -487,8 +487,8 @@ wait_for_vblank (ClutterBackendGLX *back
|
||||
(retraceCount + 1) % 2,
|
||||
&retraceCount);
|
||||
}
|
||||
- else
|
||||
#ifdef __linux__
|
||||
+ else
|
||||
{
|
||||
drm_wait_vblank_t blank;
|
||||
|
|
@ -1,19 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1 2010/08/01 09:04:33 obache Exp $
|
||||
|
||||
--- clutter/cogl/cogl/cogl-texture.c.orig 2010-07-14 10:32:47.000000000 +0000
|
||||
+++ clutter/cogl/cogl/cogl-texture.c
|
||||
@@ -49,6 +49,14 @@
|
||||
#include "cogl-primitives.h"
|
||||
#include "cogl-framebuffer-private.h"
|
||||
|
||||
+#if defined (HAVE_COGL_GL)
|
||||
+
|
||||
+#ifndef GL_PIXEL_UNPACK_BUFFER
|
||||
+#define GL_PIXEL_UNPACK_BUFFER GL_PIXEL_UNPACK_BUFFER_ARB
|
||||
+#endif
|
||||
+
|
||||
+#endif
|
||||
+
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#include <math.h>
|
Loading…
Reference in a new issue