emulators/atari800: Upgrade to version 2.2.1 from 2.1.0
Two years and a little over a month elapsed between the pkgsrc release and the latest version 2.2.1 (5 May 2011). There were hundreds of changes, but the vast majority were bug fixes and improvements on existing functionality. The only major addition was implementation of IDE. See changelog in DOC/ChangeLog for details.
This commit is contained in:
parent
8499006ac6
commit
c04638ca54
7 changed files with 55 additions and 39 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.46 2012/05/23 05:03:56 dholland Exp $
|
||||
# $NetBSD: Makefile,v 1.47 2012/08/26 19:42:09 marino Exp $
|
||||
|
||||
DISTNAME= atari800-2.1.0
|
||||
PKGREVISION= 2
|
||||
DISTNAME= atari800-2.2.1
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=atari800/}
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} xf25.zip
|
||||
|
@ -39,6 +38,7 @@ post-install:
|
|||
${INSTALL_DATA} ${WRKDIR}/*.rom ${WRKDIR}/*.xfd ${WRKDIR}/*.atr \
|
||||
${WRKSRC}/atari800.cfg ${DESTDIR}${PREFIX}/share/atari800/
|
||||
|
||||
.include "../../devel/readline/buildlink3.mk"
|
||||
.include "../../graphics/png/buildlink3.mk"
|
||||
.include "../../mk/oss.buildlink3.mk"
|
||||
.include "../../mk/termcap.buildlink3.mk"
|
||||
|
|
|
@ -1,12 +1,13 @@
|
|||
$NetBSD: distinfo,v 1.16 2010/12/25 10:53:21 adam Exp $
|
||||
$NetBSD: distinfo,v 1.17 2012/08/26 19:42:09 marino Exp $
|
||||
|
||||
SHA1 (atari800-2.1.0.tar.gz) = 3888ad49718bb5e1232fb544375bb635654b5ca5
|
||||
RMD160 (atari800-2.1.0.tar.gz) = c793855b27843975fcf04fea47c49499909b49ee
|
||||
Size (atari800-2.1.0.tar.gz) = 1214047 bytes
|
||||
SHA1 (atari800-2.2.1.tar.gz) = 244167a1b90b52ea9d6a230e97216c99ff32f0c9
|
||||
RMD160 (atari800-2.2.1.tar.gz) = e1787d99b0f2c0061c0c8ae3b1ae6ee02b22a3b3
|
||||
Size (atari800-2.2.1.tar.gz) = 1419198 bytes
|
||||
SHA1 (xf25.zip) = e65923fd3a4845c1c72d1677db0fda969187eb42
|
||||
RMD160 (xf25.zip) = e3960898223dd4d1b9a9cc5cfb1251bd726ea5a7
|
||||
Size (xf25.zip) = 188942 bytes
|
||||
SHA1 (patch-aa) = 6b610bab5957474e0eb63ec67f04c6cc3bc5287c
|
||||
SHA1 (patch-ab) = ff02962059156632dc72d750ae82d91c012ab178
|
||||
SHA1 (patch-ac) = 69d0ec42303b04a38b8d6b2bd7c1311d42060a11
|
||||
SHA1 (patch-ad) = 5214a52d94de3f63eb0ee9143fd6439a21df2f6c
|
||||
SHA1 (patch-ab) = 8a9ff88adf6d2e563681bf38e88e0c6076d30bb9
|
||||
SHA1 (patch-ac) = eb657d13c20689ab85d42b08247c8aaba8414019
|
||||
SHA1 (patch-ad) = 24e15baf3759fa0bb2b6638fd017f7ef7d092140
|
||||
SHA1 (patch-rdevice.c) = 9c17f7e600db506e7e6e9f1f3780e66b404813be
|
||||
|
|
|
@ -1,18 +1,14 @@
|
|||
Atari 800 Emulator, Version 1.2.4
|
||||
Atari 800 Emulator, Version 2.0.1
|
||||
OS/A_ROM=
|
||||
OS/B_ROM=@PREFIX@/share/atari800/atariosb.rom
|
||||
XL/XE_ROM=@PREFIX@/share/atari800/atarixl.rom
|
||||
BASIC_ROM=@PREFIX@/share/atari800/ataribas.rom
|
||||
5200_ROM=
|
||||
DISK_DIR=@PREFIX@/share/atari800/
|
||||
ROM_DIR=@PREFIX@/share/atari800/
|
||||
H1_DIR=.
|
||||
H2_DIR=.
|
||||
H3_DIR=.
|
||||
H4_DIR=.
|
||||
HD_READ_ONLY=1
|
||||
EXE_DIR=.
|
||||
STATE_DIR=
|
||||
PRINT_COMMAND=lpr %s
|
||||
SCREEN_REFRESH_RATIO=1
|
||||
MACHINE_TYPE=Atari XL/XE
|
||||
|
@ -22,3 +18,8 @@ DISABLE_BASIC=1
|
|||
ENABLE_SIO_PATCH=1
|
||||
ENABLE_H_PATCH=1
|
||||
ENABLE_P_PATCH=1
|
||||
ENABLE_NEW_POKEY=0
|
||||
STEREO_POKEY=0
|
||||
SPEAKER_SOUND=1
|
||||
ATARI_FILES_DIR=@PREFIX@/share/atari800/
|
||||
SAVED_FILES_DIR=~/
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.7 2009/11/04 11:44:15 adam Exp $
|
||||
$NetBSD: patch-ab,v 1.8 2012/08/26 19:42:09 marino Exp $
|
||||
|
||||
--- cfg.c.orig 2008-12-27 23:04:53.000000000 +0100
|
||||
--- cfg.c.orig 2011-04-18 01:47:48.000000000 +0000
|
||||
+++ cfg.c
|
||||
@@ -92,7 +92,7 @@ void CFG_FindROMImages(const char *direc
|
||||
@@ -105,7 +105,7 @@ void CFG_FindROMImages(const char *direc
|
||||
#endif
|
||||
|
||||
#ifndef SYSTEM_WIDE_CFG_FILE
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-ac,v 1.5 2009/11/04 11:44:15 adam Exp $
|
||||
$NetBSD: patch-ac,v 1.6 2012/08/26 19:42:09 marino Exp $
|
||||
|
||||
--- Makefile.in.orig 2008-10-30 01:13:48.000000000 +0100
|
||||
--- Makefile.in.orig 2011-04-05 02:36:16.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -16,15 +16,15 @@ else
|
||||
FINALTARGET = $(TARGET)
|
||||
@@ -20,15 +20,15 @@ else
|
||||
endif
|
||||
endif
|
||||
|
||||
-CFLAGS = @CFLAGS@
|
||||
|
|
|
@ -1,25 +1,24 @@
|
|||
$NetBSD: patch-ad,v 1.6 2010/12/25 10:53:22 adam Exp $
|
||||
$NetBSD: patch-ad,v 1.7 2012/08/26 19:42:09 marino Exp $
|
||||
|
||||
--- configure.orig 2009-03-27 10:13:51.000000000 +0100
|
||||
--- configure.orig 2011-04-28 12:07:28.000000000 +0000
|
||||
+++ configure
|
||||
@@ -3506,9 +3506,6 @@ case "$a8_target" in
|
||||
sdlcheck="X_`sdl-config --cflags`"
|
||||
if [ "$sdlcheck" != "X_" ]; then
|
||||
CFLAGS="$CFLAGS `sdl-config --cflags`"
|
||||
- if [ "$a8_host" = "win" ]; then
|
||||
- CFLAGS=${CFLAGS/-Dmain=SDL_main/}
|
||||
- fi
|
||||
else
|
||||
{ { echo "$as_me:$LINENO: error: \"No output from sdl-config! Is sdl-config installed?\"" >&5
|
||||
echo "$as_me: error: \"No output from sdl-config! Is sdl-config installed?\"" >&2;}
|
||||
@@ -6558,10 +6557,8 @@ _ACEOF
|
||||
OBJS="atari_sdl.o"
|
||||
CFLAGS="$CFLAGS -ansi -pedantic -Waggregate-return -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wstrict-prototypes -Winline"
|
||||
@@ -8425,7 +8425,7 @@ $as_echo "#define IDE 1" >>confdefs.h
|
||||
|
||||
fi
|
||||
|
||||
-if [ "$WANT_IDE" == "yes" ]; then
|
||||
+if [ "$WANT_IDE" = "yes" ]; then
|
||||
# Check whether --enable-largefile was given.
|
||||
if test "${enable_largefile+set}" = set; then :
|
||||
enableval=$enable_largefile;
|
||||
@@ -8878,10 +8878,8 @@ case "$a8_target" in
|
||||
LIBS="$LIBS $SDL_LIBS"
|
||||
CFLAGS="$CFLAGS $SDL_CFLAGS"
|
||||
if [ "$a8_host" = "win" ]; then
|
||||
- LIBS=${LIBS/-lSDLmain/}
|
||||
OBJS="$OBJS SDL_win32_main.o"
|
||||
CFLAGS="$CFLAGS -DNO_STDIO_REDIRECT"
|
||||
- LIBS=${LIBS/-mwindows/}
|
||||
fi
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
;;
|
||||
esac
|
||||
|
|
15
emulators/atari800/patches/patch-rdevice.c
Normal file
15
emulators/atari800/patches/patch-rdevice.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-rdevice.c,v 1.1 2012/08/26 19:42:09 marino Exp $
|
||||
|
||||
Add i386 DragonFly support (Same as FreeBSD but on its own line)
|
||||
|
||||
--- rdevice.c.orig 2011-04-28 10:49:39.000000000 +0000
|
||||
+++ rdevice.c
|
||||
@@ -819,6 +819,8 @@ static void open_connection(char * addre
|
||||
#define TTY_DEV_NAME "/dev/tty00" /* NetBSD/x86 */
|
||||
#elif defined (__FreeBSD__) && defined(__i386__)
|
||||
#define TTY_DEV_NAME "/dev/ttyd1" /* FreeBSD/x86 */
|
||||
+#elif defined (__DragonFly__) && defined(__i386__)
|
||||
+#define TTY_DEV_NAME "/dev/ttyd1" /* DragonFly/x86 */
|
||||
#elif defined (__sun__)
|
||||
#define TTY_DEV_NAME "/dev/ttya" /* Solaris */
|
||||
#else
|
Loading…
Reference in a new issue