update to 2.6

changes:
-support for PKCS #5 PBKDF2, SHA3, GOST R 34.11-94
-bugfixes
-minor improvements
This commit is contained in:
drochner 2013-03-15 18:22:03 +00:00
parent d2d9b52ac0
commit c04ade8bb8
8 changed files with 65 additions and 58 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.8 2012/10/23 18:16:37 asau Exp $
# $NetBSD: Makefile,v 1.9 2013/03/15 18:22:03 drochner Exp $
DISTNAME= nettle-2.4
DISTNAME= nettle-2.6
CATEGORIES= devel security
MASTER_SITES= http://www.lysator.liu.se/~nisse/archive/ \
ftp://ftp.lysator.liu.se/pub/security/lsh/
@ -15,7 +15,7 @@ USE_LIBTOOL= yes
USE_TOOLS+= gm4 gmake
GNU_CONFIGURE= yes
SET_LIBDIR= yes
CONFIGURE_ARGS+= --disable-openssl
CONFIGURE_ARGS+= --disable-openssl --disable-shared
INFO_FILES= yes
TEST_TARGET= check

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2011/09/08 20:22:13 wiz Exp $
@comment $NetBSD: PLIST,v 1.4 2013/03/15 18:22:03 drochner Exp $
bin/nettle-hash
bin/nettle-lfib-stream
bin/pkcs1-conv
@ -20,6 +20,7 @@ include/nettle/des-compat.h
include/nettle/des.h
include/nettle/dsa.h
include/nettle/gcm.h
include/nettle/gosthash94.h
include/nettle/hmac.h
include/nettle/knuth-lfib.h
include/nettle/macros.h
@ -31,15 +32,20 @@ include/nettle/memxor.h
include/nettle/nettle-meta.h
include/nettle/nettle-stdint.h
include/nettle/nettle-types.h
include/nettle/pbkdf2.h
include/nettle/pgp.h
include/nettle/pkcs1.h
include/nettle/realloc.h
include/nettle/ripemd160.h
include/nettle/rsa-compat.h
include/nettle/rsa.h
include/nettle/salsa20.h
include/nettle/serpent.h
include/nettle/sexp.h
include/nettle/sha.h
include/nettle/sha1.h
include/nettle/sha2.h
include/nettle/sha3.h
include/nettle/twofish.h
include/nettle/yarrow.h
info/nettle.info

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.6 2011/09/08 20:22:13 wiz Exp $
$NetBSD: distinfo,v 1.7 2013/03/15 18:22:03 drochner Exp $
SHA1 (nettle-2.4.tar.gz) = 1df0cd013e83f73b78a5521411a67e331de3dfa6
RMD160 (nettle-2.4.tar.gz) = 8480e10ce718db1a280d57a808a78a4cfa940d1c
Size (nettle-2.4.tar.gz) = 1075789 bytes
SHA1 (patch-Makefile.in) = cf1f0fb4e23657f493f381c80b31e7c6294b67e7
SHA1 (nettle-2.6.tar.gz) = 401f982a0b365e04c8c38c4da42afdd7d2d51d80
RMD160 (nettle-2.6.tar.gz) = 898483350285468fe66b3fad4e7891583b08e15e
Size (nettle-2.6.tar.gz) = 1385695 bytes
SHA1 (patch-Makefile.in) = 39e4eba0a984cd2cd3037b1c46b65785deb3feb6
SHA1 (patch-aa) = 509b333e80d88c9fab75c0bc3e4edde862595d0d
SHA1 (patch-config.make.in) = 0bf3d2729b97883b41374a1ea3d5286fd2554e98
SHA1 (patch-testsuite_Makefile.in) = f73c6af3fc2ae63174406df4ff89892f7b5634d7
SHA1 (patch-tools_Makefile.in) = 5eca9e6d806cea894493122f7e1c79d6a26f2c88
SHA1 (patch-x86_camellia-crypt-internal.asm) = 0dd04f76ccca63f0c3e7260269fa8f74d01ddda3
SHA1 (patch-testsuite_Makefile.in) = a1363d21af5371d36629797a413129850af9ee87
SHA1 (patch-tools_Makefile.in) = f074fc1bf0e2b7ded88fd65ec303e2be407f0217

View file

@ -1,8 +1,8 @@
$NetBSD: patch-Makefile.in,v 1.3 2011/08/22 15:09:21 wiz Exp $
$NetBSD: patch-Makefile.in,v 1.4 2013/03/15 18:22:03 drochner Exp $
Use LIBTOOL.
--- Makefile.in.orig 2011-07-11 13:59:25.000000000 +0000
--- Makefile.in.orig 2013-01-14 21:44:12.000000000 +0000
+++ Makefile.in
@@ -14,13 +14,13 @@ INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = $(INSTALL_PROGRAM) -s
@ -15,12 +15,12 @@ Use LIBTOOL.
PRE_CPPFLAGS = -I.
# FIXME: Add configuration of LIBEXT?
-LIBTARGETS = libnettle.a @IF_HOGWEED@ libhogweed.a
+LIBTARGETS = libnettle.la @IF_HOGWEED@ libhogweed.la
SHLIBTARGETS = $(LIBNETTLE_FORLINK) @IF_HOGWEED@ $(LIBHOGWEED_FORLINK)
-LIBTARGETS = @IF_STATIC@ libnettle.a @IF_HOGWEED@ libhogweed.a
+LIBTARGETS = @IF_STATIC@ libnettle.la @IF_HOGWEED@ libhogweed.la
SHLIBTARGETS = @IF_SHARED@ $(LIBNETTLE_FORLINK) @IF_HOGWEED@ $(LIBHOGWEED_FORLINK)
TARGETS = aesdata$(EXEEXT) desdata$(EXEEXT) shadata$(EXEEXT) gcmdata$(EXEEXT)\
@@ -141,18 +141,18 @@ nettle_PURE_OBJS = $(nettle_OBJS:.$(OBJE
getopt_SOURCES = getopt.c getopt1.c
@@ -169,18 +169,18 @@ nettle_PURE_OBJS = $(nettle_OBJS:.$(OBJE
hogweed_OBJS = $(hogweed_SOURCES:.c=.$(OBJEXT))
hogweed_PURE_OBJS = $(hogweed_OBJS:.$(OBJEXT)=.p$(OBJEXT))
@ -48,8 +48,8 @@ Use LIBTOOL.
+ ${LIBTOOL} --mode=compile --tag=CC $(COMPILE) $(CCPIC_MAYBE) -c $< \
&& $(DEP_PROCESS)
# Rules building shared libraries
@@ -205,7 +205,7 @@ des.$(OBJEXT): des.c des.h $(des_headers
# Rules building shared libraries.
@@ -244,7 +244,7 @@ des.$(OBJEXT): des.c des.h $(des_headers
.asm.$(OBJEXT):
$(M4) $(srcdir)/asm.m4 machine.m4 config.m4 \
$< >$*.s
@ -58,7 +58,7 @@ Use LIBTOOL.
echo "$@ : $< $(srcdir)/asm.m4 machine.m4 config.m4" >$@.d
.asm.p$(OBJEXT):
@@ -271,7 +271,7 @@ install-here: install-info install-heade
@@ -317,7 +317,7 @@ install-here: install-doc install-header
install-static: $(LIBTARGETS)
$(MKDIR_P) $(DESTDIR)$(libdir)
for f in $(LIBTARGETS); do \
@ -66,4 +66,4 @@ Use LIBTOOL.
+ ${LIBTOOL} --mode=install ${BSD_INSTALL_LIB} $$f $(DESTDIR)$(libdir) ; \
done
install-shared-nettle: $(LIBNETTLE_FORLINK)
install-dll-nettle:

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1 2013/03/15 18:22:03 drochner Exp $
--- configure.orig 2013-01-14 21:44:12.000000000 +0000
+++ configure
@@ -6886,7 +6886,7 @@ fi
enable_documentation=yes
else
- if test "x$enable_documentation" == "xauto" ; then
+ if test "x$enable_documentation" = "xauto" ; then
enable_documentation=no
else
as_fn_error $? "Cannot find 'makeinfo', required for documentation." "$LINENO" 5

View file

@ -1,26 +1,27 @@
$NetBSD: patch-testsuite_Makefile.in,v 1.2 2011/08/22 15:09:21 wiz Exp $
$NetBSD: patch-testsuite_Makefile.in,v 1.3 2013/03/15 18:22:03 drochner Exp $
Use LIBTOOL.
--- testsuite/Makefile.in.orig 2011-07-11 13:59:25.000000000 +0000
--- testsuite/Makefile.in.orig 2013-01-14 21:44:13.000000000 +0000
+++ testsuite/Makefile.in
@@ -64,8 +64,8 @@ all: $(TARGETS) $(EXTRA_TARGETS)
@@ -70,9 +70,9 @@ all: $(TARGETS) $(EXTRA_TARGETS)
# to use suffix rules to build the test executables. So we use an
# explicit rule for each and every executable.
-LIB_HOGWEED = @IF_HOGWEED@ -lhogweed
-TEST_OBJS = testutils.$(OBJEXT) $(LIB_HOGWEED) -lnettle $(LIBS)
+LIB_HOGWEED = @IF_HOGWEED@ ../libhogweed.la
+TEST_OBJS = testutils.$(OBJEXT) $(LIB_HOGWEED) ../libnettle.la $(LIBS)
TEST_OBJS = testutils.$(OBJEXT) ../nettle-internal.$(OBJEXT) \
- $(LIB_HOGWEED) -lnettle $(LIBS)
+ $(LIB_HOGWEED) ../libnettle.la $(LIBS)
.PHONY: test-rules
test-rules:
@@ -83,7 +83,7 @@ test-rules:
../nettle-internal.$(OBJEXT):
( cd .. && $(MAKE) nettle-internal.$(OBJEXT) )
@@ -93,7 +93,7 @@ test-rules:
include $(srcdir)/.test-rules.make
$(TARGETS) $(EXTRA_TARGETS): testutils.$(OBJEXT) \
$(TARGETS) $(EXTRA_TARGETS): testutils.$(OBJEXT) ../nettle-internal.$(OBJEXT) \
- ../libnettle.a @IF_HOGWEED@ ../libhogweed.a
+ ../libnettle.la @IF_HOGWEED@ ../libhogweed.la
# The PATH update is for locating dlls on w*ndows.
check: $(TS_ALL) $(srcdir)/run-tests
# For use as, e.g.,
#

View file

@ -1,13 +1,13 @@
$NetBSD: patch-tools_Makefile.in,v 1.2 2011/08/22 15:09:21 wiz Exp $
$NetBSD: patch-tools_Makefile.in,v 1.3 2013/03/15 18:22:03 drochner Exp $
Use LIBTOOL.
--- tools/Makefile.in.orig 2011-07-11 13:59:25.000000000 +0000
--- tools/Makefile.in.orig 2013-01-14 21:44:12.000000000 +0000
+++ tools/Makefile.in
@@ -33,19 +33,19 @@ SOURCES = $(sexp_conv_SOURCES) nettle-ha
DISTFILES = $(SOURCES) Makefile.in getopt.h input.h misc.h output.h parse.h
@@ -34,20 +34,20 @@ SOURCES = $(sexp_conv_SOURCES) nettle-ha
DISTFILES = $(SOURCES) Makefile.in input.h misc.h output.h parse.h
sexp_conv_OBJS = $(sexp_conv_SOURCES:.c=.$(OBJEXT))
sexp_conv_OBJS = $(sexp_conv_SOURCES:.c=.$(OBJEXT)) $(getopt_OBJS)
-sexp-conv$(EXEEXT): $(sexp_conv_OBJS) ../libnettle.a
- $(LINK) $(sexp_conv_OBJS) -lnettle $(LIBS) -o $@
+sexp-conv$(EXEEXT): $(sexp_conv_OBJS) ../libnettle.la
@ -18,20 +18,22 @@ Use LIBTOOL.
+nettle-lfib-stream$(EXEEXT): nettle-lfib-stream.$(OBJEXT) ../libnettle.la
+ $(LINK) nettle-lfib-stream.$(OBJEXT) ../libnettle.la $(LIBS) -o $@
pkcs1_conv_OBJS = $(pkcs1_conv_SOURCES:.c=.$(OBJEXT))
pkcs1_conv_OBJS = $(pkcs1_conv_SOURCES:.c=.$(OBJEXT)) $(getopt_OBJS)
-pkcs1-conv$(EXEEXT): $(pkcs1_conv_OBJS) ../libnettle.a ../libhogweed.a
- $(LINK) $(pkcs1_conv_OBJS) -lhogweed -lnettle $(LIBS) -o $@
+pkcs1-conv$(EXEEXT): $(pkcs1_conv_OBJS) ../libnettle.la ../libhogweed.la
+ $(LINK) $(pkcs1_conv_OBJS) ../libhogweed.la ../libnettle.la $(LIBS) -o $@
# FIXME: Avoid linking with gmp
nettle_hash_OBJS = $(nettle_hash_SOURCES:.c=.$(OBJEXT))
nettle_hash_OBJS = $(nettle_hash_SOURCES:.c=.$(OBJEXT)) $(getopt_OBJS)
-nettle-hash$(EXEEXT): $(nettle_hash_OBJS) ../libnettle.a
- $(LINK) $(nettle_hash_OBJS) -lnettle $(LIBS) -o $@
+nettle-hash$(EXEEXT): $(nettle_hash_OBJS) ../libnettle.la
$(LINK) $(nettle_hash_OBJS) -lnettle $(LIBS) -o $@
+ $(LINK) $(nettle_hash_OBJS) ../libnettle.la $(LIBS) -o $@
@@ -62,7 +62,7 @@ check:
.c.$(OBJEXT):
@@ -69,7 +69,7 @@ check:
install: $(TARGETS)
$(MKDIR_P) $(DESTDIR)$(bindir)
for f in $(TARGETS) ; do \

View file

@ -1,15 +0,0 @@
$NetBSD: patch-x86_camellia-crypt-internal.asm,v 1.1 2011/05/02 21:27:15 adam Exp $
Avoid ambiguous instruction.
--- x86/camellia-crypt-internal.asm.orig 2011-05-02 18:31:15.000000000 +0000
+++ x86/camellia-crypt-internal.asm
@@ -185,7 +185,7 @@ PROLOGUE(_nettle_camellia_crypt)
FL(L0, H0, -16)
FLINV(L1, H1, -8)
ROUND6
- sub $8, FRAME_CNT
+ subl $8, FRAME_CNT
ja .Lround_loop
movl FRAME_DST, TMP