strnlen.h is missing in distfile, taken from upstream repository

(and fixed in the repository).
This commit is contained in:
obache 2010-09-15 04:00:38 +00:00
parent 7cf7411b74
commit c0841756ed
2 changed files with 41 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.3 2010/09/10 19:55:11 joerg Exp $
$NetBSD: distinfo,v 1.4 2010/09/15 04:00:38 obache Exp $
SHA1 (xlsclients-1.1.0.tar.bz2) = 1961ee982f98d270c9069eaf84790c6b9dcdc851
RMD160 (xlsclients-1.1.0.tar.bz2) = ef0cb54ed84e77ea6013235582f65fcdf288f97d
Size (xlsclients-1.1.0.tar.bz2) = 107784 bytes
SHA1 (patch-aa) = 0685af3492ac834cc83e3f72e39b510b6419bff0

View file

@ -0,0 +1,39 @@
$NetBSD: patch-aa,v 1.1 2010/09/15 04:00:38 obache Exp $
taken from upstream repository (missing in distfile).
--- strnlen.h.orig 2010-09-15 03:55:30.000000000 +0000
+++ strnlen.h
@@ -0,0 +1,32 @@
+/*
+ * Copyright (c) 2009 Apple Inc.
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining a
+ * copy of this software and associated documentation files (the "Software"),
+ * to deal in the Software without restriction, including without limitation
+ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
+ * and/or sell copies of the Software, and to permit persons to whom the
+ * Software is furnished to do so, subject to the following conditions:
+ *
+ * The above copyright notice and this permission notice shall be included in
+ * all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+ * THE ABOVE LISTED COPYRIGHT HOLDER(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
+ * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ * DEALINGS IN THE SOFTWARE.
+ */
+
+ /*
+ * Author: Jeremy Huddleston, Apple Inc.
+ */
+
+#ifndef __STRNLEN_H__
+#define __STRNLEN_H__ 1
+#include <stdlib.h>
+
+extern size_t strnlen(const char *s, size_t maxlen);
+#endif /* __STRNLEN_H__ */