* Patch to Version is not required after removal of scons-devel package.

* distutils pkg, use python/disutils.mk.

Bump PKGREVISION.
This commit is contained in:
obache 2012-02-02 11:49:55 +00:00
parent c6e050a3c3
commit c09ebe65af
5 changed files with 10 additions and 20 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.15 2011/03/12 16:04:58 shattered Exp $
# $NetBSD: Makefile,v 1.16 2012/02/02 11:49:55 obache Exp $
#
PKG_DESTDIR_SUPPORT= user-destdir
@ -7,5 +7,6 @@ CONFLICTS= scons-devel-[0-9]*
.include "../../devel/scons/Makefile.common"
SCONS_VERSION= 1.3.1
PKGREVISION= 1
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.3 2011/02/28 14:52:46 wiz Exp $
# $NetBSD: Makefile.common,v 1.4 2012/02/02 11:49:55 obache Exp $
#
# used by devel/scons/Makefile
# used by devel/scons-devel/Makefile
@ -11,10 +11,7 @@ MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.scons.org/
COMMENT?= Python-based, open-source build system
PYDISTUTILSPKG= yes
MAKE_ENV+= PKGVERSION_NOREV=${PKGVERSION_NOREV:Q}
REPLACE_PYTHON+= script/scons script/scons-time script/sconsign
.include "../../lang/python/application.mk"
.include "../../lang/python/extension.mk"
.include "../../lang/python/distutils.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.6 2010/06/19 11:33:46 sborrill Exp $
@comment $NetBSD: PLIST,v 1.7 2012/02/02 11:49:55 obache Exp $
bin/scons
bin/${PKGNAME}
bin/scons-time
@ -566,6 +566,7 @@ lib/${PKGNAME}/SCons/dblite.pyo
lib/${PKGNAME}/SCons/exitfuncs.py
lib/${PKGNAME}/SCons/exitfuncs.pyc
lib/${PKGNAME}/SCons/exitfuncs.pyo
${PLIST.eggfile}lib/${PKGNAME}/${EGG_FILE}
man/man1/scons-time.1
man/man1/scons.1
man/man1/sconsign.1

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.7 2011/03/12 16:04:58 shattered Exp $
$NetBSD: distinfo,v 1.8 2012/02/02 11:49:55 obache Exp $
SHA1 (scons-1.3.1.tar.gz) = 360d4167ea7f92fbdd173776ce1c191b9aa7fa42
RMD160 (scons-1.3.1.tar.gz) = e4f568afa7c2519dc03d2993c8dfbb247b6b7c21
Size (scons-1.3.1.tar.gz) = 599550 bytes
SHA1 (patch-aa) = 054740ccd5092b8444dc00bb5488c459bff7c18f
SHA1 (patch-aa) = 20fe8e5e31b7f0f0d5755a51beefffd7504a55ae

View file

@ -1,16 +1,7 @@
$NetBSD: patch-aa,v 1.3 2011/03/12 16:04:58 shattered Exp $
$NetBSD: patch-aa,v 1.4 2012/02/02 11:49:55 obache Exp $
--- setup.py.orig 2008-11-04 11:12:26.000000000 -0500
--- setup.py.orig 2010-07-25 23:15:11.000000000 +0000
+++ setup.py
@@ -29,7 +29,7 @@ import stat
import string
import sys
-Version = "1.3.1"
+Version = os.getenv("PKGVERSION_NOREV")
man_pages = [
'scons.1',
@@ -353,7 +353,7 @@ class install_data(_install_data):
if is_win32:
dir = 'Doc'