include <stdint.h> explicitely to get uint16_t (on NetBSD/sys/types.h

defines these, but on Linux it does not)
should fix build problem reported by Lieven De Keyzer in pkgsrc-users
This commit is contained in:
drochner 2007-02-23 13:55:17 +00:00
parent 84db25aa2c
commit c0aa5a845a
2 changed files with 5 additions and 4 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.2 2007/02/15 22:52:15 joerg Exp $
$NetBSD: distinfo,v 1.3 2007/02/23 13:55:17 drochner Exp $
SHA1 (mpeg4ip-1.5.0.1.tar.gz) = 1271de695ed65284d9c39aa91bf26c5494603fd3
RMD160 (mpeg4ip-1.5.0.1.tar.gz) = fee5c21c17a470e6de349e07d233a1eb46b2064a
@ -14,4 +14,4 @@ SHA1 (patch-ah) = b5db1d879cf790c2b9c7e9132b14e1fc59e9cb4d
SHA1 (patch-ai) = 8815f81cc09bb36944bf33691aaf9060b545c76e
SHA1 (patch-aj) = f0aeab4c17bb8a737a9ae3d4385c9f2989540ea7
SHA1 (patch-ak) = 36da5d4d2824cc8b3ac62e10924058dd651cb2a7
SHA1 (patch-al) = ee0beacdc9595f258cc1833f0d3ab91209c2ab1b
SHA1 (patch-al) = 32d0c2867b5795cb8144bfb7223cc209ca0de46b

View file

@ -1,8 +1,8 @@
$NetBSD: patch-al,v 1.1.1.1 2007/02/09 19:57:48 drochner Exp $
$NetBSD: patch-al,v 1.2 2007/02/23 13:55:17 drochner Exp $
--- lib/mp4v2/mp4.h.orig 2006-02-22 23:47:07.000000000 +0100
+++ lib/mp4v2/mp4.h
@@ -31,8 +31,15 @@
@@ -31,8 +31,16 @@
#ifndef __MP4_INCLUDED__
#define __MP4_INCLUDED__
@ -14,6 +14,7 @@ $NetBSD: patch-al,v 1.1.1.1 2007/02/09 19:57:48 drochner Exp $
+#include <strings.h>
+#include <stdio.h>
+#include <stdbool.h>
+#include <stdint.h>
+#endif
#include <math.h> /* to define float HUGE_VAL and/or NAN */