Update www/links{,gui} to links-{,gui-}2.10.

From Leo Taccari in PR 50072.

pkgsrc changes:
o Convert all the old links-xz and links-zlib options to lzma and zlib2.
o Do not include the bzip2, xz and zlib buildlink3.mk files: they are
  handled in www/links/options.mk.
o Add "svg" option for links-gui (disabled by default) to reflect
  upstream change.

Changes:
o Fix "Counld not assing boundary" bug when posting a form
  The bug was found by Greg Cook
o SVG support using the rsvg library
o Attach to existing links instance instead of creating a new instance
o Detect image type based on the first few bytes rather than on
  content-type
o New glyphs taken from Volker's git
o Fixed a bug on Windows where dns lookup got stuck if we closed the
  primary instance (which resulted in fork) while the lookup was in
  progress
o Use OpenMP in the image scaler
o Fixed a bug where the output of font sharpening depended on data read
  from uninitialized memory
o Preallocate downloaded files on Linux
o Support libevent and libev
o Enable SSL SNI, some servers need it
o Test for RAND_* functions in configure because libressl doesn't have
  them
o Support keepalive on https connections
This commit is contained in:
dholland 2015-07-20 23:03:24 +00:00
parent 9171187b59
commit c0b394ea70
5 changed files with 31 additions and 22 deletions

View file

@ -1,17 +1,26 @@
# $NetBSD: Makefile,v 1.72 2014/12/30 14:47:25 wiz Exp $
# $NetBSD: Makefile,v 1.73 2015/07/20 23:03:24 dholland Exp $
PKGNAME= ${DISTNAME:S/links/&-gui/}
COMMENT= Lynx-like text and graphics WWW browser
CONFLICTS+= links-[0-9]* elinks-0.3*
USE_TOOLS+= pkg-config
USE_TOOLS+= pkg-config
CONFIGURE_ARGS+= --enable-graphics
CONFIGURE_ARGS+= --without-sdl
BUILDLINK_DEPMETHOD.libXt?= build
PKG_SUPPORTED_OPTIONS+= svg
.include "../../www/links/Makefile.common"
.if !empty(PKG_OPTIONS:Msvg)
. include "../../graphics/librsvg/buildlink3.mk"
.else
CONFIGURE_ARGS+= --without-librsvg
.endif
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"

View file

@ -1,12 +1,12 @@
# $NetBSD: Makefile.common,v 1.61 2014/12/30 14:47:25 wiz Exp $
# $NetBSD: Makefile.common,v 1.62 2015/07/20 23:03:24 dholland Exp $
#
# used by www/links/Makefile
# used by www/links-gui/Makefile
DISTNAME= links-2.9
DISTNAME= links-2.10
CATEGORIES= www
MASTER_SITES= http://links.twibright.com/download/
EXTRACT_SUFX= .tar.bz2
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://links.twibright.com/
@ -25,7 +25,5 @@ INSTALLATION_DIRS= share/doc/links
post-install:
${INSTALL_DATA} ${WRKSRC}/KEYS ${DESTDIR}${PREFIX}/share/doc/links
.include "../../archivers/bzip2/buildlink3.mk"
.include "../../archivers/xz/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../devel/libevent/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.61 2014/12/30 14:47:25 wiz Exp $
$NetBSD: distinfo,v 1.62 2015/07/20 23:03:24 dholland Exp $
SHA1 (links-2.9.tar.bz2) = 1202f1ade1075fa4f62e343702e5a0a22cdc2b13
RMD160 (links-2.9.tar.bz2) = f7ef5b4418ea0bfde660eeaa6e6f2ccbe3f4aaa1
Size (links-2.9.tar.bz2) = 4111393 bytes
SHA1 (patch-ab) = ae543b7c986edff8d5aa2d46d54a62311486e0d9
SHA1 (links-2.10.tar.bz2) = bffd48917a9d038f4277443bf6ea2cf8c9372c3c
RMD160 (links-2.10.tar.bz2) = 6c760dbc3b1ba61d6f47ce1512061f9d5b518980
Size (links-2.10.tar.bz2) = 6230715 bytes
SHA1 (patch-ab) = 679ad68a09d39776977bd5414e5a2f79d5386fa5

View file

@ -1,12 +1,14 @@
# $NetBSD: options.mk,v 1.2 2012/01/27 08:24:28 sbd Exp $
# $NetBSD: options.mk,v 1.3 2015/07/20 23:03:24 dholland Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.links
PKG_SUPPORTED_OPTIONS= bzip2 links-zlib links-xz
PKG_SUGGESTED_OPTIONS= bzip2 links-zlib links-xz
PKG_OPTIONS_VAR= PKG_OPTIONS.links
PKG_OPTIONS_LEGACY_OPTS+= links-xz:lzma
PKG_OPTIONS_LEGACY_OPTS+= links-zlib:zlib
PKG_SUPPORTED_OPTIONS+= bzip2 lzma zlib
PKG_SUGGESTED_OPTIONS= bzip2 lzma zlib
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Mlinks-xz)
.if !empty(PKG_OPTIONS:Mlzma)
. include "../../archivers/xz/buildlink3.mk"
.else
CONFIGURE_ARGS+= --without-lzma
@ -18,7 +20,7 @@ CONFIGURE_ARGS+= --without-lzma
CONFIGURE_ARGS+= --without-bzip2
.endif
.if !empty(PKG_OPTIONS:Mlinks-zlib)
.if !empty(PKG_OPTIONS:Mzlib)
. include "../../devel/zlib/buildlink3.mk"
.else
CONFIGURE_ARGS+= --without-zlib

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.7 2014/12/30 14:47:25 wiz Exp $
$NetBSD: patch-ab,v 1.8 2015/07/20 23:03:24 dholland Exp $
--- configure.orig 2014-12-19 20:04:31.000000000 +0000
--- configure.orig 2015-07-03 21:23:41.000000000 +0000
+++ configure
@@ -830,10 +830,10 @@ fi
@@ -838,10 +838,10 @@ fi