Add mlog: Merge log files by timestamp

mlog reads lines from multiple log files and prints them in
chronological order. The files need to start with comparable timestamps.
mlog prints the oldest line first, thus preserving relative order.

mlog behaves like a combination of 'sort -m' and 'tail -f'.
This commit is contained in:
schmonz 2024-01-19 15:57:59 +00:00
parent 84355188a0
commit c0db6da810
5 changed files with 48 additions and 0 deletions

5
sysutils/mlog/DESCR Normal file
View File

@ -0,0 +1,5 @@
mlog reads lines from multiple log files and prints them in
chronological order. The files need to start with comparable timestamps.
mlog prints the oldest line first, thus preserving relative order.
mlog behaves like a combination of 'sort -m' and 'tail -f'.

20
sysutils/mlog/Makefile Normal file
View File

@ -0,0 +1,20 @@
# $NetBSD: Makefile,v 1.1 2024/01/19 15:57:59 schmonz Exp $
DISTNAME= mlog-0.1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_GITHUB:=leahneukirchen/}
GITHUB_TAG= v${PKGVERSION_NOREV}
MAINTAINER= schmonz@NetBSD.org
HOMEPAGE= https://github.com/leahneukirchen/mlog/
COMMENT= Merge log files by timestamp
LICENSE= public-domain
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1
do-install:
cd ${WRKSRC}; \
${INSTALL_PROGRAM} ${PKGBASE} ${DESTDIR}${PREFIX}/bin/; \
${INSTALL_DATA} ${PKGBASE}.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
.include "../../mk/bsd.pkg.mk"

3
sysutils/mlog/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2024/01/19 15:57:59 schmonz Exp $
bin/mlog
man/man1/mlog.1

6
sysutils/mlog/distinfo Normal file
View File

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2024/01/19 15:58:00 schmonz Exp $
BLAKE2s (mlog-0.1.tar.gz) = 071e55e72be3493449851e85bd1e64abce71282edcd918c2f3a3157c70f9d262
SHA512 (mlog-0.1.tar.gz) = 5e68d0554c79af546738d360bdd7997e308b4377a887db758a8f04274f36f8b4010463409d9932c51b14f9cf6a2d3e2f4a72f61171a039379c6183ebb2c4dbae
Size (mlog-0.1.tar.gz) = 3931 bytes
SHA1 (patch-Makefile) = dc2678274e12482b7c6879d3a7c7ec5fc162b250

View File

@ -0,0 +1,14 @@
$NetBSD: patch-Makefile,v 1.1 2024/01/19 15:58:00 schmonz Exp $
Respect CFLAGS.
--- Makefile.orig 2024-01-12 17:51:01.000000000 +0000
+++ Makefile
@@ -1,6 +1,6 @@
ALL=mlog
-CFLAGS=-g -O2 -Wall -Wno-unused-parameter -Wextra -Wwrite-strings
+CFLAGS?=-g -O2 -Wall -Wno-unused-parameter -Wextra -Wwrite-strings
all: $(ALL)