mate-system-monitor:

Fix build with clang.
This commit is contained in:
youri 2016-06-08 13:00:44 +00:00
parent b6a4357c7c
commit c0de001402
2 changed files with 17 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1 2016/05/21 19:16:04 youri Exp $
$NetBSD: distinfo,v 1.2 2016/06/08 13:00:44 youri Exp $
SHA1 (mate-system-monitor-1.14.0.tar.xz) = a9045ce34fe9c116b6afae08b04030ab9c2287ae
RMD160 (mate-system-monitor-1.14.0.tar.xz) = 42351dd35cf4f1510423adf1ef91c9aa79ab1980
SHA512 (mate-system-monitor-1.14.0.tar.xz) = f19fa0241228be8ec8600db43e71495750039288292ba5714489a84acb3e5cc9f4c87d39a63d29a0fc6f907af6ecc319382cd4276ae2de1125bba059d5b24be5
Size (mate-system-monitor-1.14.0.tar.xz) = 2135464 bytes
SHA1 (patch-src_lsof.cpp) = 2ad9df6cdf66a42e408107700c04abae145011a2

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_lsof.cpp,v 1.1 2016/06/08 13:00:44 youri Exp $
Fix build on clang.
--- src/lsof.cpp.orig 2016-04-05 16:12:54.000000000 +0000
+++ src/lsof.cpp
@@ -137,7 +137,7 @@ namespace
void update_count(unsigned count)
{
- string s = static_cast<std::ostringstream&>(std::ostringstream() << count).str();
+ string s = static_cast<const std::ostringstream&>(std::ostringstream() << count).str();
gtk_label_set_text(this->count, s.c_str());
}