Fix build on SunOS.

This commit is contained in:
hans 2012-02-16 16:30:03 +00:00
parent 54c8799333
commit c0dfa2c444
10 changed files with 110 additions and 13 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.37 2012/01/17 02:12:52 jnemeth Exp $
# $NetBSD: Makefile,v 1.38 2012/02/16 16:30:03 hans Exp $
#
# NOTE: when updating this package, there are two places that sound
# tarballs need to be checked
@ -91,6 +91,10 @@ MAKE_FLAGS+= LDOPTS=${LDFLAGS:M*:Q}
MAKE_FLAGS+= HTTP_DOCSDIR=${PREFIX}/share/httpd/htdocs
MAKE_FLAGS+= HTTP_CGIDIR=${PREFIX}/libexec/cgi-bin
.if !empty(MACHINE_PLATFORM:MSunOS-*-i386)
BUILDLINK_TRANSFORM+= rm:-march=i386
.endif
.include "options.mk"
# check sounds/Makefile for current version when upgrading package

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.24 2012/01/14 08:30:15 jnemeth Exp $
$NetBSD: distinfo,v 1.25 2012/02/16 16:30:03 hans Exp $
SHA1 (asterisk-1.6.2.22/asterisk-1.6.2.22.tar.gz) = 63b24f20b8301f8039548d2871c4b6d6e175499b
RMD160 (asterisk-1.6.2.22/asterisk-1.6.2.22.tar.gz) = b56095629c4b00ab3551caf5a931315c79494017
@ -16,7 +16,7 @@ SHA1 (patch-aa) = 8c2a3c75adff34474c8f416bcea5842e771e4631
SHA1 (patch-af) = 09860d714281cb4c65d1a087cf5b16647a16e2fa
SHA1 (patch-ag) = c71c61350cefbbe53eefa99245ca7712753f22d5
SHA1 (patch-ai) = e92edab5c1ff323478f41d0b0783102ed527fe39
SHA1 (patch-ak) = adee75b7716a8794de1b8cb054af7a5a8f0e5ffd
SHA1 (patch-ak) = 8e8d949377dee37dcb217f531b7a20895b68bb5d
SHA1 (patch-al) = b2a1134786d7c3b118ee8c47892f91dd2a4c783a
SHA1 (patch-am) = 98aa4648b867d193ec05d8da14434205f369c17b
SHA1 (patch-an) = 93a5df66fd6459fb76e9191dc3bf37b9ee5483b5
@ -37,3 +37,5 @@ SHA1 (patch-bb) = 3b78ed3c8233e2db38d09ca81f1768d018ffd2e2
SHA1 (patch-bc) = 0efc99595d1ef82a879361e8bf3b2ef7fd84af62
SHA1 (patch-bd) = c827419664f78230556e43607d1abf6b156dcc88
SHA1 (patch-be) = b9d1e891b1d1d45612b5b02067393e2845663030
SHA1 (patch-main_editline_sys.h) = e0325242fcfadc35f7803438fec536691654e623
SHA1 (patch-main_editline_term.c) = 74144a7a467f84c66b98d498b556a51f1161faad

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ak,v 1.1.1.1 2009/06/12 09:04:56 jnemeth Exp $
$NetBSD: patch-ak,v 1.2 2012/02/16 16:30:04 hans Exp $
--- channels/chan_oss.c.orig 2008-11-02 16:39:04.000000000 -0800
+++ channels/chan_oss.c
@ -7,7 +7,25 @@ $NetBSD: patch-ak,v 1.1.1.1 2009/06/12 09:04:56 jnemeth Exp $
#ifdef __linux
#include <linux/soundcard.h>
-#elif defined(__FreeBSD__) || defined(__CYGWIN__)
+#elif defined(__FreeBSD__) || defined(__CYGWIN__) || defined(__DragonFly__)
+#elif defined(__FreeBSD__) || defined(__CYGWIN__) || defined(__DragonFly__) || defined(__sun)
#include <sys/soundcard.h>
#else
#include <soundcard.h>
@@ -248,7 +248,7 @@ struct chan_oss_pvt {
char *name;
int total_blocks; /*!< total blocks in the output device */
int sounddev;
- enum { M_UNSET, M_FULL, M_READ, M_WRITE } duplex;
+ enum { M_UNSET, M_FULL, M_READ_foo, M_WRITE } duplex;
int autoanswer; /*!< Boolean: whether to answer the immediately upon calling */
int autohangup; /*!< Boolean: whether to hangup the call when the remote end hangs up */
int hookstate; /*!< Boolean: 1 if offhook; 0 if onhook */
@@ -515,7 +515,7 @@ static int setformat(struct chan_oss_pvt
break;
case O_RDONLY:
- o->duplex = M_READ;
+ o->duplex = M_READ_foo;
break;
}

View file

@ -0,0 +1,15 @@
$NetBSD: patch-main_editline_sys.h,v 1.1 2012/02/16 16:30:04 hans Exp $
--- main/editline/sys.h.orig 2009-03-02 21:16:51.000000000 +0100
+++ main/editline/sys.h 2012-01-25 15:39:39.413404722 +0100
@@ -101,9 +101,9 @@ extern int tgetent(const char *bp, char
extern int tgetflag(const char *id);
extern int tgetnum(const char *id);
extern char *tgetstr(const char *id, char **area);
-#endif
extern char *tgoto(const char *cap, int col, int row);
extern int tputs(const char *str, int affcnt, int (*putc)(int));
+#endif
extern char *getenv(const char *);
extern int fprintf(FILE *, const char *, ...);
extern int sigsetmask(int);

View file

@ -0,0 +1,15 @@
$NetBSD: patch-main_editline_term.c,v 1.1 2012/02/16 16:30:04 hans Exp $
--- main/editline/term.c.orig 2006-08-21 04:11:39.000000000 +0200
+++ main/editline/term.c 2012-01-25 15:34:57.916508677 +0100
@@ -71,8 +71,10 @@ extern int tgetent(char *, const char *)
extern int tgetflag(const char *);
extern int tgetnum(const char *);
extern char *tgetstr(const char *, char **);
+#ifndef __sun
extern int tputs (const char *, int, int (*)(int));
extern char *tgoto (const char *, int, int);
+#endif
#endif /* defined(HAVE_TERM_H) */
#include <sys/types.h>
#include <sys/ioctl.h>

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.24 2012/02/12 20:16:31 jnemeth Exp $
# $NetBSD: Makefile,v 1.25 2012/02/16 16:33:36 hans Exp $
#
# NOTE: when updating this package, there are two places that sound
# tarballs need to be checked
@ -90,6 +90,15 @@ MAKE_FLAGS+= LDOPTS=${LDFLAGS:M*:Q}
MAKE_FLAGS+= HTTP_DOCSDIR=${PREFIX}/share/httpd/htdocs
MAKE_FLAGS+= HTTP_CGIDIR=${PREFIX}/libexec/cgi-bin
.if !empty(MACHINE_PLATFORM:MSunOS-*-i386)
BUILDLINK_TRANSFORM+= rm:-march=i386
.endif
PLIST_VARS+= kqueue
.if ${OPSYS} != "SunOS"
PLIST.kqueue= yes
.endif
.include "options.mk"
# check sounds/Makefile for current version when upgrading package

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.12 2012/01/28 19:11:35 jnemeth Exp $
@comment $NetBSD: PLIST,v 1.13 2012/02/16 16:33:36 hans Exp $
include/asterisk.h
include/asterisk/_private.h
include/asterisk/abstract_jb.h
@ -332,7 +332,7 @@ lib/asterisk/modules/res_security_log.so
lib/asterisk/modules/res_smdi.so
lib/asterisk/modules/res_speech.so
lib/asterisk/modules/res_stun_monitor.so
lib/asterisk/modules/res_timing_kqueue.so
${PLIST.kqueue}lib/asterisk/modules/res_timing_kqueue.so
lib/asterisk/modules/res_timing_pthread.so
lib/pkgconfig/asterisk.pc
libdata/asterisk/documentation/appdocsxml.dtd

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.20 2012/02/12 20:16:32 jnemeth Exp $
$NetBSD: distinfo,v 1.21 2012/02/16 16:33:36 hans Exp $
SHA1 (asterisk-1.8.9.2/asterisk-1.8.9.2.tar.gz) = ac53c6db9d68b36479000326d88f200057d641ef
RMD160 (asterisk-1.8.9.2/asterisk-1.8.9.2.tar.gz) = cd57801defd69b358979a1e2ff8db73ba3364e57
@ -16,7 +16,7 @@ SHA1 (patch-aa) = 496565e1e567c42ab6ba8f996c506f52cb9c8cfe
SHA1 (patch-af) = 19786616bb606c38f769ec85f2e4d118573659ab
SHA1 (patch-ag) = c71c61350cefbbe53eefa99245ca7712753f22d5
SHA1 (patch-ai) = e92edab5c1ff323478f41d0b0783102ed527fe39
SHA1 (patch-ak) = adee75b7716a8794de1b8cb054af7a5a8f0e5ffd
SHA1 (patch-ak) = f8d5de733807bc6c0701886a3095901d6815a8bd
SHA1 (patch-al) = b2a1134786d7c3b118ee8c47892f91dd2a4c783a
SHA1 (patch-am) = 5f9cbf47ec1cb66758492a5ed1bf843006eae9b7
SHA1 (patch-an) = 93a5df66fd6459fb76e9191dc3bf37b9ee5483b5
@ -43,3 +43,4 @@ SHA1 (patch-bi) = d71662f618a10c3ca4277feb7ad0d659935dee1e
SHA1 (patch-bj) = a184452adf2c883695e3819c13c584a3db9608d7
SHA1 (patch-bk) = 93679dfb04d26c99ac9c2822e0d74d869d16369f
SHA1 (patch-bl) = ae68a81a758e3b49eb54b7400d8d5c6ed4efa51a
SHA1 (patch-main_editline_sys.h) = 284b34e20091b3427cd67b835fc7aa62c9d92a6c

View file

@ -1,13 +1,31 @@
$NetBSD: patch-ak,v 1.1.1.1 2010/12/15 03:22:45 jnemeth Exp $
$NetBSD: patch-ak,v 1.2 2012/02/16 16:33:36 hans Exp $
--- channels/chan_oss.c.orig 2008-11-02 16:39:04.000000000 -0800
+++ channels/chan_oss.c
@@ -47,7 +47,7 @@ ASTERISK_FILE_VERSION(__FILE__, "$Revisi
@@ -48,7 +48,7 @@ ASTERISK_FILE_VERSION(__FILE__, "$Revisi
#ifdef __linux
#include <linux/soundcard.h>
-#elif defined(__FreeBSD__) || defined(__CYGWIN__)
+#elif defined(__FreeBSD__) || defined(__CYGWIN__) || defined(__DragonFly__)
+#elif defined(__FreeBSD__) || defined(__CYGWIN__) || defined(__DragonFly__) || defined(__sun)
#include <sys/soundcard.h>
#else
#include <soundcard.h>
@@ -250,7 +250,7 @@ struct chan_oss_pvt {
char *name;
int total_blocks; /*!< total blocks in the output device */
int sounddev;
- enum { M_UNSET, M_FULL, M_READ, M_WRITE } duplex;
+ enum { M_UNSET, M_FULL, M_READ_foo, M_WRITE } duplex;
int autoanswer; /*!< Boolean: whether to answer the immediately upon calling */
int autohangup; /*!< Boolean: whether to hangup the call when the remote end hangs up */
int hookstate; /*!< Boolean: 1 if offhook; 0 if onhook */
@@ -518,7 +518,7 @@ static int setformat(struct chan_oss_pvt
break;
case O_RDONLY:
- o->duplex = M_READ;
+ o->duplex = M_READ_foo;
break;
}

View file

@ -0,0 +1,15 @@
$NetBSD: patch-main_editline_sys.h,v 1.1 2012/02/16 16:33:36 hans Exp $
--- main/editline/sys.h.orig 2010-07-28 00:30:38.000000000 +0200
+++ main/editline/sys.h 2012-01-25 15:50:04.918035224 +0100
@@ -103,9 +103,9 @@ extern int tgetent(const char *bp, char
extern int tgetflag(const char *id);
extern int tgetnum(const char *id);
extern char *tgetstr(const char *id, char **area);
-#endif
extern char *tgoto(const char *cap, int col, int row);
extern int tputs(const char *str, int affcnt, int (*putc)(int));
+#endif
extern char *getenv(const char *);
extern int fprintf(FILE *, const char *, ...);
extern int sigsetmask(int);