Define default_context_to before using it in templates.
This commit is contained in:
parent
de074147bc
commit
c0f10e3ea6
2 changed files with 42 additions and 1 deletions
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.5 2012/07/01 01:43:02 dholland Exp $
|
||||
$NetBSD: distinfo,v 1.6 2013/02/26 10:26:27 joerg Exp $
|
||||
|
||||
SHA1 (gobby-0.4.12.tar.gz) = 55d23f6ca51c1f2929218f6877f2c580a3b2c34e
|
||||
RMD160 (gobby-0.4.12.tar.gz) = fca36ca997e2f5fdd6062e135ea35f0adae6d965
|
||||
Size (gobby-0.4.12.tar.gz) = 464464 bytes
|
||||
SHA1 (patch-aa) = be469582c2e0d0b958adc7a8edb17b796f3ac15b
|
||||
SHA1 (patch-configure) = b3b9fd5d5698cfb7db946304f86d7c524d6bc948
|
||||
SHA1 (patch-inc_config.hpp) = c9b08460b0b11dab30069c092a7f1ce22c42a2a1
|
||||
SHA1 (patch-src_gselector_cpp) = 2b3065f34ab4557800e1dc5da9253da23fffa565
|
||||
|
|
40
editors/gobby/patches/patch-inc_config.hpp
Normal file
40
editors/gobby/patches/patch-inc_config.hpp
Normal file
|
@ -0,0 +1,40 @@
|
|||
$NetBSD: patch-inc_config.hpp,v 1.1 2013/02/26 10:26:27 joerg Exp $
|
||||
|
||||
--- inc/config.hpp.orig 2013-02-25 19:32:06.000000000 +0000
|
||||
+++ inc/config.hpp
|
||||
@@ -31,6 +31,19 @@
|
||||
#include <libxml++/nodes/element.h>
|
||||
#include <libxml++/nodes/textnode.h>
|
||||
|
||||
+
|
||||
+namespace serialise
|
||||
+{
|
||||
+template<>
|
||||
+class default_context_to<Glib::ustring>: public context_base_to<Glib::ustring>
|
||||
+{
|
||||
+public:
|
||||
+ typedef Glib::ustring data_type;
|
||||
+
|
||||
+ virtual std::string to_string(const data_type& from) const;
|
||||
+};
|
||||
+}
|
||||
+
|
||||
namespace Gobby
|
||||
{
|
||||
|
||||
@@ -460,15 +473,6 @@ public:
|
||||
};
|
||||
|
||||
template<>
|
||||
-class default_context_to<Glib::ustring>: public context_base_to<Glib::ustring>
|
||||
-{
|
||||
-public:
|
||||
- typedef Glib::ustring data_type;
|
||||
-
|
||||
- virtual std::string to_string(const data_type& from) const;
|
||||
-};
|
||||
-
|
||||
-template<>
|
||||
class default_context_from<Glib::ustring>:
|
||||
public context_base_from<Glib::ustring>
|
||||
{
|
Loading…
Reference in a new issue