Fix PLIST for SunOS.
This commit is contained in:
parent
5a784e8fe0
commit
c112971377
4 changed files with 30 additions and 3 deletions
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2014/12/01 05:58:03 jnemeth Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2015/01/20 11:03:51 fhajny Exp $
|
||||
bin/innochecksum
|
||||
bin/mcc_config.py
|
||||
bin/memclient
|
||||
|
@ -5677,7 +5677,7 @@ share/mysql/mcc/frontend/js/mcc/util/tests/runTests.html
|
|||
share/mysql/mcc/frontend/js/mcc/util/tests/util.js
|
||||
share/mysql/mcc/frontend/testProtocol.html
|
||||
share/mysql/mcc/frontend/welcome.html
|
||||
share/mysql/mcc/host_info/NetBSD/${MACHINE_ARCH}/host_info
|
||||
share/mysql/mcc/host_info/${OPSYS}/${MACHINE_ARCH}/host_info
|
||||
share/mysql/mcc/post-install.py
|
||||
share/mysql/mcc/remote_clusterhost.py
|
||||
share/mysql/mcc/request_handler.py
|
||||
|
|
2
databases/mysql-cluster/PLIST.SunOS
Normal file
2
databases/mysql-cluster/PLIST.SunOS
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST.SunOS,v 1.1 2015/01/20 11:03:51 fhajny Exp $
|
||||
share/mysql/solaris/postinstall-solaris
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2014/12/01 05:58:03 jnemeth Exp $
|
||||
$NetBSD: distinfo,v 1.2 2015/01/20 11:03:51 fhajny Exp $
|
||||
|
||||
SHA1 (mysql-cluster-gpl-7.3.7.tar.gz) = c0574d48d5ee94dcc8dbcfdcc89ae581df1cbaea
|
||||
RMD160 (mysql-cluster-gpl-7.3.7.tar.gz) = 93b62e00ea24bef90644df1daddead9b339e7e99
|
||||
|
@ -34,5 +34,6 @@ SHA1 (patch-storage_heap_CMakeLists.txt) = 0a1a5a7b5e83f14cec43bfa4782dd4bb7b629
|
|||
SHA1 (patch-storage_myisam_CMakeLists.txt) = 55897ae78208f78a396776d1082cb5f98631fff8
|
||||
SHA1 (patch-storage_myisammrg_CMakeLists.txt) = 0a56a16ccaff3fa9de996fec6ffc324af9855a4e
|
||||
SHA1 (patch-storage_ndb_mcc_frontend_dojo_dojox_mobile_build_build.sh) = 1aa09b34d5f9cef6fb244a2ca8d675a22f30a9a8
|
||||
SHA1 (patch-storage_ndb_mcc_host__info_CMakeLists.txt) = c21711c96387d0e9ddda9eff01691f7fbf08cab3
|
||||
SHA1 (patch-strings_decimal.c) = 069c9d930c735f74510702baa9bef38aec425903
|
||||
SHA1 (patch-vio_viossl.c) = 538c08e6ec85d02a7eeead2bb940c91c7f701321
|
||||
|
|
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-storage_ndb_mcc_host__info_CMakeLists.txt,v 1.1 2015/01/20 11:03:51 fhajny Exp $
|
||||
|
||||
Use DEFAULT_MACHINE instead of CMAKE_SYSTEM_PROCESSOR, because the latter is unreliable
|
||||
on systems like SunOS where `uname -p` returns i386 regardless.
|
||||
--- storage/ndb/mcc/host_info/CMakeLists.txt.orig 2014-10-09 13:46:25.000000000 +0000
|
||||
+++ storage/ndb/mcc/host_info/CMakeLists.txt
|
||||
@@ -80,7 +80,7 @@ include_directories(${CMAKE_CURRENT_BINA
|
||||
|
||||
if(DEFAULT_MYSQL_HOME)
|
||||
MYSQL_ADD_EXECUTABLE(host_info host_info.c
|
||||
- DESTINATION "${MCC_INSTALL_SUBDIR}/host_info/${CMAKE_SYSTEM_NAME}/${CMAKE_SYSTEM_PROCESSOR}"
|
||||
+ DESTINATION "${MCC_INSTALL_SUBDIR}/host_info/${CMAKE_SYSTEM_NAME}/${DEFAULT_MACHINE}"
|
||||
COMPONENT ClusterTools)
|
||||
else()
|
||||
# If not building as part of Cluster we don't have the
|
||||
@@ -91,7 +91,7 @@ else()
|
||||
# ... and install the old way
|
||||
# "Install" binary for this host into source tree
|
||||
install(TARGETS host_info
|
||||
- DESTINATION "${CMAKE_CURRENT_SOURCE_DIR}/binaries/${CMAKE_SYSTEM_NAME}/${CMAKE_SYSTEM_PROCESSOR}")
|
||||
+ DESTINATION "${CMAKE_CURRENT_SOURCE_DIR}/binaries/${CMAKE_SYSTEM_NAME}/${DEFAULT_MACHINE}")
|
||||
|
||||
# Install all binaries in source tree into install dir/package
|
||||
install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/binaries"
|
Loading…
Reference in a new issue