ImageMagick6: update to 6.9.13-3

Reflects upstream functional fix for image generation on NetBSD.
This commit is contained in:
gutteridge 2024-01-04 01:32:08 +00:00
parent 9df4240d78
commit c15a16da28
4 changed files with 7 additions and 36 deletions

View File

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.67 2024/01/01 02:15:27 gutteridge Exp $
# $NetBSD: Makefile,v 1.68 2024/01/04 01:32:08 gutteridge Exp $
.include "Makefile.common"
PKGNAME= ImageMagick6-${DISTVERSION}
PKGREVISION= 1
MAINTAINER= pkgsrc-users@NetBSD.org
COMMENT= Package for display and interactive manipulation of images

View File

@ -1,7 +1,7 @@
# $NetBSD: Makefile.common,v 1.18 2023/12/31 20:40:31 gutteridge Exp $
# $NetBSD: Makefile.common,v 1.19 2024/01/04 01:32:08 gutteridge Exp $
IM_MAJOR_VER= 6.9.13
IM_MINOR_VER= 2
IM_MINOR_VER= 3
IM_MAJOR_LIB_VER= 6
.if (${IM_MINOR_VER} != NONE)

View File

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.16 2023/12/31 20:40:31 gutteridge Exp $
$NetBSD: distinfo,v 1.17 2024/01/04 01:32:08 gutteridge Exp $
BLAKE2s (ImageMagick-6.9.13-2.tar.xz) = 4f91023d076210de16425e9a60b4c4ad43da23567640258dd7b2bc1b3f76417c
SHA512 (ImageMagick-6.9.13-2.tar.xz) = d693983eda6fba6b5e1d5d5bb4dc814dffd6a064c0464dded86c5f780ce52bef737d1bc870fae4c5bd039c419585fb374a0c4fbd19d94153d319eb8e3d5595b3
Size (ImageMagick-6.9.13-2.tar.xz) = 9611768 bytes
BLAKE2s (ImageMagick-6.9.13-3.tar.xz) = eef042b1cc600c0e6549943b3dc7889a59b2d307f8793cd3b795c5ca34daf486
SHA512 (ImageMagick-6.9.13-3.tar.xz) = 3e061c8a7bec0c49db9e990858257ff092500430d382bcad0c76aaa8d531bd2c13b727a52f060fc6051a0217f41f254570d23a4301c15a7af547e13f148a4ca9
Size (ImageMagick-6.9.13-3.tar.xz) = 9616088 bytes
SHA1 (patch-Makefile.in) = 8360c4e0903bdbc73dd40f9a466f40996c53ce44
SHA1 (patch-magick_blob.c) = 6890910addb9dcd153ef44c449b101cc43470302

View File

@ -1,27 +0,0 @@
$NetBSD: patch-magick_blob.c,v 1.1 2023/12/31 20:40:32 gutteridge Exp $
Fix regression that was causing image generation failures on NetBSD.
https://github.com/ImageMagick/ImageMagick/issues/6984
https://github.com/ImageMagick/ImageMagick6/commit/a1e5ff811aeb935f7adfa4740026c59dac2bb01f
--- magick/blob.c.orig 2023-12-25 14:08:06.000000000 +0000
+++ magick/blob.c
@@ -522,8 +522,7 @@ MagickExport MagickBooleanType CloseBlob
blob_info=image->blob;
if ((blob_info == (BlobInfo *) NULL) || (blob_info->type == UndefinedStream))
return(MagickTrue);
- if (SyncBlob(image) != 0)
- ThrowBlobException(blob_info);
+ (void) SyncBlob(image);
status=blob_info->status;
switch (blob_info->type)
{
@@ -4735,6 +4734,8 @@ static int SyncBlob(const Image *image)
assert(image->blob != (BlobInfo *) NULL);
if (IsEventLogging() != MagickFalse)
(void) LogMagickEvent(TraceEvent,GetMagickModule(),"%s",image->filename);
+ if (EOFBlob(image) != 0)
+ return(0);
blob_info=image->blob;
status=0;
switch (blob_info->type)