Explicitly reference the std version of some wchar.h functions to
resolve ambiguity.
This commit is contained in:
parent
e1ced9e7a5
commit
c17ddf7568
2 changed files with 17 additions and 1 deletions
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.5 2013/08/11 16:06:25 jaapb Exp $
|
||||
$NetBSD: distinfo,v 1.6 2013/08/13 10:24:22 joerg Exp $
|
||||
|
||||
SHA1 (clucene-core-2.3.3.4.tar.gz) = 76d6788e747e78abb5abf8eaad78d3342da5f2a4
|
||||
RMD160 (clucene-core-2.3.3.4.tar.gz) = 5acfc9c8acd167b3684cfc731a60fd9c5465cc9b
|
||||
Size (clucene-core-2.3.3.4.tar.gz) = 2241498 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 1c127bdc90a9f7b3c0f3debe46a9681f3b85df9a
|
||||
SHA1 (patch-src_contribs-lib_CMakeLists.txt) = c4cf7505474368a7a7b4b826c5d0a7df1cbc2a63
|
||||
SHA1 (patch-src_shared_CLucene_config_repl__tchar.h) = 465537d5ee226d9831df2da8d87f3dbc5e364d5f
|
||||
|
|
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_shared_CLucene_config_repl__tchar.h,v 1.1 2013/08/13 10:24:22 joerg Exp $
|
||||
|
||||
--- src/shared/CLucene/config/repl_tchar.h.orig 2011-03-17 00:21:07.000000000 +0000
|
||||
+++ src/shared/CLucene/config/repl_tchar.h
|
||||
@@ -36,8 +36,8 @@
|
||||
#define _tcsncpy wcsncpy //copy a specified amount of one string to another string.
|
||||
#define _tcscat wcscat //copy a string onto the end of the other string
|
||||
#define _tcsncat wcsncat
|
||||
- #define _tcschr wcschr //find location of one character
|
||||
- #define _tcsstr wcsstr //find location of a string
|
||||
+ #define _tcschr ::std::wcschr //find location of one character
|
||||
+ #define _tcsstr ::std::wcsstr //find location of a string
|
||||
#define _tcslen wcslen //get length of a string
|
||||
#define _tcscmp wcscmp //case sensitive compare two strings
|
||||
#define _tcsncmp wcsncmp //case sensitive compare two strings
|
Loading…
Reference in a new issue