update to 2.31

this is a major upgrade (from 1.07), please check the homepage for
details
(I've played with 2.30 for a while and it worked well.)
closes PR pkg/32872 by Evan Hall; thanks for the ncurses hint, wouldn't
have found it myself
This commit is contained in:
drochner 2006-03-02 20:05:57 +00:00
parent 3847bae468
commit c1889f8bb8
5 changed files with 50 additions and 25 deletions

View file

@ -1,18 +1,17 @@
# $NetBSD: Makefile,v 1.2 2005/06/16 06:57:56 jlam Exp $
# $NetBSD: Makefile,v 1.3 2006/03/02 20:05:57 drochner Exp $
DISTNAME= gpsd-1.07
DISTNAME= gpsd-2.31
CATEGORIES= geography
MASTER_SITES= http://www.pygps.org/gpsd/
MASTER_SITES= http://download.berlios.de/gpsd/
MAINTAINER= tsarna@NetBSD.org
HOMEPAGE= http://www.pygps.org/gpsd/
COMMENT= GPS information daemon
GNU_CONFIGURE= YES
USE_LIBTOOL= yes
INSTALLATION_DIRS= sbin
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gpsd ${PREFIX}/sbin
.include "../../devel/ncurses/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,2 +1,28 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/07/26 23:31:56 wiz Exp $
@comment $NetBSD: PLIST,v 1.2 2006/03/02 20:05:57 drochner Exp $
bin/cgps
bin/cgpxlogger
bin/gpsfake
bin/gpsflash
bin/gpspipe
bin/gpsprof
bin/rtcmdecode
bin/sirfmon
include/gps.h
include/gpsd.h
include/libgpsmm.h
lib/libgps.la
man/man1/cgpxlogger.1
man/man1/gpsfake.1
man/man1/gpsflash.1
man/man1/gpspipe.1
man/man1/gpsprof.1
man/man1/rtcmdecode.1
man/man1/sirfmon.1
man/man1/xgps.1
man/man3/libgps.3
man/man3/libgpsd.3
man/man3/libgpsmm.3
man/man5/rtcm-104.5
man/man5/srec.5
man/man8/gpsd.8
sbin/gpsd

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2005/02/22 21:08:32 agc Exp $
$NetBSD: distinfo,v 1.3 2006/03/02 20:05:57 drochner Exp $
SHA1 (gpsd-1.07.tar.gz) = 00650bec2f516bee671cd21f8f2fdc6c2aea0902
RMD160 (gpsd-1.07.tar.gz) = 1c1a8ae9f79f6280c761e79a579547fcee442aac
Size (gpsd-1.07.tar.gz) = 70930 bytes
SHA1 (patch-aa) = dfe7bbdddb9298f7ea2ac196c121b56233a951d2
SHA1 (gpsd-2.31.tar.gz) = c9f35d3b34023df1d3b4814f9c5fb4ed404fb898
RMD160 (gpsd-2.31.tar.gz) = 00c2d41b7cf18842699203e1bb3b564d167db956
Size (gpsd-2.31.tar.gz) = 620460 bytes
SHA1 (patch-ab) = 0703e9da1e6f34bd575c6b61f891fc13a3598bb4

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/07/26 23:31:56 wiz Exp $
--- netlib.c.orig 2004-06-04 00:49:02.000000000 +0200
+++ netlib.c
@@ -9,7 +9,7 @@
#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
-#include <varargs.h>
+#include <stdarg.h>
#include <netdb.h>
#include <stdio.h>
#include <arpa/inet.h>

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2006/03/02 20:05:57 drochner Exp $
--- sirfmon.c.orig 2006-02-19 15:30:10.000000000 +0100
+++ sirfmon.c
@@ -23,7 +23,7 @@
* so it deliberately doesn't use much of the library.
*/
#include <stdio.h>
-#include <curses.h>
+#include <ncurses.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>