Update gnuchess to 5.00. From the GNU chess web page:

Version 5.00 is the current release. Version 5.00 shares no code with
   versions 1.x through 4.x. The major motivation for this release is to
   simplify chess code making it more pedantically accessible, use modern
   data structures, make it easy to modify by less skilled programmers,
   and increase understandability to non-programmer, skilled chess
   experts.
This commit is contained in:
jlam 2000-03-26 08:29:25 +00:00
parent 45c2310c69
commit c1a19d047c
12 changed files with 75 additions and 194 deletions

View file

@ -1,24 +1,32 @@
# $NetBSD: Makefile,v 1.6 1999/11/17 23:21:53 tron Exp $
# $NetBSD: Makefile,v 1.7 2000/03/26 08:29:25 jlam Exp $
# FreeBSD Id: Makefile,v 1.6 1999/01/27 07:41:12 fenner Exp
#
DISTNAME= gnuchess-4.0.pl80
PKGNAME= gnuchess-4.0.80
WRKSRC= ${WRKDIR}/${DISTNAME}/src
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL}
DISTNAME= chess-5.00
PKGNAME= gnuchess-5.00
WRKSRC= ${WRKDIR}/${DISTNAME}/src
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GNU:=chess/}
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.gnu.org/software/chess/chess.html
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.gnu.org/software/chess/chess.html
MIRROR_DISTFILE= no
GNU_CONFIGURE= yes
USE_GMAKE= yes
ALL_TARGET= gnuchess
GNU_CONFIGURE= yes
post-build:
${SED} -e "s,@PREFIX@,${PREFIX},g" ${FILESDIR}/gnuchessx.sh \
> ${WRKDIR}/gnuchessx.sh
post-install:
${MKDIR} ${PREFIX}/share/doc/gnuchess
.for file in ARTICLE ARTICLE.2 CHESSTOOL FAQ HEURISTICS MOVE-GEN README.font README.output
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/${file} ${PREFIX}/share/doc/gnuchess
.endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gnuchess ${PREFIX}/bin/gnuchess
${INSTALL_SCRIPT} ${WRKDIR}/gnuchessx.sh ${PREFIX}/bin/gnuchessx
${INSTALL_DATA_DIR} ${PREFIX}/share/gnuchess
${INSTALL_DATA} ${WRKSRC}/book.dat ${WRKSRC}/book.pgn \
${PREFIX}/share/gnuchess
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/gnuchess
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/README \
${PREFIX}/share/doc/gnuchess
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,7 @@
#!/bin/sh
#
# $NetBSD: gnuchessx.sh,v 1.1 2000/03/26 08:29:25 jlam Exp $
#
# Wrapper script for gnuchess to interface with xboard.
exec @PREFIX@/bin/gnuchess xboard

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.3 1999/11/17 23:06:21 tron Exp $
$NetBSD: md5,v 1.4 2000/03/26 08:29:25 jlam Exp $
MD5 (gnuchess-4.0.pl80.tar.gz) = 833110654ec086b4ace45e037612033e
MD5 (chess-5.00.tar.gz) = 8bf7cd9250aa96c4e37e9770733d8fe3

View file

@ -1,7 +1,4 @@
$NetBSD: patch-sum,v 1.2 1999/11/17 23:06:22 tron Exp $
$NetBSD: patch-sum,v 1.3 2000/03/26 08:29:25 jlam Exp $
MD5 (patch-aa) = eb9353044e32ba547471a5ec50bfd665
MD5 (patch-ab) = 3878b056bf3bf89d75d483594a376584
MD5 (patch-ac) = 5dbc904dd3ef1e75d198a07c2aa44340
MD5 (patch-ad) = 91d9978a5ae0901d83a861769c21d900
MD5 (patch-ae) = 243c76fc330ec282d83ded70ffd68e16
MD5 (patch-aa) = 9aede68ccd4a386b653381a8245a21d5
MD5 (patch-ab) = 4376f2b68d7733c469ac67e657e1343f

View file

@ -1,20 +1,22 @@
$NetBSD: patch-aa,v 1.2 1999/11/17 23:06:22 tron Exp $
$NetBSD: patch-aa,v 1.3 2000/03/26 08:29:25 jlam Exp $
--- dspcom.c.orig Mon Sep 28 08:41:19 1998
+++ dspcom.c Thu Dec 10 23:40:57 1998
@@ -1099,14 +1099,14 @@
#ifdef NONDSP
s[0] = sx[0] = '\0';
while (!sx[0])
- (void) gets (sx);
+ (void) fgets (sx, 80, stdin); sx[79] = '\0';
#else
fflush (stdout);
#ifdef MSDOS
s[0] = '\0';
eof = ( gets (sx) == NULL );
#else
eof = ( getstr (sx) == ERR );
#endif
#endif
sscanf (sx, "%s", s);
--- Makefile.in.orig Sat Oct 23 11:43:36 1999
+++ Makefile.in Thu Feb 17 23:11:58 2000
@@ -43,7 +43,7 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
-LIBDIR = $(prefix)/lib
+LIBDIR = $(prefix)/share/gnuchess
BINDIR = $(exec_prefix)/bin
MANDIR = $(prefix)/man/man6
MANEXT = .6
@@ -63,7 +63,7 @@
# -DUNIVERSAL -- define for use with Novag Universal physical playing board.
INTERFACE=
-CFLAGS=-O3 -Winline -Wmissing-prototypes -funroll-loops -fomit-frame-pointer $(MACHINE) $(INTERFACE)
+CFLAGS=-O3 -Winline -Wmissing-prototypes -funroll-loops -fomit-frame-pointer $(MACHINE) $(INTERFACE) -DLIBDIR=\"${LIBDIR}/\"
# Not normally needed unless debugging or profiling.
# Debugging

View file

@ -1,47 +1,12 @@
$NetBSD: patch-ab,v 1.2 1999/11/17 23:06:22 tron Exp $
$NetBSD: patch-ab,v 1.3 2000/03/26 08:29:25 jlam Exp $
--- gnuan.c.orig Sat Apr 3 05:58:53 1999
+++ gnuan.c Wed Nov 17 23:57:25 1999
@@ -1348,12 +1348,12 @@
fpout = stderr;
fprintf (fpout, "Input the file with the algebraic moves of the game.\n");
fflush (fpout);
- gets (infilename);
+ fgets (infilename, 255, stdin); infilename[255] = '\0';
fprintf (fpout, "\n");
do
{
fprintf (fpout, "Input the search depth you want to use. (1 to 29)(- for depth from file)\n");
- gets (inbuf);
+ fgets (inbuf, 256, stdin); inbuf[255] = '\0';
search_depth = atoi (inbuf);
if (search_depth < 0)
{
@@ -1369,7 +1369,7 @@
do
{
fprintf (fpout, "Input the maximum number of minutes per move you want to use.\n");
- gets (inbuf);
+ fgets (inbuf, 256, stdin); inbuf[255] = '\0';
max_minutes = atoi (inbuf);
if (max_minutes < 0)
{
@@ -1379,7 +1379,7 @@
}
while ((max_minutes + max_seconds) < 1);
fprintf (fpout, "Post the search results(y/n).\n");
- gets (inbuf);
+ fgets (inbuf, 256, stdin); inbuf[255] = '\0';
if (inbuf[0] == 'y')
flag.post = true;
else
@@ -1559,7 +1559,8 @@
while (true)
{
printf (">");
- gets (GNUANinbuf1);
+ fgets (GNUANinbuf1, 128, stdin);
+ GNUANinbuf1[127] = '\0';
p = GNUANinbuf1;
q = GNUANinbuf;
while (true)
--- book.h.orig Fri Oct 15 23:41:03 1999
+++ book.h Thu Feb 17 23:11:33 2000
@@ -23,5 +23,5 @@
bug-gnu-chess@gnu.org
cracraft@ai.mit.edu, cracraft@stanfordalumni.org, cracraft@earthlink.net
*/
-#define BOOKSRC "book.pgn"
-#define BOOKBIN "book.dat"
+#define BOOKSRC LIBDIR "book.pgn"
+#define BOOKBIN LIBDIR "book.dat"

View file

@ -1,27 +0,0 @@
$NetBSD: patch-ac,v 1.2 1999/11/17 23:06:22 tron Exp $
--- nondsp.c.orig Mon Sep 28 08:41:22 1998
+++ nondsp.c Thu Dec 10 23:39:26 1998
@@ -264,10 +264,11 @@
NewGame ();
- gets (s); /* skip "setup" command */
+ fgets (s, 80, stdin); /* skip "setup" command */
+ s[79] = '\0';
for (r = 7; r >= 0; r--)
{
- gets (s);
+ fgets (s, 80, stdin); s[79] = '\0';
for (c = 0; c <= 7; c++)
{
ch = s[c];
@@ -617,7 +618,7 @@
if (!T[0])
{
printz (CP[61]);
- gets (T);
+ fgets (T, 64, stdin); T[63] = '\0';
}
strcat (T, "XX");
/* skip whitespace */

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ad,v 1.2 1999/11/17 23:06:22 tron Exp $
--- search.c.orig Mon Sep 28 08:41:23 1998
+++ search.c Thu Dec 10 23:39:26 1998
@@ -174,7 +174,7 @@
while (true)
{
printf ("debug?");
- gets (b);
+ fgets (b, 32, stdin); b[31] = '\0';
if (b[0] == 'p')
traceply = atoi (&b[1]);
else if (b[0] == '\0')

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ae,v 1.1.1.1 1999/02/08 08:48:37 frueauf Exp $
--- Makefile.in-orig Mon Sep 28 08:41:13 1998
+++ Makefile.in Mon Feb 8 08:52:59 1999
@@ -127,7 +127,7 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
-LIBDIR = $(prefix)/lib
+LIBDIR = $(prefix)/share/gnuchess
BINDIR = $(exec_prefix)/bin
MANDIR = $(prefix)/man/man6
MANEXT = .6
@@ -156,6 +156,7 @@
$(INSTALL) postprint $(BINDIR)/postprint
$(INSTALL) gnuan $(BINDIR)/gnuan
$(INSTALL) game $(BINDIR)/game
+ mkdir $(LIBDIR)
$(INSTALL) $(srcdir)/../misc/gnuchess.lang $(LIBDIR)/gnuchess.lang
$(INSTALL) $(srcdir)/../book/eco.pgn $(LIBDIR)/eco.pgn
$(INSTALL) gnuchess.data $(LIBDIR)/gnuchess.data

View file

@ -1 +1 @@
the "classic" GNU chess
GNU chess engine

View file

@ -2,23 +2,5 @@
plays against itself.
Gnuchess is an updated version of the GNU chess playing
program. It has a simple alpha-numeric board display, an
IBM PC compatible interface, or it can be compiled for use
with the chesstool program on a SUN workstation or with
the xboard program under X-windows. To invoke the program
gnuchess
- simple curses based version
gnuchessn
- fancy version using curses and inverse video on
UNIX, or IBM PC cursor controls and characters on
MSDOS
gnuchessr
- ASCII based version
gnuchessc
- chesstool compatible version
gnuchessx
- xboard compatible version
program. It has a simple alpha-numeric board display or
can be run with the xboard program under X-windows.

View file

@ -1,27 +1,8 @@
@comment $NetBSD: PLIST,v 1.2 1999/02/18 21:34:36 frueauf Exp $
@comment $NetBSD: PLIST,v 1.3 2000/03/26 08:29:26 jlam Exp $
bin/gnuchess
bin/gnuchessr
bin/gnuchessn
bin/gnuchessx
bin/gnuchessc
bin/postprint
bin/gnuan
bin/game
share/gnuchess/gnuchess.lang
share/gnuchess/eco.pgn
share/gnuchess/gnuchess.data
share/gnuchess/gnuchess.eco
share/doc/gnuchess/ARTICLE
share/doc/gnuchess/ARTICLE.2
share/doc/gnuchess/CHESSTOOL
share/doc/gnuchess/FAQ
share/doc/gnuchess/HEURISTICS
share/doc/gnuchess/MOVE-GEN
share/doc/gnuchess/README.font
share/doc/gnuchess/README.output
man/man6/game.6
man/man6/gnuan.6
man/man6/gnuchess.6
man/man6/postprint.6
@dirrm share/gnuchess
share/gnuchess/book.dat
share/gnuchess/book.pgn
share/doc/gnuchess/README
@dirrm share/doc/gnuchess
@dirrm share/gnuchess