xcb-util-image: update to 0.4.1.

Alan Coopersmith (9):
      Update README for gitlab migration
      Add README.md to EXTRA_DIST
      Update configure.ac bug URL for gitlab migration
      Update m4 to xorg/util/xcb-util-m4@c617eee22ae5c285e79e81
      Build xz tarballs instead of bzip2
      gitlab CI: add a basic build test
      configure: Drop AM_MAINTAINER_MODE
      autogen.sh: Honor NOCONFIGURE=1
      xcb-util-image 0.4.1

David Callu (1):
      test: add XCB_SHM_LIBS to all test

Emil Velikov (1):
      autogen.sh: use quoted string variables

Mihail Konev (1):
      autogen: add default patch prefix

Peter Hutterer (1):
      autogen.sh: use exec instead of waiting for configure to finish
This commit is contained in:
wiz 2022-10-18 22:07:05 +00:00
parent 1d27ac6f3b
commit c1b194fe31
4 changed files with 10 additions and 26 deletions

View File

@ -1,3 +1,2 @@
XCB util-image module provides the following library:
- image: Port of Xlib's XImage and XShmImage functions.
This library provides an XCB port of Xlib's XImage and XShmImage
functions.

View File

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.5 2017/08/16 20:21:18 wiz Exp $
# $NetBSD: Makefile,v 1.6 2022/10/18 22:07:05 wiz Exp $
DISTNAME= xcb-util-image-0.4.0
DISTNAME= xcb-util-image-0.4.1
CATEGORIES= x11
MASTER_SITES= https://xcb.freedesktop.org/dist/
EXTRACT_SUFX= .tar.bz2
MASTER_SITES= https://xorg.freedesktop.org/archive/individual/lib/
EXTRACT_SUFX= .tar.xz
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://xcb.freedesktop.org/

View File

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.8 2021/10/26 11:34:35 nia Exp $
$NetBSD: distinfo,v 1.9 2022/10/18 22:07:05 wiz Exp $
BLAKE2s (xcb-util-image-0.4.0.tar.bz2) = 6330d8bebe486e267e61ca6b0fefbbad614f3c49a3b12678a07a790837826c36
SHA512 (xcb-util-image-0.4.0.tar.bz2) = 9b7202c054e1160f9ca97a86be1210d9fb47f2119f89ca85f15f20909cca884bfe0cb88e3e71c75b65e1a0a72b980066ccac810e41a91db895c74dde77440d4f
Size (xcb-util-image-0.4.0.tar.bz2) = 327891 bytes
SHA1 (patch-image_xcb__bitops.h) = d6b8a29380d7f4c5faaa9e1c68c4a58005bf3e55
BLAKE2s (xcb-util-image-0.4.1.tar.xz) = e35593ecc0094441126afdeabbdf49d6033c2a4e2512edb42b48eabfe9f8eae8
SHA512 (xcb-util-image-0.4.1.tar.xz) = 9b47ba38b91196d76541b6ccabeaf291d3b91036f15422909cd6a79b3fd1a9786d5b1728e411bc41cfdf3d60a253485f4ef7c65ffa6ae646fa93439ec782746e
Size (xcb-util-image-0.4.1.tar.xz) = 289016 bytes

View File

@ -1,14 +0,0 @@
$NetBSD: patch-image_xcb__bitops.h,v 1.1 2018/01/25 13:47:22 jperkin Exp $
Workaround clang "error: control may reach end of non-void function".
--- image/xcb_bitops.h.orig 2011-06-30 08:05:22.000000000 +0000
+++ image/xcb_bitops.h
@@ -207,6 +207,7 @@ xcb_host_byte_order(void) {
return XCB_IMAGE_ORDER_LSB_FIRST;
}
assert(0);
+ return -1;
}
#endif /* __XCB_BITOPS_H__ */