_dbus_poll: Set the timeout value argument to poll to -1 whenever

it is less than -1 to avoid kde4 session start hang
From: Sverre Froyen
Bump PKGREVISION
This commit is contained in:
abs 2012-08-14 19:18:08 +00:00
parent 1fb9e81bcd
commit c216e6bb5c
3 changed files with 19 additions and 4 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.54 2012/08/01 17:52:21 drochner Exp $
# $NetBSD: Makefile,v 1.55 2012/08/14 19:18:08 abs Exp $
DISTNAME= dbus-1.6.4
PKGREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://dbus.freedesktop.org/releases/dbus/

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.40 2012/08/09 10:21:19 jperkin Exp $
$NetBSD: distinfo,v 1.41 2012/08/14 19:18:08 abs Exp $
SHA1 (dbus-1.6.4.tar.gz) = 17e619f008301592b7f01a60e7cf18e2752b5270
RMD160 (dbus-1.6.4.tar.gz) = 041ad41c26f38647f3da8d7f0cb548c979521def
Size (dbus-1.6.4.tar.gz) = 1927446 bytes
SHA1 (patch-aa) = 0c3d145979e3b2358261c9f7f34701d02eb6ecd4
SHA1 (patch-ab) = 1edd2dfd566b96a8908af2efa37d905919f07713
SHA1 (patch-ab) = 48dd40c59eef3d99e1933a646e23206c7c55bc97
SHA1 (patch-ak) = fcb0cad1b6e306db03d538d4ca65f4a18d4726ab
SHA1 (patch-al) = 3f9f793b0c1455bf2bf079cc27b841c22f42c276
SHA1 (patch-am) = 8c794ff8b0981e90243ee20c26ae1ecc72e68de8

View file

@ -1,4 +1,7 @@
$NetBSD: patch-ab,v 1.19 2012/08/01 17:52:22 drochner Exp $
$NetBSD: patch-ab,v 1.20 2012/08/14 19:18:08 abs Exp $
_dbus_poll: Set the timeout value argument to poll to -1 whenever
it is less than -1 to avoid kde4 session start hang
--- dbus/dbus-sysdeps-unix.c.orig 2012-07-03 18:02:45.000000000 +0000
+++ dbus/dbus-sysdeps-unix.c
@ -134,3 +137,14 @@ $NetBSD: patch-ab,v 1.19 2012/08/01 17:52:22 drochner Exp $
_dbus_verbose ("Socket credentials not supported on this OS\n");
#endif
}
@@ -2525,6 +2581,10 @@ _dbus_poll (DBusPollFD *fds,
_DBUS_STRUCT_OFFSET (DBusPollFD, revents) ==
_DBUS_STRUCT_OFFSET (struct pollfd, revents))
{
+ if (timeout_milliseconds < -1) {
+ _dbus_warn("_dbus_poll: timeout = %d (fixed)\n", timeout_milliseconds);
+ timeout_milliseconds = -1;
+ }
return poll ((struct pollfd*) fds,
n_fds,
timeout_milliseconds);