Import CLISP rawsock module as net/clisp-rawsock.
This commit is contained in:
parent
16e1f87020
commit
c239205b38
6 changed files with 76 additions and 0 deletions
1
net/clisp-rawsock/DESCR
Normal file
1
net/clisp-rawsock/DESCR
Normal file
|
@ -0,0 +1 @@
|
||||||
|
CLISP rawsock module.
|
18
net/clisp-rawsock/Makefile
Normal file
18
net/clisp-rawsock/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
# $NetBSD: Makefile,v 1.1.1.1 2010/07/09 19:12:27 asau Exp $
|
||||||
|
#
|
||||||
|
|
||||||
|
CLISP_MODULE= rawsock
|
||||||
|
|
||||||
|
PKGNAME= clisp-$(CLISP_MODULE)-$(CLISP_VERSION)
|
||||||
|
CATEGORIES= net
|
||||||
|
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=clisp/}
|
||||||
|
|
||||||
|
MAINTAINER= asau@inbox.ru
|
||||||
|
HOMEPAGE= http://clisp.cons.org/
|
||||||
|
COMMENT= CLISP rawsock module
|
||||||
|
|
||||||
|
MAKE_JOBS_SAFE= no
|
||||||
|
|
||||||
|
.include "../../lang/clisp/module.mk"
|
||||||
|
|
||||||
|
.include "../../mk/bsd.pkg.mk"
|
11
net/clisp-rawsock/PLIST
Normal file
11
net/clisp-rawsock/PLIST
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
@comment $NetBSD: PLIST,v 1.1.1.1 2010/07/09 19:12:27 asau Exp $
|
||||||
|
lib/clisp/dynmod/lib-rawsock.so
|
||||||
|
lib/clisp/dynmod/rawsock.lisp
|
||||||
|
lib/clisp/rawsock/Makefile
|
||||||
|
lib/clisp/rawsock/demos/README
|
||||||
|
lib/clisp/rawsock/demos/sniffer.lisp
|
||||||
|
lib/clisp/rawsock/link.sh
|
||||||
|
lib/clisp/rawsock/preload.lisp
|
||||||
|
lib/clisp/rawsock/rawsock.o
|
||||||
|
lib/clisp/rawsock/sock.fas
|
||||||
|
lib/clisp/rawsock/sock.lisp
|
7
net/clisp-rawsock/distinfo
Normal file
7
net/clisp-rawsock/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
||||||
|
$NetBSD: distinfo,v 1.1.1.1 2010/07/09 19:12:27 asau Exp $
|
||||||
|
|
||||||
|
SHA1 (clisp-2.49.tar.gz) = 1743e7917013162400c955af441e991db43b3323
|
||||||
|
RMD160 (clisp-2.49.tar.gz) = ae30f3b681cb023e885c6e4ed12210ee5ba14c76
|
||||||
|
Size (clisp-2.49.tar.gz) = 9823111 bytes
|
||||||
|
SHA1 (patch-aa) = 57ca93e90afba3ffc34070b7ba89211a481ea23f
|
||||||
|
SHA1 (patch-ab) = 1fe17741e422c190e515ca5d126e198b8182a7de
|
26
net/clisp-rawsock/patches/patch-aa
Normal file
26
net/clisp-rawsock/patches/patch-aa
Normal file
|
@ -0,0 +1,26 @@
|
||||||
|
$NetBSD: patch-aa,v 1.1.1.1 2010/07/09 19:12:27 asau Exp $
|
||||||
|
|
||||||
|
Override ac_install_sh.
|
||||||
|
|
||||||
|
--- modules/rawsock/configure.orig 2010-07-09 12:21:11.000000000 +0400
|
||||||
|
+++ modules/rawsock/configure 2010-07-09 12:21:37.000000000 +0400
|
||||||
|
@@ -2381,19 +2381,6 @@
|
||||||
|
required=true
|
||||||
|
${required} && test $cl_cv_have_clisp = no && as_fn_error "CLISP not found" "$LINENO" 5
|
||||||
|
|
||||||
|
-ac_aux_dir=
|
||||||
|
-for ac_dir in $cl_cv_clisp_libdir/build-aux "$srcdir"/$cl_cv_clisp_libdir/build-aux; do
|
||||||
|
- for ac_t in install-sh install.sh shtool; do
|
||||||
|
- if test -f "$ac_dir/$ac_t"; then
|
||||||
|
- ac_aux_dir=$ac_dir
|
||||||
|
- ac_install_sh="$ac_aux_dir/$ac_t -c"
|
||||||
|
- break 2
|
||||||
|
- fi
|
||||||
|
- done
|
||||||
|
-done
|
||||||
|
-if test -z "$ac_aux_dir"; then
|
||||||
|
- as_fn_error "cannot find install-sh, install.sh, or shtool in $cl_cv_clisp_libdir/build-aux \"$srcdir\"/$cl_cv_clisp_libdir/build-aux" "$LINENO" 5
|
||||||
|
-fi
|
||||||
|
|
||||||
|
# These three variables are undocumented and unsupported,
|
||||||
|
# and are intended to be withdrawn in a future Autoconf release.
|
13
net/clisp-rawsock/patches/patch-ab
Normal file
13
net/clisp-rawsock/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
$NetBSD: patch-ab,v 1.1.1.1 2010/07/09 19:12:27 asau Exp $
|
||||||
|
|
||||||
|
--- modules/rawsock/Makefile.in.orig 2010-04-16 11:36:58.000000000 +0400
|
||||||
|
+++ modules/rawsock/Makefile.in 2010-07-09 12:22:32.000000000 +0400
|
||||||
|
@@ -3,7 +3,7 @@
|
||||||
|
srcdir = @srcdir@
|
||||||
|
CC = @CC@
|
||||||
|
CPPFLAGS = @CPPFLAGS@
|
||||||
|
-CFLAGS = @CFLAGS@
|
||||||
|
+CFLAGS = @CLISP_CFLAGS@
|
||||||
|
CLISP = @CLISP@ -norc -q
|
||||||
|
CLISP_LINKKIT = @CLISP_LINKKIT@
|
||||||
|
|
Loading…
Reference in a new issue