Make it build on DragonFly.

This commit is contained in:
hasso 2008-12-30 20:25:54 +00:00
parent f399c0d753
commit c2d5a2bf9b
2 changed files with 11 additions and 9 deletions

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.5 2007/12/18 20:45:49 rumble Exp $
$NetBSD: distinfo,v 1.6 2008/12/30 20:25:54 hasso Exp $
SHA1 (radeontool-1.5.tar.gz) = bd9096d5b18b31a1f1addbea80e6debfc707abf6
RMD160 (radeontool-1.5.tar.gz) = 1cdeeb7ad379afa7bc03e1cd79adbb09f6a9cb85
Size (radeontool-1.5.tar.gz) = 20869 bytes
SHA1 (patch-aa) = fa7dfa4b6fe9cbf0d4eacce012047ba36b7ca548
SHA1 (patch-aa) = b2b765131bfcb22eb0e5082d529fb0f01644a9a3

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.3 2007/12/18 20:45:49 rumble Exp $
--- radeontool.c.orig 2007-12-17 21:35:53.000000000 -0500
+++ radeontool.c 2007-12-18 15:38:46.000000000 -0500
@@ -21,7 +21,17 @@
$NetBSD: patch-aa,v 1.4 2008/12/30 20:25:54 hasso Exp $
--- radeontool.c.orig 2004-02-11 05:50:27 +0200
+++ radeontool.c 2008-12-30 21:47:53 +0200
@@ -21,7 +21,19 @@
#include <sys/stat.h>
#include <fcntl.h>
#include <sys/mman.h>
@ -13,13 +13,15 @@ $NetBSD: patch-aa,v 1.3 2007/12/18 20:45:49 rumble Exp $
+#include <sys/lock.h>
+#endif
+#include <machine/vmparam.h>
+#elif defined(__DragonFly__)
+#include <sys/param.h>
+#else /* ! __NetBSD__ */
#include <asm/page.h>
+#endif
#include "radeon_reg.h"
@@ -107,7 +117,7 @@
@@ -107,7 +119,7 @@ static unsigned char * map_devince_memor
mem_fd,
base
);
@ -28,7 +30,7 @@ $NetBSD: patch-aa,v 1.3 2007/12/18 20:45:49 rumble Exp $
if(debug)
fprintf(stderr,"mmap returned %d\n",(int)device_mem);
fatal("mmap error \n");
@@ -251,7 +261,6 @@
@@ -251,7 +263,6 @@ static void map_radeon_cntl_mem(void)
} else if(forkrc == 0) { /* if child */
close(pipefd[0]);
dup2(pipefd[1],1); /* stdout */
@ -36,7 +38,7 @@ $NetBSD: patch-aa,v 1.3 2007/12/18 20:45:49 rumble Exp $
execlp("lspci","lspci","-v",NULL);
fatal("exec lspci failure\n");
}
@@ -307,7 +316,13 @@
@@ -307,7 +318,13 @@ We need to look through it to find the s
}
if(debug)
printf("%s",line);