Update parrot to version 3.4.0.

Local changes:
 o Remove local fix which has been adopted upstream.

Upstream changes:
3.4.0 news:

- Core
  + The Generational Mark and Sweep garbage collector is the new default.
  + The --gc-nursery-size command line argument was added.
  + Parrot now gets entropy from the underlying OS.
  + The NCI subsystem now supports 8, 16, 32 and 64 bit integers.
  + The NCI subsystem now supports "long long" and "long double" signatures.
    Not all platforms/compilers support these non-standard types, so developers
    are cautioned to take note that using them reduces portability.
  + Many more OpenGL functions in the Parrot OpenGL bindings are available,
    which required the above-mentioned signatures.
  + Bytecode-related embedding api functions moved to src/embed/bytecode.c.
- Languages
  + Winxed
    - Use 'using extern' for module imports.
    - Improved stage 0 prefix ++ and -- operators.
    - Allow 'null' in conditional operator.
    - Several examples are updated.
- Community
  + Google Summer of Code Bonding period is going well. Students are
    mostly done with their classes and much code will flow soon.
- Documentation
  + More PCT introductions are available.

3.3.0 news:

- Core
  + The isa and isa_pmc vtables can now be overridden from PIR
  + IMCC has a new improved external interface
  + A new IMCCompiler PMC adds prototype PDD31-alike functionality for the
    PIR and PASM compilers
  + New --with-llvm option to Configure.pl, which will link to LLVM if it
    is available
- Community
  + Parrot Virtual Machine was accepted into Google Summer of Code 2011
- Ecosystem
  + Rosella adds a stable "Event" library to implement a
    publish/subscribe mechanism
- Tests
  + The test coverage of the extend_vtable subsystem was greatly increased
This commit is contained in:
he 2011-05-18 08:20:30 +00:00
parent ea0b7ae802
commit c2e92828d7
3 changed files with 6 additions and 33 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.44 2011/04/06 11:22:57 he Exp $
# $NetBSD: Makefile,v 1.45 2011/05/18 08:20:30 he Exp $
#
VERSION= 3.2.0
VERSION= 3.4.0
RTYPE= devel
DISTNAME= parrot-${VERSION}
CATEGORIES= lang

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.38 2011/04/06 11:25:30 he Exp $
$NetBSD: distinfo,v 1.39 2011/05/18 08:20:30 he Exp $
SHA1 (parrot-3.2.0.tar.gz) = 06bbd16039bb2bac7397068a7ba2c9a6a36dd749
RMD160 (parrot-3.2.0.tar.gz) = 95ea31bacc3484decadb8926cd38fba5d99f55fc
Size (parrot-3.2.0.tar.gz) = 3955517 bytes
SHA1 (parrot-3.4.0.tar.gz) = df3b1349912c78605d9d3e35f00ccbba6be12b87
RMD160 (parrot-3.4.0.tar.gz) = 995e9b24a028eec6e60a65902c1570f8d3e04b8e
Size (parrot-3.4.0.tar.gz) = 3945732 bytes
SHA1 (patch-ad) = a972d48a879e541f6894f2eeb82a70b1756437d9
SHA1 (patch-ak) = 19d7dfff43bb08ba046040771e45b95774e024b7
SHA1 (patch-am) = 3e1cc7a4f99a972eb352e90701f8415a3f443c4a

View file

@ -1,26 +0,0 @@
$NetBSD: patch-am,v 1.2 2011/04/06 11:25:31 he Exp $
Perl uses stat(2) and lstat(2) directly, and those system calls may
not fill in st_rdev, leaving garbage behind. Parrot, on the other hand,
sets the st_rdev member always to 0 in stat_buf_to_array() in dynpmc/os.pmc,
so compensate for this by zeroing the st_rdev member from the perl stat
and lstat operations.
--- t/dynpmc/os.t.orig 2011-03-15 08:01:43.000000000 +0000
+++ t/dynpmc/os.t
@@ -324,6 +324,7 @@ my $stat;
my $count = $MSWin32 ? 11 : 13;
my @s = stat('xpto');
+$s[6] = 0; # Parrot does this internally...
if ( $cygwin ) {
# Mask inode number (fudge it)
$s[1] &= 0xffffffff;
@@ -483,6 +484,7 @@ SKIP: {
skip 'broken test TT #457', 1 if $solaris;
my @s = lstat('xpto');
+ $s[6] = 0; # Parrot does this internally...
if ($cygwin) {
# Mask inode number (fudge it)
$s[1] &= 0xffffffff;