Import of lit2epub 0.1.1

Script to convert .lit files to valid epub - from ebook-tools.
This commit is contained in:
markd 2010-06-06 23:41:12 +00:00
parent 73499d5105
commit c2edf5752e
5 changed files with 61 additions and 0 deletions

1
textproc/lit2epub/DESCR Normal file
View file

@ -0,0 +1 @@
Script to convert .lit files to valid epub - from ebook-tools.

View file

@ -0,0 +1,30 @@
# $NetBSD: Makefile,v 1.1.1.1 2010/06/06 23:41:12 markd Exp $
#
DISTNAME= ebook-tools-0.1.1
PKGNAME= lit2epub-0.1.1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ebook-tools/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://ebook-tools.sourceforge.net/
COMMENT= Convert .lit files to valid epub
LICENSE= mit
DEPENDS+= zip-[0-9]*:../../archivers/zip
DEPENDS+= convertlit-[0-9]*:../../textproc/convertlit
CONFLICTS+= ebook-tools<=0.1.1
PKG_DESTDIR_SUPPORT= user-destdir
USE_TOOLS+= bash:run
REPLACE_BASH= src/tools/lit2epub
NO_BUILD= yes
INSTALLATION_DIRS= bin
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/src/tools/lit2epub ${DESTDIR}${PREFIX}/bin
.include "../../mk/bsd.pkg.mk"

2
textproc/lit2epub/PLIST Normal file
View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/06/06 23:41:12 markd Exp $
bin/lit2epub

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2010/06/06 23:41:12 markd Exp $
SHA1 (ebook-tools-0.1.1.tar.gz) = 5c7c177914767412f3c8b145319fa4683755ac90
RMD160 (ebook-tools-0.1.1.tar.gz) = 02ee38ed7175e94577f718cc68c468f4e9d229ea
Size (ebook-tools-0.1.1.tar.gz) = 43280 bytes
SHA1 (patch-aa) = e8b2df45fdcd985eb1df5ed6a56861af268f7d7c

View file

@ -0,0 +1,22 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/06/06 23:41:12 markd Exp $
--- src/tools/lit2epub.orig 2008-06-07 21:09:38.000000000 +0200
+++ src/tools/lit2epub
@@ -2,7 +2,7 @@
# Uses clit to convert .lit files to valid epub
# known issues: created metadata uses the old spec
-CLIT=$(which clit)
+CLIT=$(which convertlit)
if [ "$?" != 0 ]; then
echo "Can't find clit, please make sure it is in your path"
@@ -42,7 +42,7 @@ if [ "$?" != 0 ]; then
fi
else
- TEMPDIR=$($MKTEMP -d)
+ TEMPDIR=$($MKTEMP -d -t lit2epub.tmp)
fi
WD=$(pwd)