mail: remove etpan
Unmaintained upstream and no longer supported by newer libetpan versions
This commit is contained in:
parent
e88b1fbbf9
commit
c31c1b6c61
7 changed files with 1 additions and 118 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.550 2020/05/14 16:58:41 nia Exp $
|
||||
# $NetBSD: Makefile,v 1.551 2020/05/25 11:49:47 nia Exp $
|
||||
#
|
||||
|
||||
COMMENT= Electronic mail utilities
|
||||
|
@ -79,7 +79,6 @@ SUBDIR+= elmo
|
|||
SUBDIR+= enma
|
||||
SUBDIR+= esmtp
|
||||
SUBDIR+= etach
|
||||
SUBDIR+= etpan
|
||||
SUBDIR+= evolution
|
||||
SUBDIR+= evolution-data-server
|
||||
SUBDIR+= exim
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
etPan is a mail client that is based on libEtPan!
|
||||
|
||||
Features:
|
||||
|
||||
* IMAP4rev1 / POP3 / NNTP / mbox / mh / maildir
|
||||
* virtual folder tree
|
||||
* multiple folder views and message views
|
||||
* smart multi-threading
|
||||
* PGP signing and encryption (using GnuPG as external command)
|
||||
* S/MIME signing and encryption (using OpenSSL as external command)
|
||||
* SPAM process (using bogofilter as external command)
|
||||
* user interface for configuration edition
|
|
@ -1,34 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.50 2020/05/22 10:56:19 adam Exp $
|
||||
|
||||
DISTNAME= etpan-ng-0.7.1
|
||||
PKGNAME= ${DISTNAME:S/-ng//}
|
||||
PKGREVISION= 42
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=libetpan/}
|
||||
|
||||
MAINTAINER= dawszy@arhea.pl
|
||||
#HOMEPAGE= http://libetpan.sourceforge.net/etpan/
|
||||
COMMENT= Mail console client with S/MIME and PGP support
|
||||
|
||||
BDB_ACCEPTED= db4 db5
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_TOOLS+= perl:run yacc
|
||||
GNU_CONFIGURE= yes
|
||||
FAKE_NCURSES= yes
|
||||
|
||||
DOCDIR= ${PREFIX}/share/doc/etpan
|
||||
|
||||
INSTALLATION_DIRS= bin share/doc/etpan
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/etpan ${DESTDIR}${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DESTDIR}${DOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/CONFIG ${DESTDIR}${DOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/INTERNAL ${DESTDIR}${DOCDIR}
|
||||
|
||||
.include "../../mk/curses.buildlink3.mk"
|
||||
.include "../../mail/libetpan/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../mk/bdb.buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,5 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2009/06/14 18:04:32 joerg Exp $
|
||||
bin/etpan
|
||||
share/doc/etpan/CONFIG
|
||||
share/doc/etpan/INTERNAL
|
||||
share/doc/etpan/README
|
|
@ -1,8 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.3 2015/11/03 23:27:04 agc Exp $
|
||||
|
||||
SHA1 (etpan-ng-0.7.1.tar.gz) = 2261913d31bbe64efe64a24cc37740eaf21d1d89
|
||||
RMD160 (etpan-ng-0.7.1.tar.gz) = bbd196a2151f99032dbdfc0ebb652a50567792f8
|
||||
SHA512 (etpan-ng-0.7.1.tar.gz) = e56ca50030516a0a35d2471505ce2c2ef94abb8f640a896bac0bc2cdaac65af38f69efd5f52219576df0a50d8bea92716c6dae5f4cf06fbd2a722bf768681493
|
||||
Size (etpan-ng-0.7.1.tar.gz) = 364394 bytes
|
||||
SHA1 (patch-aa) = 72ab16853068fc5d7f3f736411187b720d15f8a0
|
||||
SHA1 (patch-ab) = f45fadaa7b7326fe73726761c499fb2792527787
|
|
@ -1,43 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2005/08/06 05:32:19 xtraeme Exp $
|
||||
|
||||
--- src/Makefile.in.orig 2005-08-05 21:37:44.000000000 +0200
|
||||
+++ src/Makefile.in 2005-08-05 21:38:46.000000000 +0200
|
||||
@@ -7,14 +7,14 @@
|
||||
bindir = @bindir@
|
||||
INSTALL = @INSTALL@
|
||||
|
||||
-SHELL = /bin/sh
|
||||
-RM = rm -fr
|
||||
+#SHELL = /bin/sh
|
||||
+#RM = rm -fr
|
||||
# CPPFLAGS is duplicated for FreeBSD compatibility
|
||||
-CFLAGS = @DEFS@ @CFLAGS@ @CPPFLAGS@
|
||||
-CPPFLAGS = -I.. -Ilibversit @CPPFLAGS@
|
||||
-CC = @CC@
|
||||
+CFLAGS += @DEFS@
|
||||
+CPPFLAGS += -I.. -Ilibversit
|
||||
+#CC = @CC@
|
||||
PROGS = etpan
|
||||
-LDFLAGS = @LDFLAGS@ @LIBS@
|
||||
+LINKERFLAGS = @LDFLAGS@ @LIBS@
|
||||
|
||||
OBJ = \
|
||||
etpan-config.o \
|
||||
@@ -104,7 +104,7 @@
|
||||
all: all-recursive $(PROGS)
|
||||
|
||||
etpan: $(OBJ)
|
||||
- $(CC) -o $@ $(OBJ) $(VERSIT_OBJ) $(LDFLAGS)
|
||||
+ $(CC) -o $@ $(OBJ) $(VERSIT_OBJ) $(LINKERFLAGS)
|
||||
|
||||
install: etpan
|
||||
$(INSTALL) -m 755 -d $(bindir)
|
||||
@@ -123,7 +123,7 @@
|
||||
$(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
etpan-ldap-test: etpan-ldap-test.o etpan-ldap.o
|
||||
- $(CC) -o $@ etpan-ldap-test.o etpan-ldap.o $(LDFLAGS)
|
||||
+ $(CC) -o $@ etpan-ldap-test.o etpan-ldap.o $(LINKERFLAGS)
|
||||
|
||||
dep:
|
||||
$(CC) -M $(CFLAGS) $(OBJ:.o=.c) etpan-ldap-test.c | sed 's,\( /[^ ]*\),,g;/^ *\\$$/d' > .deps
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2005/08/06 05:32:19 xtraeme Exp $
|
||||
|
||||
--- src/etpan-app-subapp.c.orig 2005-08-06 07:00:51.000000000 +0200
|
||||
+++ src/etpan-app-subapp.c 2005-08-06 07:14:57.000000000 +0200
|
||||
@@ -807,7 +807,9 @@
|
||||
struct etpan_subapp * old_subapp;
|
||||
int app_index;
|
||||
|
||||
+#if 0
|
||||
color_reset(subapp->app);
|
||||
+#endif
|
||||
|
||||
old_subapp = subapp->app->current_subapp;
|
||||
if (old_subapp != NULL) {
|
Loading…
Reference in a new issue