Don't force linking against libstdc++, it might not exist. Bump

revision.
This commit is contained in:
joerg 2014-11-17 19:04:25 +00:00
parent e7ca5b655d
commit c3272bb396
5 changed files with 43 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.21 2013/05/26 09:07:34 adam Exp $
# $NetBSD: Makefile,v 1.22 2014/11/17 19:04:25 joerg Exp $
DISTNAME= LibRaw-0.15.1
PKGNAME= ${DISTNAME:tl}
PKGREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.libraw.org/data/

View file

@ -1,5 +1,8 @@
$NetBSD: distinfo,v 1.17 2013/05/26 09:07:34 adam Exp $
$NetBSD: distinfo,v 1.18 2014/11/17 19:04:25 joerg Exp $
SHA1 (LibRaw-0.15.1.tar.gz) = b080046190902169f7f329c09e9183789417f1d2
RMD160 (LibRaw-0.15.1.tar.gz) = 5364ee06551132cbaa1c6c2dc585ef8649c3baa1
Size (LibRaw-0.15.1.tar.gz) = 1406204 bytes
SHA1 (patch-configure) = 2d91bca722e5c45e8f7695a1f7f571937b5b7697
SHA1 (patch-configure.ac) = c7b3def34afb52b7353a56d4f2d940cb5ec3d1a4
SHA1 (patch-libraw__r.pc.in) = 4a09704852e7c107bf656de1210bfdea5b889beb

View file

@ -0,0 +1,13 @@
$NetBSD: patch-configure,v 1.1 2014/11/17 19:04:25 joerg Exp $
--- configure.orig 2013-05-24 17:55:19.000000000 +0000
+++ configure
@@ -16207,7 +16207,7 @@ $as_echo "$as_me: WARNING: Unable to fin
fi
fi
-LIBS="$LIBS -lm -lstdc++"
+LIBS="$LIBS -lm"
LIBRAW_SHLIB_VERSION=9:0:0

View file

@ -0,0 +1,13 @@
$NetBSD: patch-configure.ac,v 1.1 2014/11/17 19:04:25 joerg Exp $
--- configure.ac.orig 2013-05-17 22:56:40.000000000 +0000
+++ configure.ac
@@ -220,7 +220,7 @@ if test x$dp3 = xtrue ; then
fi
fi
-LIBS="$LIBS -lm -lstdc++"
+LIBS="$LIBS -lm"
AC_SUBST([LIBRAW_SHLIB_VERSION],m4_esyscmd([./shlib-version.sh]))
AC_SUBST([LIBRAW_RELEASE_VERSION],m4_esyscmd([./version.sh]))

View file

@ -0,0 +1,11 @@
$NetBSD: patch-libraw__r.pc.in,v 1.1 2014/11/17 19:04:25 joerg Exp $
--- libraw_r.pc.in.orig 2013-05-17 22:56:40.000000000 +0000
+++ libraw_r.pc.in
@@ -7,5 +7,5 @@ Name: libraw
Description: Raw image decoder library (thread-safe)
Requires: @PACKAGE_REQUIRES@
Version: @PACKAGE_VERSION@
-Libs: -L${libdir} -lraw_r -lstdc++@PC_OPENMP@
+Libs: -L${libdir} -lraw_r @PC_OPENMP@
Cflags: -I${includedir}/libraw