fix fallout from boost and cmake updates:

-prefix uses of "exception" with "std::" to avoid conflict with
 a similar definition in new "boost"
-set a cmake var to get an rpath into the installed executable
 (seems that cmake's behaviour changed)
This commit is contained in:
drochner 2008-09-16 13:23:42 +00:00
parent 32d094cb31
commit c3299e116a
6 changed files with 194 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.25 2008/06/20 01:09:27 joerg Exp $
# $NetBSD: Makefile,v 1.26 2008/09/16 13:23:42 drochner Exp $
DISTNAME= stellarium-0.9.1
CATEGORIES= misc
@ -21,6 +21,7 @@ CM_ARGS+= -D CMAKE_INSTALL_PREFIX:PATH=${PREFIX}
CM_ARGS+= -D FreeType2_INCLUDE_DIR:PATH=${LOCALBASE}/include/freetype2
CM_ARGS+= -D FreeType2_LIBRARIES:PATH=${LOCALBASE}/lib
CM_ARGS+= -D SDLMIXER_INCLUDE_DIR:PATH=${LOCALBASE}/include/SDL
CM_ARGS+= -D CMAKE_INSTALL_RPATH_USE_LINK_PATH:BOOL=TRUE
do-configure:
(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} cmake ${CM_ARGS} .)

View file

@ -1,5 +1,9 @@
$NetBSD: distinfo,v 1.8 2008/02/28 18:07:54 drochner Exp $
$NetBSD: distinfo,v 1.9 2008/09/16 13:23:42 drochner Exp $
SHA1 (stellarium-0.9.1.tar.gz) = 7cbfc207a4497d7f9afa0dda715fae21f8a0d9ef
RMD160 (stellarium-0.9.1.tar.gz) = df777f6f0f1f7748dd1ce1e2de7cc343cc9caaed
Size (stellarium-0.9.1.tar.gz) = 31491807 bytes
SHA1 (patch-aa) = 2791d454360c81f05c80dede368fe65fe32aa66c
SHA1 (patch-ab) = 04570905a82b80054f4dfe207eb6bbe3a4fe9696
SHA1 (patch-ac) = 28d42d9663289bc73d31071ea9b7ac50f19d4b25
SHA1 (patch-ad) = b70c6c7ab288e9ab1f07432c7599c06a8759fb8a

View file

@ -0,0 +1,94 @@
$NetBSD: patch-aa,v 1.1 2008/09/16 13:23:42 drochner Exp $
--- src/StelApp.cpp.orig 2008-09-15 13:42:12.000000000 +0200
+++ src/StelApp.cpp
@@ -141,7 +141,7 @@ void StelApp::init()
{
Translator::init(stelFileMgr->findFile("data/iso639-1.utf8"));
}
- catch (exception& e)
+ catch (std::exception& e)
{
cerr << "ERROR while loading translations: " << e.what() << endl;
}
@@ -180,7 +180,7 @@ void StelApp::init()
{
fontMapFile = stelFileMgr->findFile(QFile::decodeName("data/fontmap.dat"));
}
- catch(exception& e)
+ catch(std::exception& e)
{
cerr << "ERROR when locating font map file: " << e.what() << endl;
}
@@ -243,7 +243,7 @@ void StelApp::init()
{
iconPath = stelFileMgr->findFile("data/icon.bmp");
}
- catch(exception& e)
+ catch(std::exception& e)
{
cerr << "ERROR when trying to locate icon file: " << e.what() << endl;
}
@@ -425,7 +425,7 @@ void StelApp::parseCLIArgsPreConfig(void
stelFileMgr->findFile("landscapes/" + *i + "/landscape.ini");
cout << (*i).toUtf8().data() << endl;
}
- catch(exception& e){}
+ catch(std::exception& e){}
}
exit(0);
}
@@ -434,7 +434,7 @@ void StelApp::parseCLIArgsPreConfig(void
{
setConfigFile(qPrintable(argsGetOptionWithArg<QString>(argList, "-c", "--config-file", "config.ini")));
}
- catch(exception& e)
+ catch(std::exception& e)
{
cerr << "ERROR: while looking for --config-file option: " << e.what() << ". Using \"config.ini\"" << endl;
setConfigFile("config.ini");
@@ -463,7 +463,7 @@ void StelApp::parseCLIArgsPostConfig(Ini
projectionType = argsGetOptionWithArg<QString>(argList, "", "--projection-type", "");
}
- catch (exception& e)
+ catch (std::exception& e)
{
cerr << "ERROR while checking command line options: " << e.what() << endl;
exit(0);
@@ -746,7 +746,7 @@ void StelApp::setConfigFile(const QStrin
configFile = stelFileMgr->findFile(configName, StelFileMgr::FLAGS(StelFileMgr::WRITABLE|StelFileMgr::FILE));
return;
}
- catch(exception& e)
+ catch(std::exception& e)
{
//cerr << "DEBUG StelApp::setConfigFile could not locate writable config file " << configName << endl;
}
@@ -756,7 +756,7 @@ void StelApp::setConfigFile(const QStrin
configFile = stelFileMgr->findFile(configName, StelFileMgr::FILE);
return;
}
- catch(exception& e)
+ catch(std::exception& e)
{
//cerr << "DEBUG StelApp::setConfigFile could not find read only config file " << configName << endl;
}
@@ -767,7 +767,7 @@ void StelApp::setConfigFile(const QStrin
//cerr << "DEBUG StelApp::setConfigFile found NEW file path: " << configFile << endl;
return;
}
- catch(exception& e)
+ catch(std::exception& e)
{
cerr << "ERROR StelApp::setConfigFile could not find or create configuration file " << configName.toUtf8().data() << endl;
exit(1);
@@ -781,7 +781,7 @@ void StelApp::copyDefaultConfigFile()
{
defaultConfigFilePath = stelFileMgr->findFile("data/default_config.ini");
}
- catch(exception& e)
+ catch(std::exception& e)
{
cerr << "ERROR (copyDefaultConfigFile): failed to locate data/default_config.ini. Please check your installation." << endl;
exit(1);

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ab,v 1.1 2008/09/16 13:23:42 drochner Exp $
--- src/stel_command_interface.cpp.orig 2008-09-15 14:03:46.000000000 +0200
+++ src/stel_command_interface.cpp
@@ -436,7 +436,7 @@ int StelCommandInterface::execute_comman
image_filename = stapp->getFileMgr().findFile(image_filename);
script_images->load_image(image_filename, args["name"].c_str(), img_pos);
}
- catch(exception& e)
+ catch(std::exception& e)
{
cerr << "ERROR finding script: " << e.what() << endl;
debug_message = _("Unable to open file: ") + image_filename.toStdWString();
@@ -511,7 +511,7 @@ int StelCommandInterface::execute_comman
audio = new Audio(QFile::encodeName(audioFilePath).constData(), "default track", StelUtils::stringToLong(args["output_rate"]));
audio->play(args["loop"]=="on");
}
- catch(exception& e)
+ catch(std::exception& e)
{
cerr << "ERROR while trying to play audio file: " << args["filename"] << " : " << e.what() << endl;
}

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1 2008/09/16 13:23:42 drochner Exp $
--- src/stel_ui_conf.cpp.orig 2008-09-15 14:05:32.000000000 +0200
+++ src/stel_ui_conf.cpp
@@ -620,7 +620,7 @@ void StelUI::load_cities(const string& p
{
fileName = StelApp::getInstance().getFileMgr().findFile(QString("data/cities_") + planetEnglishName.c_str() + ".fab");
}
- catch (exception& e)
+ catch (std::exception& e)
{
cerr << "INFO StelUI::load_cities " << e.what() << endl;
return;

View file

@ -0,0 +1,58 @@
$NetBSD: patch-ad,v 1.1 2008/09/16 13:23:42 drochner Exp $
--- src/stel_ui_tuiconf.cpp.orig 2008-09-15 14:07:22.000000000 +0200
+++ src/stel_ui_tuiconf.cpp
@@ -155,7 +155,7 @@ void StelUI::init_tui(void)
{
tui_time_settmz = new s_tui::Time_zone_item(QFile::encodeName(app->getFileMgr().findFile("data/zone.tab")).constData(), wstring(L"2.2 "));
}
- catch(exception &e)
+ catch(std::exception &e)
{
cerr << "ERROR locating zone file: " << e.what() << endl;
}
@@ -520,7 +520,7 @@ int StelUI::handle_keys_tui(Uint16 key,
cmd = "script action play filename \"" + SelectedScript
+ "\" path \"" + QFile::encodeName(theParent).constData() + "/\"";
}
- catch(exception& e)
+ catch(std::exception& e)
{
cerr << "ERROR while executing script " << SelectedScript << ": " << e.what() << endl;
}
@@ -677,7 +677,7 @@ void StelUI::tui_cb_admin_save_default(v
{
saveCurrentConfig(app->getConfigFilePath());
}
- catch(exception& e)
+ catch(std::exception& e)
{
cerr << "ERROR: could not save config.ini file: " << e.what() << endl;
}
@@ -686,7 +686,7 @@ void StelUI::tui_cb_admin_save_default(v
{
system( QFile::encodeName(app->getFileMgr().findFile("data/script_save_config ")).constData());
}
- catch(exception& e)
+ catch(std::exception& e)
{
cerr << "ERROR while calling script_save_config: " << e.what() << endl;
}
@@ -699,7 +699,7 @@ void StelUI::tui_cb_admin_updateme(void)
{
system( QFile::encodeName(app->getFileMgr().findFile("data/script_internet_update ")).constData());
}
- catch(exception& e)
+ catch(std::exception& e)
{
cerr << "ERROR while calling script_internet_update: " << e.what() << endl;
}
@@ -713,7 +713,7 @@ void StelUI::tui_cb_admin_shutdown(void)
{
system( QFile::encodeName(app->getFileMgr().findFile("data/script_shutdown ")).constData());
}
- catch(exception& e)
+ catch(std::exception& e)
{
cerr << "ERROR while calling script_shutdown: " << e.what() << endl;
}