Update to version 3.1.19.
From the CHANGES file: 254 v3.1 rev 19 8/12/03 Required reconfiguring without Tcl once to generate the "Makefile.in" in the Xw directory; otherwise, automake 1.7 becomes a requirement. 253 v3.1 rev 18 8/6/03 A fix to the output, correcting the page numbering in the PostScript page headers. The incorrect numbering can cause some printers to lock up. . . 252 v3.1 rev 17 7/14/03 Thanks to Ted Roth for fixing my rather too-hasty fix of revision 16. Also: Some fixes to the autoconf script (also from Ted Roth), and autoconf script updated to work with the latest versions of autoconf/automake/aclocal.
This commit is contained in:
parent
e86593f3e0
commit
c338224e93
3 changed files with 5 additions and 24 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.13 2003/07/17 21:25:31 grant Exp $
|
||||
# $NetBSD: Makefile,v 1.14 2003/08/31 02:02:30 jtb Exp $
|
||||
|
||||
DISTNAME= xcircuit-3.1.16
|
||||
DISTNAME= xcircuit-3.1.19
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
CATEGORIES= cad graphics
|
||||
MASTER_SITES= http://bach.ece.jhu.edu/~tim/programs/xcircuit/archive/
|
||||
|
|
|
@ -1,10 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.4 2003/08/04 07:17:36 jmc Exp $
|
||||
$NetBSD: distinfo,v 1.5 2003/08/31 02:02:30 jtb Exp $
|
||||
|
||||
SHA1 (xcircuit-3.1.16.tar.bz2) = 1602c066e415cc1a0501222c66da94aee5ecb10c
|
||||
Size (xcircuit-3.1.16.tar.bz2) = 652104 bytes
|
||||
SHA1 (xcircuit-3.1.19.tar.bz2) = cc45c073fd53ba457e142fe06e694409da83729e
|
||||
Size (xcircuit-3.1.19.tar.bz2) = 650324 bytes
|
||||
SHA1 (patch-aa) = 252824044a7bd55f7a09a345cba3bd2903d1caf0
|
||||
SHA1 (patch-ab) = fb9604f7c3efc09aa0db3f40bf7b951e26bd715a
|
||||
SHA1 (patch-ac) = 9bb20a39445e532d1fbe4587eb39cdd0cc5a0e6a
|
||||
SHA1 (patch-ad) = 45a2f28f140eaff81a22c2cdda9733801c91dbb4
|
||||
SHA1 (patch-ae) = a65367b80369b1ba6aa22b71ab692b9705165764
|
||||
SHA1 (patch-af) = 51c1f03005cb237078f417a138e39a580e73cbcd
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2003/07/10 08:03:58 jtb Exp $
|
||||
|
||||
--- netlist.c.orig
|
||||
+++ netlist.c
|
||||
@@ -2045,11 +2045,11 @@
|
||||
break;
|
||||
case 'x':
|
||||
sout = (char *)realloc(sout, strlen(sout) + 7);
|
||||
- strcat(sout, "%d", clist->callinst->position.x);
|
||||
+ strncat(sout, "%d", clist->callinst->position.x);
|
||||
break;
|
||||
case 'y':
|
||||
sout = (char *)realloc(sout, strlen(sout) + 7);
|
||||
- strcat(sout, "%d", clist->callinst->position.y);
|
||||
+ strncat(sout, "%d", clist->callinst->position.y);
|
||||
break;
|
||||
case 'p':
|
||||
/* Pin name either has no spaces or is in quotes */
|
Loading…
Reference in a new issue