Disable MMX section on Solaris which has compiler issues, and ensure

libxine-interface.la is not empty by using the dummy object.

Fixes package on Solaris.
This commit is contained in:
jperkin 2012-09-20 15:33:40 +00:00
parent a7117744c7
commit c345d78c04
4 changed files with 50 additions and 8 deletions

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.86 2012/09/20 15:27:29 jperkin Exp $
$NetBSD: distinfo,v 1.87 2012/09/20 15:33:40 jperkin Exp $
SHA1 (xine-lib-1.2.2.tar.xz) = a349cbb0b72256bb262377796a022dcf63829b4c
RMD160 (xine-lib-1.2.2.tar.xz) = 3f11df3fa8a8946bdcc9cdecd6952dc76b834d14
Size (xine-lib-1.2.2.tar.xz) = 4857248 bytes
SHA1 (patch-Makefile.am) = ab2bdb97834ea3ebf161e2c716f0dcb6eb147c1e
SHA1 (patch-ad) = 94aaac03f74c72a1ca753d1320aac07d1bb8a846
SHA1 (patch-ag) = 0bdd5910ad7c446bdec5abac3292bcab7a4147ee
SHA1 (patch-ag) = 00009002714ed26fa646eed326e2b0a5e2265572
SHA1 (patch-aj) = 4215c3bc37cf636e563a509f9a391081ed8e773b
SHA1 (patch-ak) = 987700e6526b5112ac66bd6a8f9ee41f338c3508
SHA1 (patch-ap) = d48fa83879895d4b1f56bfbcbe31087dd57d8a82
@ -41,3 +41,5 @@ SHA1 (patch-src-xine-engine-post.h) = 3b96d1279bbec48b2f3df50a576bfa8ec25f796f
SHA1 (patch-src_audio__out_Makefile.am) = 5f8ba2ce81a63cb195407c3ce6649007ce15408f
SHA1 (patch-src_libw32dll_wine_Makefile.am) = 17c717c84531780dc06c3cd5db8f879a560aeb3a
SHA1 (patch-src_libw32dll_wine_registry.c) = f34685be27dc9ec098f80e78cd24f3e92f12367a
SHA1 (patch-src_post_goom_convolve_fx.c) = 61ab87d03780f057ba6e8e7f2097e57bac9bfa49
SHA1 (patch-src_xine-engine_Makefile.am) = 24efec8a881ca068b18e6370e9b02a6f6bc5c3d9

View file

@ -1,8 +1,17 @@
$NetBSD: patch-ag,v 1.25 2012/04/01 18:42:02 hans Exp $
$NetBSD: patch-ag,v 1.26 2012/09/20 15:33:40 jperkin Exp $
--- configure.ac.orig 2012-02-04 00:41:43.000000000 +0000
+++ configure.ac
@@ -272,6 +272,10 @@ AC_CHECK_LIB([nsl], [gethostbyname],
--- configure.ac.orig 2012-06-09 17:30:18.000000000 +0000
+++ configure.ac 2012-09-20 14:41:33.687892237 +0000
@@ -9,7 +9,7 @@
dnl Initialize autoconf, autoheader, and automake
AC_INIT([xine-lib], XINE_VERSION_SPEC, [xine-bugs@lists.sourceforge.net])
-AM_INIT_AUTOMAKE
+AM_INIT_AUTOMAKE([subdir-objects])
AC_CONFIG_SRCDIR([src/xine-engine/xine.c])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_LIBOBJ_DIR([lib])
@@ -272,6 +272,10 @@
AC_CHECK_LIB([resolv], [hstrerror], [NET_LIBS="-lresolv $NET_LIBS"])
AC_SUBST(NET_LIBS)
@ -13,7 +22,7 @@ $NetBSD: patch-ag,v 1.25 2012/04/01 18:42:02 hans Exp $
AC_CHECK_LIB([rt], [clock_getres],
[RT_LIBS="-lrt"
AC_DEFINE(HAVE_POSIX_TIMERS, 1, [Define this if you have POSIX timers.])],
@@ -361,6 +365,10 @@ case "$host_os" in
@@ -361,6 +365,10 @@
esac
AC_CHECK_HEADERS([sys/dvdio.h sys/cdio.h sys/scsiio.h])
@ -24,7 +33,7 @@ $NetBSD: patch-ag,v 1.25 2012/04/01 18:42:02 hans Exp $
dnl ----------------
dnl checks for types
@@ -908,6 +916,7 @@ AC_CHECK_FUNCS([strncasecmp _strnicmp],
@@ -905,6 +913,7 @@
AC_FUNC_FSEEKO

View file

@ -0,0 +1,17 @@
$NetBSD: patch-src_post_goom_convolve_fx.c,v 1.1 2012/09/20 15:33:40 jperkin Exp $
Solaris cannot handle this MMX section, failing with:
error: can't find a register in class GENERAL_REGS while reloading 'asm'.
--- src/post/goom/convolve_fx.c.orig 2012-09-20 15:19:11.848384461 +0000
+++ src/post/goom/convolve_fx.c 2012-09-20 15:19:24.654150136 +0000
@@ -151,7 +151,7 @@
ytex = yprime + yi + CONV_MOTIF_W * 0x10000 / 2;
yprime += c;
-#if defined(HAVE_MMX) && ! defined(ARCH_X86_64)
+#if defined(HAVE_MMX) && ! defined(ARCH_X86_64) && !defined(__sun)
/* This code uses 32-bit registers eax,ecx,esi */
__asm__ __volatile__
("\n\t pxor %%mm7, %%mm7" /* mm7 = 0 */

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_xine-engine_Makefile.am,v 1.1 2012/09/20 15:33:40 jperkin Exp $
Ensure we link something.
--- src/xine-engine/Makefile.am.orig 2012-09-20 14:30:26.827382120 +0000
+++ src/xine-engine/Makefile.am 2012-09-20 14:31:37.419849112 +0000
@@ -50,6 +50,7 @@
-version-info $(XINE_LT_CURRENT):$(XINE_LT_REVISION):$(XINE_LT_AGE)
libxine_interface_la_SOURCES =
+libxine_interface_la_LIBADD = @LTLIBOBJS@
libxine_interface_la_LDFLAGS = $(AM_LDFLAGS) $(def_ldflags) \
-version-info $(XINE_LT_CURRENT):$(XINE_LT_REVISION):$(XINE_LT_AGE)