Adapt this package to NetBSD.
This commit is contained in:
parent
f22d5ce6fa
commit
c349396b06
6 changed files with 42 additions and 17 deletions
|
@ -1,27 +1,19 @@
|
|||
# New ports collection makefile for: grep+mb
|
||||
# Version required: 2.0+mb1.04
|
||||
# Date created: 2 April 1995
|
||||
# Whom: Nobuhiro Yasutomi <nobu@psrc.isac.co.jp>
|
||||
#
|
||||
# $Id: Makefile,v 1.1.1.1 1999/06/08 09:22:01 sakamoto Exp $
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.2 1999/06/08 09:27:27 sakamoto Exp $
|
||||
# FreeBSD Id: Makefile,v 1.10 1999/01/27 07:41:16 fenner Exp $
|
||||
|
||||
DISTNAME= grep-2.0
|
||||
PKGNAME= ja-grep-2.0
|
||||
CATEGORIES= japanese textproc
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= grep
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=grep/}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.ORG
|
||||
MAINTAINER= tech-pkg-ja@jp.netbsd.org
|
||||
HOMEPAGE= http://www.gnu.org/software/grep/grep.html
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
PATCH_STRIP= -p1
|
||||
MAN1= grep.1
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/ja-grep
|
||||
${INSTALL_DATA} ${WRKSRC}/README.MB ${PREFIX}/share/doc/ja-grep
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1 +1,3 @@
|
|||
$NetBSD: md5,v 1.2 1999/06/08 09:27:27 sakamoto Exp $
|
||||
|
||||
MD5 (grep-2.0.tar.gz) = b676733ad3437ebd5dc3999f56c55950
|
||||
|
|
|
@ -1,3 +1,5 @@
|
|||
$NetBSD: patch-aa,v 1.2 1999/06/08 09:27:27 sakamoto Exp $
|
||||
|
||||
$B!|!|!|!|!|(B GNU grep version 2.0 + multi-byte extension 1.04 $B!|!|!|!|!|(B
|
||||
$B!|!|!|!|!|(B Jun. 2, 1994 by t^2 $B!|!|!|!|!|(B
|
||||
|
||||
|
|
|
@ -1,3 +1,5 @@
|
|||
$NetBSD: patch-ab,v 1.2 1999/06/08 09:27:27 sakamoto Exp $
|
||||
|
||||
--- grep-2.0/Makefile.in.orig Tue Apr 4 02:25:58 1995
|
||||
+++ grep-2.0/Makefile.in Tue Apr 4 02:27:57 1995
|
||||
@@ -74,7 +74,7 @@
|
||||
|
|
25
japanese/grep/patches/patch-ac
Normal file
25
japanese/grep/patches/patch-ac
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-ac,v 1.1 1999/06/08 09:27:27 sakamoto Exp $
|
||||
|
||||
--- Makefile.in.orig Tue Jun 8 10:04:26 1999
|
||||
+++ Makefile.in Tue Jun 8 10:08:26 1999
|
||||
@@ -60,9 +60,9 @@
|
||||
exec_prefix=$(prefix)
|
||||
|
||||
# Prefix for installed program, normally empty or `g'.
|
||||
-binprefix=
|
||||
+binprefix=j
|
||||
# Prefix for installed man page, normally empty or `g'.
|
||||
-manprefix=
|
||||
+manprefix=j
|
||||
|
||||
# Where to install executables.
|
||||
bindir=$(exec_prefix)/bin
|
||||
@@ -100,7 +100,7 @@
|
||||
cd $(bindir); $(LN) $(binprefix)grep $(binprefix)egrep
|
||||
rm -f $(bindir)/$(binprefix)fgrep
|
||||
cd $(bindir); $(LN) $(binprefix)grep $(binprefix)fgrep
|
||||
- $(INSTALL_DATA) $(srcdir)/grep.man $(mandir)/grep.$(manext)
|
||||
+ $(INSTALL_DATA) $(srcdir)/grep.man $(mandir)/$(manprefix)grep.$(manext)
|
||||
|
||||
check:
|
||||
AWK=$(AWK) sh $(srcdir)/tests/check.sh $(srcdir)/tests
|
|
@ -1,5 +1,7 @@
|
|||
bin/grep
|
||||
bin/egrep
|
||||
bin/fgrep
|
||||
@comment $NetBSD: PLIST,v 1.2 1999/06/08 09:27:28 sakamoto Exp $
|
||||
bin/jgrep
|
||||
bin/jegrep
|
||||
bin/jfgrep
|
||||
man/man1/jgrep.1
|
||||
share/doc/ja-grep/README.MB
|
||||
@dirrm share/doc/ja-grep
|
||||
|
|
Loading…
Reference in a new issue