Update clex to 3.16.
Patch provided by maintainer, Bartosz Kuzma by PR 36634. 3.16 24-APR-2007 Problems fixed: - filter in the file panel could leave the counter of selected files in an inconsistent state. This could lead to problems in other functions that were using the counter. The problem existed only on some systems 3.15 14-AUG-2006 Problems fixed: - the tilde expansion in the internal cd (change directory) command did not work in CLEX 3.14, the problem has been corrected - the usage of the <del> key in the history panel has been corrected: press <del> to delete the character from the command line and press <esc> <del> to delete the entry from the panel - the situation when some external command crashes and leaves the non-blocking flag set on standard input is now properly handled New/improved functionality: - the locate file function was replaced by a more efficient panel filter mechanism. The filtering is available in several panel types (ctrl-F) - some key bindings has been redefined for compatibility reasons: old new move cursor left to next word ctrl-B --> alt-B move cursor right to next word ctrl-W --> alt-F delete word ctrl-D --> alt-D directory panel alt-D --> alt-W bookmark panel alt-B --> alt-K delete until the end of the line ctrl-Y -> ctrl-K complete from the command history ctrl-K --> alt-P main function menu ctrl-G --> alt-M insert the full filename <esc> <tab> -> ctrl-A - (for emacs users) ctrl-G has now the same meaning as ctrl-C (cancel) - user and group names longer than 8 characters were silently truncated in the file panel, such names are now displayed using the '>' mark - user (alt-U) and group (alt-G) information panels have been added - new panel (<esc> <tab>) that summarizes all completion and insertion functions has been added. Type of the completion can be specified using this panel - completion of commands from the history utilizes the same user interface as the name completion - changes made in the bookmark manager can be cancelled - the input line of the directory panel has no longer precedence over the panel contents. You can switch the focus (indicated by cursor bar's visibility) from the input line to the panel and back - it is no longer possible to execute commands directly from within the history panel. It was easy to make a mistake there and execute other command than intended (panel vs input line) - characters '!' and ':' are automatically quoted only if your shell is a C-shell - there is yet another new option in the directory compare panel - configuration parameter SHELLPROG: standard option -c <COMMAND> is appended automatically if it is not specified - configuration parameters CMD_Fn: command parameters $c and $S have been added (cursor position and selected files) - configuration parameters LAYOUTn: there are two new fields: $S and $P (alternative forms of file size and permissions)
This commit is contained in:
parent
4103c8cd39
commit
c34d565a64
5 changed files with 24 additions and 24 deletions
|
@ -1,11 +1,11 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2005/12/01 03:54:26 minskim Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2007/07/12 12:43:20 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= clex-3.14
|
||||
DISTNAME= clex-3.16
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://www.clex.sk/download/
|
||||
|
||||
MAINTAINER= bartosz@atom.eu.org
|
||||
MAINTAINER= bartosz.kuzma@gmail.com
|
||||
HOMEPAGE= http://www.clex.sk/download/
|
||||
COMMENT= File manager with a full-screen user interface
|
||||
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
$NetBSD: distinfo,v 1.2 2006/01/13 15:16:14 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.3 2007/07/12 12:43:20 obache Exp $
|
||||
|
||||
SHA1 (clex-3.14.tar.gz) = 8ed56610d2e6bb8db9af5ddbcc44b289d1b2d97c
|
||||
RMD160 (clex-3.14.tar.gz) = a23df661efa0451bd6cf1db31f9254354cee5b73
|
||||
Size (clex-3.14.tar.gz) = 178492 bytes
|
||||
SHA1 (clex-3.16.tar.gz) = e92c5c596fead2cf09c22cd484b3bbff536c58e0
|
||||
RMD160 (clex-3.16.tar.gz) = 69ab253a9c451559cc4db1650ef13b24ecccbd2c
|
||||
Size (clex-3.16.tar.gz) = 186313 bytes
|
||||
SHA1 (patch-aa) = b6cd477159c3b2279f1d9d3f8dc04709115de57c
|
||||
SHA1 (patch-ab) = 0b6e36eca7ab1bc85af0a488d6d8be97f52480d5
|
||||
SHA1 (patch-ac) = 862553bf1f4a2c401e19fa8c07d24ee6a2924ca8
|
||||
SHA1 (patch-ad) = 063164741ab69827fcf95be7c70280d276b44721
|
||||
SHA1 (patch-ac) = f658ab8f033f60f49d5f0a2e2982a60d961a61fa
|
||||
SHA1 (patch-ad) = 318d238e46ce31102f83d9857e6f61fb671ad58b
|
||||
SHA1 (patch-ae) = 0c72744fde6b0315941396b0a62281cccb49e4dd
|
||||
SHA1 (patch-af) = 1532776758559542bdecc86b720ce2900c107867
|
||||
SHA1 (patch-ag) = 3791004513e333648ab95fbb8617a2d9314771ef
|
||||
SHA1 (patch-ag) = ee108f63473474f7af42e25e158a22a49f0a764d
|
||||
SHA1 (patch-ah) = 21ed59c002e0a99df1091e04775807ad2b6b9a29
|
||||
SHA1 (patch-ai) = be0490fc358c252ef953d71f520efd641f7ac46f
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-ac,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2007/07/12 12:43:21 obache Exp $
|
||||
|
||||
--- src/completion.c.orig 2006-01-13 14:56:31.000000000 +0000
|
||||
--- src/completion.c.orig 2007-04-24 08:58:51.000000000 +0200
|
||||
+++ src/completion.c
|
||||
@@ -115,8 +115,6 @@ static struct {
|
||||
static int cc_alloc = 0; /* max number of candidates in CC_LIST */
|
||||
static int cc_max; /* max number of candidates to present */
|
||||
@@ -111,8 +111,6 @@ static int cc_max; /* max number of ca
|
||||
static FLAG done; /* done: completion not possible or
|
||||
full (not partial) name was completed */
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ad,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
||||
$NetBSD: patch-ad,v 1.2 2007/07/12 12:43:21 obache Exp $
|
||||
|
||||
--- src/exec.c.orig 2006-01-13 14:58:05.000000000 +0000
|
||||
--- src/exec.c.orig 2007-04-24 08:59:04.000000000 +0200
|
||||
+++ src/exec.c
|
||||
@@ -50,8 +50,6 @@
|
||||
#include "ustring.h" /* us_copy() */
|
||||
|
@ -9,5 +9,5 @@ $NetBSD: patch-ad,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
|||
-extern int errno;
|
||||
-
|
||||
#define MAX_SHELL_ARGS 8
|
||||
static char *shell_argv[MAX_SHELL_ARGS + 1];
|
||||
static char *shell_argv[MAX_SHELL_ARGS + 2 + 1];
|
||||
static int cmd_index; /* which parameter is the command
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-ag,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
||||
$NetBSD: patch-ag,v 1.2 2007/07/12 12:43:21 obache Exp $
|
||||
|
||||
--- src/list.c.orig 2006-01-13 14:59:27.000000000 +0000
|
||||
--- src/list.c.orig 2007-04-24 08:59:39.000000000 +0200
|
||||
+++ src/list.c
|
||||
@@ -80,8 +80,6 @@
|
||||
*/
|
||||
#define FE_ALLOC_UNIT 128
|
||||
@@ -83,8 +83,6 @@
|
||||
|
||||
#define CACHE_SIZE 24 /* size of cache for user/group name lookups */
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
static time_t now;
|
||||
static FLAG do_a, do_d, do_i, do_l, do_L, do_m, do_M, do_o, do_p, do_s;
|
||||
static FLAG do_a, do_d, do_i, do_l, do_L, do_m, do_M, do_o, do_s;
|
||||
static FLAG clock24, use_pathname = 0;
|
||||
|
|
Loading…
Reference in a new issue