hugin: fix build with exiv2 0.28

This commit is contained in:
wiz 2023-07-19 07:17:47 +00:00
parent fa70e250cf
commit c34dcddc4c
4 changed files with 82 additions and 5 deletions

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.29 2023/01/12 08:08:36 adam Exp $
$NetBSD: distinfo,v 1.30 2023/07/19 07:17:47 wiz Exp $
BLAKE2s (hugin-2022.0.0.tar.bz2) = e6d9ce2ec7edee976ab29b8355e470850eb0f422ee3df464d7f01f684b89698c
SHA512 (hugin-2022.0.0.tar.bz2) = 752bdaaea666a24bddc72b4aa4ccfbf366af30022102a2e74fad9c86045b3aeae50929a8a3eb27e296b27bdb487ecd60b6e363b23413e08af6ed944686569c97
Size (hugin-2022.0.0.tar.bz2) = 10374360 bytes
SHA1 (patch-CMakeLists.txt) = 94e087f3eeab899a6dad701cc4d8a95414a980df
SHA1 (patch-CMakeLists.txt) = f46fbe2c618ec1c1ecc9906d41b1640c73bda5bf
SHA1 (patch-CMakeModules_FindPNG.cmake) = 811fd3cf6f819b31129e1560cd8acd1f7ee6defc
SHA1 (patch-doc_deghosting_mask.pod) = fe5462b10966420b0cf3fab004854d9dab3bfb4f
SHA1 (patch-src_hugin1_base__wx_wxPanoCommand.cpp) = d5bf8f747ae86338e728c472d3dc04bf4c84f182
@ -11,6 +11,8 @@ SHA1 (patch-src_hugin1_calibrate__lens_LensCalFrame.cpp) = 9b815a681317cb19880e7
SHA1 (patch-src_hugin1_hugin_CPEditorPanel.cpp) = d373c00d4783b3edc1bad5a67339163a0c23d8c5
SHA1 (patch-src_hugin1_hugin_GLPreviewFrame.cpp) = 0b1396f4a45a5ab6529c0b8c64ff291a021226c4
SHA1 (patch-src_hugin1_ptbatcher_BatchFrame.cpp) = 51ce24f1eb99cc5c0151758299eb1ecc34128171
SHA1 (patch-src_hugin__base_panodata_Exiv2Helper.cpp) = a6d19f020750d3ee78c6960a5f2a0ef2b4c915fb
SHA1 (patch-src_hugin__base_panodata_SrcPanoImage.cpp) = c1bd95da3df2afd2eb8b6372c80fa4423dbac934
SHA1 (patch-src_hugin__script__interface_hsi.i) = b11a52579fd12fdf7c51fef63049d285cb2b52e1
SHA1 (patch-src_tools_align_image_stack.cpp) = fc2759f0722365d4c5339c5c8bc1eda1a6bf7a71
SHA1 (patch-src_tools_tca__correct.cpp) = 73a86d3086336f168de5fb1cc02378a3ecc43104

View file

@ -1,10 +1,10 @@
$NetBSD: patch-CMakeLists.txt,v 1.7 2021/01/09 21:17:37 adam Exp $
$NetBSD: patch-CMakeLists.txt,v 1.8 2023/07/19 07:17:47 wiz Exp $
Do not make an application bundle on OS X.
--- CMakeLists.txt.orig 2020-12-12 11:09:15.000000000 +0000
--- CMakeLists.txt.orig 2022-12-18 09:05:39.000000000 +0000
+++ CMakeLists.txt
@@ -558,16 +558,6 @@ IF (APPLE)
@@ -573,16 +573,6 @@ IF (APPLE)
ENDIF (NOT MAC_SELF_CONTAINED_BUNDLE)
ENDIF (APPLE)

View file

@ -0,0 +1,24 @@
$NetBSD: patch-src_hugin__base_panodata_Exiv2Helper.cpp,v 1.3 2023/07/19 07:17:47 wiz Exp $
Fix build with exiv2 0.28.
--- src/hugin_base/panodata/Exiv2Helper.cpp.orig 2019-05-15 15:30:47.000000000 +0000
+++ src/hugin_base/panodata/Exiv2Helper.cpp
@@ -40,7 +40,7 @@ namespace HuginBase
Exiv2::ExifData::iterator itr = exifData.findKey(Exiv2::ExifKey(keyName));
if (itr != exifData.end() && itr->count())
{
- value = itr->toLong();
+ value = itr->toInt64();
return true;
}
else
@@ -165,7 +165,7 @@ namespace HuginBase
{
if(it!=exifData.end() && it->count())
{
- return it->toLong();
+ return it->toInt64();
}
return 0;
};

View file

@ -0,0 +1,51 @@
$NetBSD: patch-src_hugin__base_panodata_SrcPanoImage.cpp,v 1.3 2023/07/19 07:17:47 wiz Exp $
Fix build with exiv2 0.28.
--- src/hugin_base/panodata/SrcPanoImage.cpp.orig 2022-05-26 16:18:56.000000000 +0000
+++ src/hugin_base/panodata/SrcPanoImage.cpp
@@ -384,7 +384,7 @@ bool SrcPanoImage::readEXIF()
pos = xmpData.findKey(Exiv2::XmpKey("Xmp.GPano.CroppedAreaImageWidthPixels"));
if (pos != xmpData.end())
{
- croppedWidth = pos->toLong();
+ croppedWidth = pos->toInt64();
}
else
{
@@ -394,7 +394,7 @@ bool SrcPanoImage::readEXIF()
pos = xmpData.findKey(Exiv2::XmpKey("Xmp.GPano.CroppedAreaImageHeightPixels"));
if (pos != xmpData.end())
{
- croppedHeight = pos->toLong();
+ croppedHeight = pos->toInt64();
}
else
{
@@ -408,7 +408,7 @@ bool SrcPanoImage::readEXIF()
double hfov = 0;
if (pos != xmpData.end())
{
- hfov = 360 * croppedWidth / (double)pos->toLong();
+ hfov = 360 * croppedWidth / (double)pos->toInt64();
}
else
{
@@ -419,7 +419,7 @@ bool SrcPanoImage::readEXIF()
pos = xmpData.findKey(Exiv2::XmpKey("Xmp.GPano.FullPanoHeightPixels"));
if (pos != xmpData.end())
{
- fullHeight = pos->toLong();
+ fullHeight = pos->toInt64();
}
else
{
@@ -430,7 +430,7 @@ bool SrcPanoImage::readEXIF()
pos = xmpData.findKey(Exiv2::XmpKey("Xmp.GPano.CroppedAreaTopPixels"));
if (pos != xmpData.end())
{
- cropTop = pos->toLong();
+ cropTop = pos->toInt64();
}
else
{