No utmp.h on modern FreeBSD, use utmpx.h instead.
This commit is contained in:
parent
1f9efbd97d
commit
c35ff52027
3 changed files with 35 additions and 6 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.14 2008/09/19 19:39:22 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.15 2013/12/17 06:45:40 asau Exp $
|
||||
|
||||
SHA1 (clusterit-2.5.tar.gz) = 65d36116665179dd16029ac53182fde92d868020
|
||||
RMD160 (clusterit-2.5.tar.gz) = b08f7903bc90375e45a733ef843df3e9bf216bb7
|
||||
|
@ -7,5 +7,6 @@ SHA1 (patch-aa) = 15b4db813a8cb91b2c2ac277297fe4394637e804
|
|||
SHA1 (patch-ab) = 32a8efdbf45226a7ec1a7a190ff7fae9e2bfe2ae
|
||||
SHA1 (patch-ac) = d3c66a9f8e48fbc0e3471de71d91b7601400f74b
|
||||
SHA1 (patch-ad) = 01935f2e2e2d308a148c26186e04912ad6c8d88d
|
||||
SHA1 (patch-ae) = d3cb2da90a7b4ee9d027c4ccd63d549cdbe48a73
|
||||
SHA1 (patch-ae) = 3956e89d1e0b35bbb83db74879f1ce03f70a99ad
|
||||
SHA1 (patch-af) = d699f909af6af13b492e21907cdb4216664b9169
|
||||
SHA1 (patch-rvt_ttyinit.c) = 00f433d7ca7da0819a38abcf9fe687913e231109
|
||||
|
|
|
@ -1,8 +1,20 @@
|
|||
$NetBSD: patch-ae,v 1.2 2008/02/27 21:52:16 garbled Exp $
|
||||
$NetBSD: patch-ae,v 1.3 2013/12/17 06:45:40 asau Exp $
|
||||
|
||||
--- rvt/command.c.orig 2008-02-27 14:35:55.000000000 -0700
|
||||
+++ rvt/command.c 2008-02-27 14:37:56.000000000 -0700
|
||||
@@ -453,7 +453,6 @@
|
||||
--- rvt/command.c.orig 2008-02-27 19:29:48.000000000 +0000
|
||||
+++ rvt/command.c 2013-12-17 06:36:55.670505584 +0000
|
||||
@@ -41,7 +41,11 @@
|
||||
#include <unistd.h>
|
||||
#include <signal.h>
|
||||
#include <fcntl.h>
|
||||
+#if defined(__FreeBSD__)
|
||||
+#include <utmpx.h>
|
||||
+#else
|
||||
#include <utmp.h>
|
||||
+#endif
|
||||
#include <errno.h>
|
||||
#include <string.h>
|
||||
#include "rvt.h"
|
||||
@@ -453,7 +457,6 @@
|
||||
unsigned char *s;
|
||||
int count, sv;
|
||||
unsigned char mask = is_eightbit() ? 0xff : 0x7f;
|
||||
|
|
16
parallel/clusterit/patches/patch-rvt_ttyinit.c
Normal file
16
parallel/clusterit/patches/patch-rvt_ttyinit.c
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-rvt_ttyinit.c,v 1.1 2013/12/17 06:45:40 asau Exp $
|
||||
|
||||
--- rvt/ttyinit.c.orig 2007-01-24 19:02:10.000000000 +0000
|
||||
+++ rvt/ttyinit.c 2013-12-17 06:40:04.802505132 +0000
|
||||
@@ -41,7 +41,11 @@
|
||||
#include <unistd.h>
|
||||
#include <signal.h>
|
||||
#include <fcntl.h>
|
||||
+#if defined(__FreeBSD__)
|
||||
+#include <utmpx.h>
|
||||
+#else
|
||||
#include <utmp.h>
|
||||
+#endif
|
||||
#include <grp.h>
|
||||
#include <pwd.h>
|
||||
#include <errno.h>
|
Loading…
Reference in a new issue