gemrb: fix broken patch

This commit is contained in:
nia 2021-06-21 14:02:47 +00:00
parent 22afd6b1ea
commit c3774afa43
2 changed files with 5 additions and 6 deletions

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.4 2021/06/06 16:59:51 nia Exp $
$NetBSD: distinfo,v 1.5 2021/06/21 14:02:47 nia Exp $
SHA1 (gemrb-0.8.8.tar.gz) = 62e5e19e2cd6f2c2ce5d14a23637aaa78c6ce95a
RMD160 (gemrb-0.8.8.tar.gz) = c88ce8b2c604f297fa205390a21fda5f96006593
SHA512 (gemrb-0.8.8.tar.gz) = 9425d68b931663e25b449386266d0409141f40da0e79513aa52c52e3f0f8c81f14b498d816e6b8dd86ce7948b22ad94128b700c013706bf808c7f1e58f734758
Size (gemrb-0.8.8.tar.gz) = 13918948 bytes
SHA1 (patch-gemrb_core_System_String.cpp) = 3e692b69a3a334050cb10400fce276893143dd57
SHA1 (patch-gemrb_core_System_String.cpp) = ffdaaed3ffac3048bdfc8eb4b951b497b896f613
SHA1 (patch-gemrb_plugins_TTFImporter_TTFFont.cpp) = 5d21363e3b1957f96bf20f4229ebe529909bc3da

View file

@ -1,10 +1,10 @@
$NetBSD: patch-gemrb_core_System_String.cpp,v 1.2 2021/06/06 16:59:51 nia Exp $
$NetBSD: patch-gemrb_core_System_String.cpp,v 1.3 2021/06/21 14:02:47 nia Exp $
Deal with old NetBSD/SunOS style iconv.
--- gemrb/core/System/String.cpp.orig 2021-06-02 16:16:47.000000000 +0000
+++ gemrb/core/System/String.cpp
@@ -31,6 +31,16 @@
@@ -31,6 +31,15 @@
#include <iconv.h>
#endif
@ -16,12 +16,11 @@ Deal with old NetBSD/SunOS style iconv.
+#define NETBSD_POSIX_ICONV 0
+#endif /* __NetBSD_Prereq__(9,99,17) */
+#endif /* defined(__NetBSD__) */
+#endif
+
namespace GemRB {
static String* StringFromEncodedData(const ieByte* string, const EncodingStruct& encoded)
@@ -123,7 +133,11 @@ char* ConvertCharEncoding(const char* st
@@ -123,7 +132,11 @@ char* ConvertCharEncoding(const char* st
size_t out_len_left = out_len;
char* buf = (char*) malloc(out_len);
char* buf_out = buf;