exifprobe: switch master site to github (new maintainer)

This commit is contained in:
tnn 2022-08-19 01:01:28 +00:00
parent b6eac70edc
commit c3783072d5
4 changed files with 45 additions and 41 deletions

View File

@ -1,21 +1,21 @@
# $NetBSD: Makefile,v 1.8 2019/11/02 22:37:55 rillig Exp $
# $NetBSD: Makefile,v 1.9 2022/08/19 01:01:28 tnn Exp $
#
DISTNAME= exifprobe-2.0.1
DISTNAME= exifprobe-2.1.0.20201230
CATEGORIES= graphics
MASTER_SITES= http://www.virtual-cafe.com/~dhh/tools.d/exifprobe.d/
MASTER_SITES= ${MASTER_SITE_GITHUB:=hfiguiere/}
GITHUB_TAG= eee65ff3c62fed3fff35e690230820bd80c90381
MAINTAINER= pkgsrc-users@NetBSD.org
#HOMEPAGE= http://www.virtual-cafe.com/~dhh/tools.d/exifprobe.d/exifprobe.html
HOMEPAGE= https://github.com/hfiguiere/exifprobe
COMMENT= EXIF data extractor
LICENSE= modified-bsd
# byteorder.h problems
MAKE_JOBS_SAFE= no
CFLAGS.SunOS+= -Du_int32_t=uint32_t
INSTALL_MAKE_FLAGS+= BINDIR=${DESTDIR}${PREFIX}/bin \
MANDIR=${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
INSTALLATION_DIRS+= bin ${PKGMANDIR}/man1
INSTALL_MAKE_FLAGS= MANDIR=${PREFIX}/${PKGMANDIR}/man1
.include "../../mk/bsd.pkg.mk"

View File

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.5 2021/10/26 10:46:06 nia Exp $
$NetBSD: distinfo,v 1.6 2022/08/19 01:01:28 tnn Exp $
BLAKE2s (exifprobe-2.0.1.tar.gz) = 4e73d97dfed00e74566aff0545c24eaa0500b8817868e080eea58c4f0d372a70
SHA512 (exifprobe-2.0.1.tar.gz) = 55ac89382539274eb5d5437807f87578cf3898afd5cb5068c8ed71c82a91ec90afac6ae7ae7a4400d7bf9fbc5d37dc6e16d873a4bc413aae5c1d65506ae3fdc6
Size (exifprobe-2.0.1.tar.gz) = 261568 bytes
SHA1 (patch-Makefile) = 1f846256b198ce0b2a9418111fe0a6fab773bc67
SHA1 (patch-aa) = 40e6d887505790de6d4e57c66298534e0e130fa3
BLAKE2s (exifprobe-2.1.0.20201230-eee65ff3c62fed3fff35e690230820bd80c90381.tar.gz) = 70f71f3f8be2145842d8e8c1b9650e98a62d82940ec9f18071b502e6adf71f56
SHA512 (exifprobe-2.1.0.20201230-eee65ff3c62fed3fff35e690230820bd80c90381.tar.gz) = 995a6dc2a723b06763419b4922fd73c0341e4909672ceffc1e303ce031e03cfa7015daae20a594ed3c6d9cbe7bce9fb56bdc443514330bb073411af2d9e1e75a
Size (exifprobe-2.1.0.20201230-eee65ff3c62fed3fff35e690230820bd80c90381.tar.gz) = 271784 bytes
SHA1 (patch-Makefile) = dfd89c847a3f556d0745b6e3b652924e816da500

View File

@ -1,17 +1,38 @@
$NetBSD: patch-Makefile,v 1.1 2013/12/10 11:41:43 jperkin Exp $
$NetBSD: patch-Makefile,v 1.2 2022/08/19 01:01:29 tnn Exp $
Use compiler wrapper and support additional CFLAGS.
support DESTDIR installation properly
--- Makefile.orig 2005-07-25 22:15:49.000000000 +0000
--- Makefile.orig 2020-12-30 18:17:52.000000000 +0000
+++ Makefile
@@ -2,8 +2,8 @@
# Makefile for EXIFPROBE image file probe
@@ -23,9 +23,9 @@ CFLAGS+=-DCOLOR -O -std=c99
# Any compiler should do
-CC=cc
-CFLAGS=-DCOLOR -O
+#CC=cc
+CFLAGS+=-DCOLOR
# On Solaris, you may need to use 'gmake', or edit the next line.
INSTALL = install -d -m 644
-PREFIX ?= $(DESTDIR)/usr
-BINDIR=$(PREFIX)/bin/local
-MANDIR=$(PREFIX)/share/man/man1
+PREFIX ?= /usr
+BINDIR?=$(PREFIX)/bin
+MANDIR?=$(PREFIX)/share/man/man1
# You probably don't need these
# CFLAGS=-DCOLOR -g -O -Dlint -Wall -Wno-long-long
INCLUDES=defs.h extern.h misc.h tifftags.h exiftags.h \
tiffeptags.h jpegtags.h global.h
@@ -71,12 +71,12 @@ exifprobe: $(OBJS) $(INCLUDES) Makefile
$(CC) -o exifprobe $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) $(OBJS) comptime.c -lm
install: all
- install -d $(PREFIX)/bin
- install -d $(PREFIX)/share/man/man1
- install -c -m 755 exifprobe $(PREFIX)/bin
- install -c -m 755 exifgrep $(PREFIX)/bin
- install -c -m 644 exifprobe.1 $(PREFIX)/share/man/man1
- install -c -m 644 exifgrep.1 $(PREFIX)/share/man/man1
+ install -d $(DESTDIR)$(BINDIR)
+ install -d $(DESTDIR)$(MANDIR)
+ install -c -m 755 exifprobe $(DESTDIR)$(BINDIR)
+ install -c -m 755 exifgrep $(DESTDIR)$(BINDIR)
+ install -c -m 644 exifprobe.1 $(DESTDIR)$(MANDIR)
+ install -c -m 644 exifgrep.1 $(DESTDIR)$(MANDIR)
# if you want HTML man pages, pick a target; I prefer man2html
rman: exifprobe.1 exifgrep.1

View File

@ -1,16 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/10/21 17:17:08 drochner Exp $
*** makebyteorder.sh.orig Wed Jul 27 12:31:35 2005
--- makebyteorder.sh Wed Jul 27 12:33:58 2005
***************
*** 3,5 ****
! if test -f /usr/include/machine/endian.h
then
--- 3,8 ----
! if test -f /usr/include/machine/endian_machdep.h
! then
! byteorder=`grep BYTE_ /usr/include/machine/endian_machdep.h`
! elif test -f /usr/include/machine/endian.h
then