Fix build with editline.

This commit is contained in:
joerg 2013-07-18 12:03:52 +00:00
parent 836166a765
commit c3852e3198
2 changed files with 27 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.6 2013/07/12 13:37:38 ryoon Exp $
$NetBSD: distinfo,v 1.7 2013/07/18 12:03:52 joerg Exp $
SHA1 (newlisp-10.5.3.tgz) = dc02542ebb5b2ee2685e51f988a742c4294d14c3
RMD160 (newlisp-10.5.3.tgz) = 789d4a2ed590326e01ad5379d4288952e53d4834
Size (newlisp-10.5.3.tgz) = 1631742 bytes
SHA1 (patch-configure-alt) = f8669b8432fe460af18d0f2d3d1135debfd74654
SHA1 (patch-newlisp.c) = 0ec358377dcae961d89fbbf00474e2feda3f53ae

View file

@ -0,0 +1,25 @@
$NetBSD: patch-newlisp.c,v 1.1 2013/07/18 12:03:52 joerg Exp $
--- newlisp.c.orig 2013-07-18 09:58:06.000000000 +0000
+++ newlisp.c
@@ -886,7 +886,7 @@ if(errorReg && !isNil((CELL*)errorEvent-
#ifdef READLINE
rl_readline_name = "newlisp";
rl_attempted_completion_function = (CPPFunction *)newlisp_completion;
-#if defined(LINUX) || defined(_BSD)
+#if defined(LINUX)
/* in Bash .inputrc put 'set blink-matching-paren on' */
rl_set_paren_blink_timeout(300000); /* 300 ms */
#endif
@@ -965,11 +965,7 @@ while((name = primitive[list_index].name
return ((char *)NULL);
}
-#ifdef _BSD
-extern char **completion_matches PARAMS((char *, rl_compentry_func_t *));
-#else
char ** completion_matches(const char * text, CPFunction commands);
-#endif
char ** newlisp_completion (char * text, int start, int end)
{